the sx20 porting thread - page 126 - General Discussion and Assistance - CHDK Forum supplierdeeply

the sx20 porting thread

  • 1286 Replies
  • 388677 Views
*

Offline jan

  • *
  • 48
  • PowerShot SX20 IS (100f)
    • cms -db
Re: the sx20 porting thread
« Reply #1250 on: 25 / April / 2011, 14:34:03 »
Advertisements
The Version in the attachment "sx20-100f-0.9.9-1160-full.zip" i built with the following steps:
(...)
This changes i made "blindly". I can not test it.
So please test and try out this version and give me feedback how it works.

This version works very well for me. The only problem I could after some testing is that the camera just turns off sometimes, but I can't find any pattern. This problem existed with older CHDK builds as well.

*

Offline f_m_b

  • **
  • 71
Re: the sx20 porting thread
« Reply #1251 on: 25 / April / 2011, 15:16:52 »
This version works very well for me. The only problem I could after some testing is that the camera just turns off sometimes, but I can't find any pattern. This problem existed with older CHDK builds as well.
Thanks for your test report. Sounds fine to me.

I know only one sequence which produce this error you described: Try to shoot a picture while making a movie with the cam.

Well... i think you are going to test more... and maybe you find some more "pattern".
Greetings Frank
SX20 (1.02b)

*

Offline jan

  • *
  • 48
  • PowerShot SX20 IS (100f)
    • cms -db
Re: the sx20 porting thread
« Reply #1252 on: 25 / April / 2011, 16:10:01 »
I know only one sequence which produce this error you described: Try to shoot a picture while making a movie with the cam.

Actually this works fine for me. But I'll try to find a way to reproduce the problem if it occurs again.

Re: the sx20 porting thread
« Reply #1253 on: 27 / April / 2011, 14:10:32 »
This is a request to SX20 developers:
Please tell 1.00f users what kind of additional testing is needed/required in order to make the 1.00f beta release a stable one and published also in the autobuild download section.

Thanks in advance
Hello baxev2005

let's start with this test. ;-)
Now the files for 1.00f.


Thank you for your fast response. From my side I had an unexpected trip away home and only today I was able to read your answer. I already downloaded and testing


*

Offline f_m_b

  • **
  • 71
Re: the sx20 porting thread
« Reply #1254 on: 27 / April / 2011, 16:39:56 »
I already downloaded and testing
Hello baxev2005.
That's fine. I hope you have downloaded the test version from there: Link
« Last Edit: 27 / April / 2011, 16:44:28 by f_m_b »
Greetings Frank
SX20 (1.02b)

Re: the sx20 porting thread
« Reply #1255 on: 01 / May / 2011, 14:39:49 »
Is the getmeminfo in the new 1165 changeset also implemented for the sx20?

what are the benefits exactly....and could it help with making exmem work with the sx20?  curiosity makes me ask...
sx20is 1.02d

*

Offline reyalp

  • ******
  • 13749
Re: the sx20 porting thread
« Reply #1256 on: 01 / May / 2011, 14:44:10 »
Is the getmeminfo in the new 1165 changeset also implemented for the sx20?
The function is found with a 100% match.

Quote
what are the benefits exactly...
None at all right now. It's just putting some pieces in place.
Quote
.and could it help with making exmem work with the sx20?  curiosity makes me ask...
No, it lets us find out how much heap the Canon firmware has free (and some other possibly useful statistics)
Don't forget what the H stands for.

Re: the sx20 porting thread
« Reply #1257 on: 01 / May / 2011, 15:12:26 »
Sounds good

thanks for the reply reyalp.
sx20is 1.02d


Re: the sx20 porting thread
« Reply #1258 on: 07 / May / 2011, 16:44:05 »
I've also tested the release from here and it works (firmware 1.00f).

a) badpixels.bin generation works on camera, and I've created the other badpixels (standalone) file outside the camera. After setting info in the menu, it works.
b) grids work.
c) both histogram and the other that shows the overexposed areas work (I tested out of curiosity, since I do not use them anyway).
d) Fiddled around - all ok.
d) I've tested the ultra intervalometer script and made a short video here:

http://www.youtube.com/watch?v=NZqzea4X4pE#

For me the most important feature is the bad pixels removal and it does the job.

PS: Not related to the firmware but to the Wiki pages. Some links to the show_bad.zip and show_bad_b.zip return a 404 - but if you type them directly - they work. This address for example:
Code: [Select]
http://chdk.wikia.com/index.php?title=Special:Outbound&f=Badpixel_removal&u=http%3A%2F%2Fewavr.nm.ru%2Fchdk%2Fshow_bad_b.zip

*

Offline f_m_b

  • **
  • 71
Re: the sx20 porting thread
« Reply #1259 on: 13 / May / 2011, 15:02:20 »
I've also tested the release from here and it works (firmware 1.00f).
Hello viulian
nice to hear that. :)

Nice Time Lapse: You wan't to give up smoking, and this was your last cigarette? ;)

If the final test results from jan, phaedra and baxev2005 are although fine i think we can mark the 1.00f as stable and reyalp (or other admin) can check in the patch.
Greetings Frank
SX20 (1.02b)

 

Related Topics