the sx20 porting thread - page 111 - General Discussion and Assistance - CHDK Forum  

the sx20 porting thread

  • 1279 Replies
  • 308475 Views
Re: the sx20 porting thread
« Reply #1100 on: 28 / January / 2011, 16:14:36 »
Advertisements
Thank guys for help and for tips))

Re: the sx20 porting thread
« Reply #1101 on: 28 / January / 2011, 17:03:05 »
I must be really stupid or there is something I really don't understand but all of this talk about Raw, DNG, CRW and all really has nothing to do with all of these crashes (for me anyway). If I go with the experience that I have with all those crashes, Raw was never ever enabled in any of the crash but the camera crashed anyway. Like I said previously and I will say it again....I have stopped having these crashes ever since I start the camera with the start button and holding it for a period of approximately 1.5 seconds.

Sorry if I can't be of any help to you guys but all this talk about Raw being at fault, I thought I should let you know that in my case, that was never even turned on at the time of the crash.
« Last Edit: 29 / January / 2011, 06:25:03 by wowsers51 »
SX20 1.02d

Re: the sx20 porting thread
« Reply #1102 on: 28 / January / 2011, 19:10:01 »
hey wowsers...
just to let you know, the conversation went away from any talk of crashes.
Oskar had some other questions (about the raw) that didn't have to do with the crashes...
he was asking for some assistance that.
sx20is 1.02d

Re: the sx20 porting thread
« Reply #1103 on: 28 / January / 2011, 19:40:16 »
Sometimes the camera doesnt  turn on correctly.The are many bugs( It is an alfa version i think not beta and not the final...

Sorry but when I saw this, I thought it was related. My bad I guess.

**Edit**
He does have crash problems. By holding the start button longer, it cures the problem...just like I experience. Read Oskar latest post. 8)
« Last Edit: 29 / January / 2011, 06:29:10 by wowsers51 »
SX20 1.02d


*

Offline whim

  • ******
  • 2023
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: the sx20 porting thread
« Reply #1104 on: 28 / January / 2011, 20:05:53 »
Quote
I must be really stupid or there is something I really don't understand ...

Wouldn't worry if I were you ... in 50+ years I've never seen/heard a stupid person write/say that  ;)

sorry for O/T,

wim

Re: the sx20 porting thread
« Reply #1105 on: 29 / January / 2011, 05:45:43 »
I must be really stupid or there is something I really don't understand but all of this talk about Raw, DNG, CRW and all really has nothing to do with all of these crashes (for me anyway). If I go with the experience that I have with all those crashes, Raw was never ever enabled in any of the crash but the camera crashed anyway. Like I said previously and I will say it again....I have stopped having these crashes ever since I start the camera with the start button and holding it for a period of approximately 1..5 seconds.

Sorry if I can't be of any help to you guys but all this talk about Raw being at fault, I thought I should let you know that in my case, that was never even turned on at the time of the crash.
I have the same problem, push quik on the button the scrensaver is turns on and than camera is crashes-turn off. If i hold the button for a second its normaly works...
Another problem option save raw with jpg- It always create a new folder and doesnt show shots- just say that there is no foto... I think evrybody have this problem...
And problem about acselerometr it doesnt work correctly....
Next/ sometimes chdk menu simply crach/ if acselerometr rotate foto chdk menu scips/ if i push "menu" to exit from chdk alt is on but it doesnt show it, and i push shot and begins problems/
« Last Edit: 29 / January / 2011, 05:59:43 by OskarDaimon »

*

Offline SkyWalker9

  • ****
  • 301
  • SX20 IS (fw 1.02b)
Re: the sx20 porting thread
« Reply #1106 on: 02 / February / 2011, 13:36:53 »
I posted a script recently that identifies several of the PropCas IDs for the SX20 (http://chdk.setepontos.com/index.php?topic=6065.msg60450#msg60450 ). I'm going to post all of the ones I have found and verified so far, and hope that some of you may have found some more as well. Eventually, after we have enough they can be posted on the PropCas web page.

PropID  Description
------  -------------------------------------------------------------------------------------------
5   AF Assist Beam Setting (0=OFF, 1=ON)

8   AF Frame
   1   Flexzone
   2   Face Detect

12   Continuous AF (0=OFF, 1=ON)

26   av96

34   bv96

50   Mode Dial setting
   8228   Custom
   -32767   Manual
   -32766   Av
   -32765   Tv
   -32764   Program
   -32768   Auto
   -32755   Portrait
   -32756   Landscape
   -32757   Night Snapshot
   -32249   Sports
   16402   Sunset
   -32246   Stitch Assist
   2600   Movie

66   Date stamp
   0   Off
   1   Date
   2   Date & Time

102   Drive Mode
   0   single
   1   continuous
   2   continuous shooting AF

127   Flash Exposure Compensation (+/- 32, 64, 96, 128, 160, 192 = +/- 1/3, 2/3, 1, 1 1/3, 1 2/3, 2)

133   MF (0=OFF,  1=ON); opposite of AF (i.e if MF=1 then AF=0)

149   ISO (Auto, 80, 100, 200, 400, 800, 1600, 3200 using SCN & mode dial)
   0   Auto
   80   ISO 80
   100   ISO 100
   200   ISO 200
   400   ISO 400
   800   ISO 800
   1600   ISO 1600
   3200   ISO 3200

155   Type of metering
   0   Evaluative
   1   Spot
   2   Center Weighted

169   Video Quality
   1   320x240
   2   640x480
   4   1280x720

209    Exposure Compensation Dial (+/- 32, 64, 96, 128, 160, 192 = +/- 1/3, 2/3, 1, 1 1/3, 1 2/3, 2)

220    Photo resolution/size
   0   Large
   1   Med 1
   2   Med 2
   3   Med 3
   4   Sending email
   8   Wide

249   sv96

266   tv96

270   White Balance
   0   Auto
   1   Daylight
   2   Cloudy
   3   Tungsten
   4   Fluorescent
   5   Fluorescent H
   6   Flash
   7   Custom

281   Safety MF (0=OFF, 1=ON)

282   AF (0=OFF,  1=ON); opposite of MF (i.e if AF=1 then MF=0)

297   Servo AF (0=OFF, 1=ON


Mar 13, 2011 Update: added APEX 96 PropCas IDs for av96, tv96, bv96 and sv96
Apr 11, 2011 Update: added MF (133) and AF (282)

« Last Edit: 12 / April / 2011, 00:57:54 by SkyWalker9 »

Re: the sx20 porting thread
« Reply #1107 on: 12 / February / 2011, 11:01:25 »
Canon SX20 is 1.02b CHDK


Re: the sx20 porting thread
« Reply #1108 on: 12 / February / 2011, 13:29:29 »
Hi Neztron,

Unfortunately, that problem has not been solved yet. Romlog didn't work for me either. It just keep crashing the camera, I would also like to know how others are coping with this issue.

One thing I have noticed is that no new version has been added since January 30th (1054). Usually, there would be a new version every few days so I am wondering if they are working on something to fix these crash or not. But I am not holding my breath about this because no new post has been added since a long time and you were the first today.
« Last Edit: 12 / February / 2011, 13:31:01 by wowsers51 »
SX20 1.02d

Re: the sx20 porting thread
« Reply #1109 on: 12 / February / 2011, 16:56:32 »
Canon SX20 is 1.02b CHDK

 

Related Topics