SX200IS and scripts - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum  

SX200IS and scripts

  • 4 Replies
SX200IS and scripts
« on: 14 / October / 2009, 06:04:00 »
Hey there,

CHDK seems to be working generally well on my SX200IS but I am having "issues" with scripts.

I have only tried one or two simple time lapse scripts, I thought it would be best to try something simple to start with.

I can load the script, the options for the script become available to me, I can change the options it I want to.  I then press the shutter button, which I think invokes the script.  And the camera does not a lot of anything for about 2 seconds and then powers off. The lens does not retract but the screen goes blank and no lights etc.

I don't think this is a feature, so am I missing something?  I used whatever build is on the autobuild server as of yesterday.

Any help would be great.




Offline whim

  • ******
  • 2022
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: SX200IS and scripts
« Reply #1 on: 14 / October / 2009, 07:07:43 »

You'll probably get more/faster help if you include the script that fails for you (with params used)

the camera does not a lot of anything for about 2 seconds
AFAIK, after starting any script you should see it's name/output @bottom left of the screen  ???




Re: SX200IS and scripts
« Reply #2 on: 14 / October / 2009, 13:08:34 »
I have tried 4 or 5 different scripts..  put them in the scripts directory on the SD card and called the first one test.bas

I got the script from here somewhere... but i have put the code below....


rem Author - Keoeeit
rem Written for S-Series
rem Should be okay on others
rem Use Endless mode with caution
rem See documentation for important info
rem updated version
@title Ultra Intervalometer
@param a Delay 1st Shot (Mins)
@default a 0
@param b Delay 1st Shot (Secs)
@default b 0
@param c Number of Shots
@default c 5
@param d Interval (Minutes)
@default d 0
@param e Interval (Seconds)
@default e 1
@param f Interval (10th Seconds)
@default f 0
@param g Endless? No=0 Yes=1
@default g 0

if c<1 then c=5
if t<1 then t=1
if g<0 then g=0
if g>1 then g=1
if p<0 then p=0
get_tv h
if h=-12 then t=t+330
if h=-11 then t=t+270
if h=-10 then t=t+210
if h=-9 then t=t+170
if h=-8 then t=t+130
if h=-7 then t=t+110
if h=-6 then t=t+90
if h=-5 then t=t+70
if h=-4 then t=t+60
if h=-3 then t=t+50
if h=-2 then t=t+40
if h=-1 then t=t+35
if h=0 then t=t+18
if h=1 then t=t+15
if h=2 then t=t+13
if h=3 then t=t+11
if h=4 then t=t+10
if h=5 then t=t+8
if h=6 then t=t+6

print "1 Cycle Time:", x/600; "min", x%600/10; "sec"

goto "interval"

  if p>0 then gosub "pause"
  for n=1 to c
  print "Shot", n, "of", c
  if n>1 then sleep u*100
  next n
  if g=1 then goto "interval" else end

  for m=1 to n
  print "Intvl Begins:", q/60; "min", q%60; "sec"
  sleep 930
  next m

Re: SX200IS and scripts
« Reply #3 on: 20 / November / 2009, 20:54:20 »
i'm also having problems with scripts. Sunset_16.lua says me that i don't have ''util.lua'' but i have it, it doesn't find it. And ultra intervalometer doesn't even let me choose any parameter, from the moment i choose the file, the camera stops working. Do you have this problems also? i really want to make timelapses, anyone know what i can do?

Re: SX200IS and scripts
« Reply #4 on: 01 / January / 2010, 10:24:28 »
I have the same issue with the lightning/motion detection script, I "load it from file" and then the camera becomes somewhat unresponsive, the scripts menu freezes. I had to use my computer to delete the script so that everything would go back to normal.

I realized I did not have the latest version, I downloaded the latest MD script and it works great but this issue still happens with some other scripts.
« Last Edit: 03 / January / 2010, 14:18:26 by Hyphen »


Related Topics