Problems to install CHDK in Canon G7 Powershot - General Help and Assistance on using CHDK stable releases - CHDK Forum

Problems to install CHDK in Canon G7 Powershot

  • 5 Replies
  • 3128 Views
Problems to install CHDK in Canon G7 Powershot
« on: 29 / October / 2009, 08:16:34 »
Advertisements
Hello Im trying to install the CHDK in my canon G7 Powershot and I cannot acces to the OSD of the CHDK and  i couldnt access neither to the splash screen.

I have a mac and a card reader ( Trust brand) , my memory card is  SD 4GB  Extrememory , I used the Alternate scripted method indicated in the wiki for mac users, i achieve to split the card in two partitions CHDK - small fat16 partition and CAMCARD -big partition .

At this point everything goes well, i insert the card to check the firmware and i see that is "1.0.0.i" . I extract the card and put it again in the card reader , I download the small zip for this firmware "g7-100i-0.9.8-824.zip " . I put the two files "DISKBOOT.bin" and "PS.FIR" inside the small partition- CHDK. I lock the card and when i insert the card the camera says me that the card is locked, os i cannot take picture

I unlock the card and i try to upgrade the firmware but i dont find the way in this camera to check the option of upgrade firmware or to access the splash screen.

I dont know if is a problem of the combination of the buttons i have to press in my camera model or if i put the files of the chdk in the wrong partition, i tryed to put them in the big partition but doent work.

Maybe the problem is that i can see the two paritions like if i would wave two different drives, in fact i have to extract from the mac os system the two separately.

Please i hope someone could help me.

Re: Problems to install CHDK in Canon G7 Powershot
« Reply #1 on: 29 / October / 2009, 08:22:14 »
I do not know anything about the Mac but, first of all, do not make two partitions .. just make one.
Then make the card autobootable and transfer the CHDK files to it.
Lock the card and insert into camera.


*

Offline fe50

  • ******
  • 3099
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Problems to install CHDK in Canon G7 Powershot
« Reply #2 on: 29 / October / 2009, 09:10:12 »
Hello & welcome, ruli83 !

1.0.0.i is not your real fw version; please read the Still having trouble ? section on the Mac FAQ wikia page carefully.

- Do not partition your card; format your Card in the camera,
- then expand all files from the CHDK package to the card's root folder
- check whether the files are named correctly

When the file  ps.fi  is stored in the card's root folder, power on the camera IN PLAYBACK mode,
then go to the Canon menu and choose "Firmware Update" (note: this menu item is not visible in record mode or if the lens is expanded !)

If you want to start CHDK automatically, the card must be FAT16 formatted (this is possible up to a card size of 4GB) and
also "CHDK-bootable" ("BOOTDISK" in the MBR, see FAQ); only for cards > 4GB you have to partition the card...

Re: Problems to install CHDK in Canon G7 Powershot
« Reply #3 on: 01 / November / 2009, 18:55:37 »
ok , im still having problems.

I format the card in my camera , then i download the g7-100i-0.9.8-825.zip , i extract the files and put in the card the files named "DISKBOOT.bin" and "PS.FIR" , i start the canon g7 in playback mode ( using the button with the triangle) i go to MENU ( using MENU button) and i check all the tabs in the menu and all the parts of every tab in the menu and i dont find any "firmware update".( the lenses are not expanded and the camera is not in record mode)

I also tryed changing the name of the file "ps.fir" to "ps.fi" before putting it in the camera and it doesnt work neither.

Please, what should i do? , i dont know what im doing wrong.


*

Online reyalp

  • ******
  • 11923
Re: Problems to install CHDK in Canon G7 Powershot
« Reply #4 on: 01 / November / 2009, 19:22:01 »
Don't forget what the H stands for.

Re: Problems to install CHDK in Canon G7 Powershot
« Reply #5 on: 04 / November / 2009, 05:45:14 »
Thanks , now it works , the problem was that i have installed stuffit but it wasnt open the zip files by default , the system was opening the zip files with the unarchive program of macOS.



 

Related Topics