Synch settings get lost (SDM 1.81) - page 4 - General Discussion and Assistance - CHDK Forum supplierdeeply

Synch settings get lost (SDM 1.81)

  • 31 Replies
  • 5483 Views
Re: Synch settings get lost (SDM 1.81)
« Reply #30 on: 04 / November / 2009, 16:20:22 »
Advertisements
Hi Microfunguy,

let me ask, if I got it right now:

enable_synch generaly enables the wait until shutter / usb switch is released, this is clear.

releasing shutter button starts to open shutter on both cams.
Flash of left cam fires immediately with 1/16 power.

if enable_synch_delay is set to enabled, then the flash of right cam gets a delay of max. 40 units (arround 4 msec.).
During this 4 msec. the left cam has time to open shutter completely. So chance is bigger that left cam also gets the flash - with shutter completely opened - am I right?

'Add User and flash delays' has only an effect if I use the 'fine delay' and / or 'coarse delay' - right?

If I set coarse delay to e.g. 50, that means photo is taken 5 sek after is button released - right?
If I set 'Add User and flash delays' to disabled, then the flash fires exactly after 5 sek - right?
If I set 'Add User and flash delays' to enabled, then the flash fires after 5 sek plus the 40 units delay (arr. 4 msec.) - right?

Is this correct?




2 x IXUS 860IS 100c
2 x Powershot S110 103a

Re: Synch settings get lost (SDM 1.81)
« Reply #31 on: 04 / November / 2009, 16:31:14 »

enable_synch generaly enables the wait until shutter / usb switch is released

Yes.
Note that in some scripts you would not want that.
The blue led would light and photo would not be taken until after ten second time-out.
You would put command 'sync_off' at start of script.

Quote
releasing shutter button starts to open shutter on both cams.
It does but there is a delay caused by the Canon firmware that can vary from about 11 to 27 msec on cameras that I have looked at.
Luckily, the delay is VERY constant.

Quote
Flash of left cam fires immediately with 1/16 power.

Yes.

Quote
if enable_synch_delay is set to enabled
In flash mode it always will be, the SDM code does that.

Quote
the flash of right cam gets a delay of max. 40 units (arround 4 msec.).

Yes.

Quote
During this 4 msec. the left cam has time to open shutter completely. So chance is bigger that left cam also gets the flash - with shutter completely opened - am I right?

Yes.
Of course there is a limit .. when you get to 1/500 sec or more the tiny synch difference is a significant fraction of shutter open time.
So, you will not get 100% successful synch flash.
Quote

If I set coarse delay to e.g. 50, that means photo is taken 5 sek after is button released - right?

Yes.

Quote
If I set 'Add User and flash delays' to disabled, then the flash fires exactly after 5 sek - right?

Yes.
But if both cameras are set to five seconds the flash fires at the same time on both cameras so may not be detected.

Quote
If I set 'Add User and flash delays' to enabled, then the flash fires after 5 sek plus the 40 units delay (arr. 4 msec.) - right?

Yes, so the flash should be synchronised.
« Last Edit: 04 / November / 2009, 16:34:16 by Microfunguy »

 

Related Topics