supplierdeeply

S90 Porting Thread

  • 397 Replies
  • 111041 Views
Re: S90 Porting Thread
« Reply #210 on: 19 / April / 2010, 16:27:24 »
Advertisements
David,

Could you give a more detailed, step by step on how to get SD cards larger than 4GB working. I had the same problem. I used SDM Installer, formatted, then created two partitions, then swapped partitions and all I got was Card Error Faults. I must be leaving some step out. Do I need to format the partitions afterwards?

Thanks,
Gregg

*

Offline ERR99

  • ****
  • 339
Re: S90 Porting Thread
« Reply #211 on: 19 / April / 2010, 16:28:09 »
Nothing happens. The camera will not switch on. If I take the write protection off and take out and reinsert the battery it powers up but says the memory card is full.

Sounds like you are using the wrong/incompatible diskboot.bin for your camera.
Verify that you are using the correct build for your camera. e.g. if you have a camera with 1.01a firmware version, you can ONLY use the 101a CHDK beta build,  and NOT the 101c build.

Re: S90 Porting Thread
« Reply #212 on: 19 / April / 2010, 16:40:28 »
How do I check which version I have?

*

Offline ERR99

  • ****
  • 339
Re: S90 Porting Thread
« Reply #213 on: 19 / April / 2010, 16:45:49 »
Check in the FAQ: http://chdk.wikia.com/wiki/FAQ
the section "Q. How can I get the original firmware version number of my camera?".


Re: S90 Porting Thread
« Reply #214 on: 19 / April / 2010, 16:47:23 »
OK got it working. I forgot the ps.fir file

I  will try the 16GB card again and swap partitions for formatting then swap back and see how that works out. BTW what about the CHKDK folders? Where should I obtain those from or are they not really needed?

*

Offline ERR99

  • ****
  • 339
Re: S90 Porting Thread
« Reply #215 on: 19 / April / 2010, 16:52:21 »
Could some please outline the procedure for using a SD card larger that 4GB. I just picked up an Eye-Fi Pro X2 8GB card that I'm trying to get working with CHDK. So far the only luck I've had is partitioning the card to 4GB the installing CHDK. I tried to use Cardtricks ansd SDM Installer to create a small FAT partition but both keep giving me a Card Error Fault.

Maybe it is not possible to (re)partition Eye-Fi cards in general?
I dont have such a card, but if i am right the card transfers the pictures via WLAN to a PC, right?
I think it would be a problem for the Eye-Fi firmware to know from which partition it should transfer the images (if there was more than one partition), so maybe they have disabled the possibility to alter the partition table at all. This is only a idea, i am not really sure about this. Maybe you can ask in the Eye-Fi forum if the Eye-Fi cards supports partitioning.

Re: S90 Porting Thread
« Reply #216 on: 19 / April / 2010, 16:53:06 »

Could you give a more detailed, step by step on how to get SD cards larger than 4GB working.


See if this helps : http://stereo.jpn.org/eng/sdm/quick.htm

Can these cards be locked ?

I vaguely remember this topic being discussed previously.
« Last Edit: 19 / April / 2010, 16:55:16 by Microfunguy »

*

Offline ERR99

  • ****
  • 339
Re: S90 Porting Thread
« Reply #217 on: 19 / April / 2010, 16:55:50 »
OK got it working. I forgot the ps.fir file

I  will try the 16GB card again and swap partitions for formatting then swap back and see how that works out. BTW what about the CHKDK folders? Where should I obtain those from or are they not really needed?

You can take the CHDK folder from any other camera port. The CHDK folder is camera indepentend and its not really needed, CHDK starts also without it. But it is usefull, you get the nice CHDK splashscreen logo and also lot of example scripts.


Re: S90 Porting Thread
« Reply #218 on: 19 / April / 2010, 17:03:49 »
Quote
Can these cards be locked ?
I vaguely remember this topic being discussed previously.

The new ones can. They finally had the foresight to add the lock switch.

Re: S90 Porting Thread
« Reply #219 on: 19 / April / 2010, 17:08:29 »
16Gb partitioned and working fine. Cool! :)

OK here is a couple of things of note. AF does not work on video mode whilst recording. I was hoping this would work. Maybe something for later? Also if you have digital zoom enabled and zoom in I am unable to zoom back/retract (This is still whilst recording video). If I disable digital zoom (Which is rubbish anyway) I can then zoom back fine. Bug? Or bug in original firmware? Not sure as I never tested that before. :D

Zebra is nice ;)

 

Related Topics