S90 Porting Thread - page 28 - DryOS Development - CHDK Forum

S90 Porting Thread

  • 397 Replies
  • 119314 Views
*

Offline fe50

  • ******
  • 3105
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: S90 Porting Thread
« Reply #270 on: 21 / April / 2010, 15:42:22 »
Advertisements
i see the chdk message with orange background, but the camera stays in play mode, the lens should come out...?
Press (or half-press) the shutter button to switch to record mode !
..or just hold the power button for 1-2 second to power on directly in record mode.

Quote
When i push play mode button, the screen becomes black and nothing happens.
This way you power off the camera, that's the camera's default behaviour when powered on in playback mode  ;)

Re: S90 Porting Thread
« Reply #271 on: 21 / April / 2010, 16:01:43 »
Great! many thanks
It's working very well!
you're chief guys!!!

CHDKly yours!
shaltzman
590
S90

Re: S90 Porting Thread
« Reply #272 on: 21 / April / 2010, 22:12:29 »
First of all thanks to everyone that helped make chdk possible for the S90.  I used to have it on my old S980 and missed it when I sold it and actually forgot how to install on a 16gb card.

I do have one ongoing issue and that is after installing chdk on a 16gb card and getting it to temporarily work, I then make two partitions....once exiting the chdk menu and then go into the Canon camera's menu to try and take a picture I get a memory card error.

I've tried doing a swap partitions by then putting the card back into my laptop reader and it won't read the card it tells me it needs formatting with and without the lock on.

Any suggestion appreciated, and what is the best method for me to find out what firmware I have on my camera?

I'm using V4 S90 100c

Thanks again.
« Last Edit: 21 / April / 2010, 22:35:50 by Hollywood »



Re: S90 Porting Thread
« Reply #274 on: 22 / April / 2010, 02:04:02 »
101b dump looks good. ;)

I did a quick compare with the other fw versions, and on the first look there has not much changed in compare to 101c.
I have to take a deeper look to be 100% sure, but i assume that there as i very good change that the 101c port will also
run on cameras with 101b firmware. So please try the 101c V4 build on your camera.

101c port seems to work fine at the moment. Thanks. :)

Re: S90 Porting Thread
« Reply #275 on: 22 / April / 2010, 15:24:06 »
I guess that any input can be useful, so just two minor things:
1. AF does indeed work on 100c (using the button - didn't know this previously).
2. My camera shut down when the battery was at around 3250 mV. I'm not sure if this is dependend on FW/used battery/etc, but maybe there's chance to set a slightly higher value (instead of the current 3000 mV) as default.

Once again, hardly possible to express my praise to all the programmers involved. Amazing work :)

Re: S90 Porting Thread
« Reply #276 on: 22 / April / 2010, 16:45:39 »
maybe there's chance to set a slightly higher value (instead of the current 3000 mV) as default.

I don't use CHDK so I don't know the exact menu location, but .. yes .. you can set the battery upper and lower limits.


*

Offline jblc

  • *
  • 20
Re: S90 Porting Thread
« Reply #277 on: 22 / April / 2010, 17:13:59 »
2. My camera shut down when the battery was at around 3250 mV. I'm not sure if this is dependend on FW/used battery/etc, but maybe there's chance to set a slightly higher value (instead of the current 3000 mV) as default.

That's possibly a battery or camera specific value.  For example, my camera starts flashing the red battery icon at 3.4V, so I changed the "min" value to 3400 mV.  The battery packs are full at 3.7V, according to chdk in any case.


*

Offline ERR99

  • ****
  • 339
Re: S90 Porting Thread
« Reply #278 on: 23 / April / 2010, 03:26:36 »
@lsl7994: Good to know that the port also works for 101b, if possible please post here if optical zomming during video and AF-scan during video is also working.

Regarding the battery stuff: Every battery/camera combination looks to be different. Even if the battery stated as 3,7V battery, the measured voltage for my battery is (fully charged) almost 4,1V. But it is possible to set the MIN/MAX value via OSD (OSD-Parameters->Battery->Battery MIN/MAX Voltage)

Re: S90 Porting Thread
« Reply #279 on: 23 / April / 2010, 04:54:56 »
@ERR99

Someone has asked me when do you think the S90 will be added to TRUNK.

I am merely asking on their behalf   ::)

 

Related Topics