S90 Porting Thread - page 31 - DryOS Development - CHDK Forum  

S90 Porting Thread

  • 397 Replies
  • 117822 Views
*

Offline reyalp

  • ******
  • 11919
Re: S90 Porting Thread
« Reply #300 on: 26 / April / 2010, 03:20:13 »
Advertisements
So i dont know what failed, but it could not be the S90 port. ;)
Code: [Select]
**** Copying duplicate Firmwares
mv: `./bin/sx200is-100c-0.9.9-886-full.zip' and `./bin/sx200is-100c-0.9.9-886-full.zip' are the same file
make: *** [batch-zip-complete] Error 1
Fixed now, and S90 is in the autobuilds.
Don't forget what the H stands for.

Re: S90 Porting Thread
« Reply #301 on: 26 / April / 2010, 05:20:21 »
Does the USB remote switch work with this camera ?

I believe it uses a special USB/Video cable.


*

Offline ERR99

  • ****
  • 339
Re: S90 Porting Thread
« Reply #302 on: 26 / April / 2010, 05:31:49 »
So i dont know what failed, but it could not be the S90 port. ;)
Code: [Select]
**** Copying duplicate Firmwares
mv: `./bin/sx200is-100c-0.9.9-886-full.zip' and `./bin/sx200is-100c-0.9.9-886-full.zip' are the same file
make: *** [batch-zip-complete] Error 1
Fixed now, and S90 is in the autobuilds.

Coooool. Thanks. ;)

*

Offline ERR99

  • ****
  • 339
Re: S90 Porting Thread
« Reply #303 on: 26 / April / 2010, 05:33:01 »
Does the USB remote switch work with this camera ?
I believe it uses a special USB/Video cable.
It works. The connector is compatible to standard (mini) usb cables.


Re: S90 Porting Thread
« Reply #304 on: 26 / April / 2010, 05:47:23 »
Yes, since posting I found this 11 pin Canon Pinout

After the screen blanks, is the photo taken on switch release ?


Re: S90 Porting Thread
« Reply #305 on: 26 / April / 2010, 09:49:02 »
@lsl7994: Good to know that the port also works for 101b, if possible please post here if optical zomming during video and AF-scan during video is also working.

sorry for the late reply. the optical zooming and AF-scan during video is working fine. thanks a lot. :)

*

Offline fvdk

  • ***
  • 144
  • Ixus 70 1.01b / 1.02a & Powershot A590is 1.01b
    • My Flickr photo page
Re: S90 Porting Thread
« Reply #306 on: 26 / April / 2010, 11:08:05 »
Does the USB remote switch work with this camera ?

I believe it uses a special USB/Video cable.



Although it uses a special USB/Video cable, the standard SDM remote works perfectly.
At least it does with the IXUS100 which uses the same connector.

Frans
« Last Edit: 26 / April / 2010, 11:25:48 by fvdk »

*

Offline schnurrhahn

  • *
  • 6
  • Canon S100, Firmware 101A
Re: S90 Porting Thread
« Reply #307 on: 26 / April / 2010, 16:12:57 »
Here is the latest build (V5) for 100c with all changes, please give it a try. ;)

Thank you very much, ERR99 !
I tested this build to check the raw-processing with the script br_dev05.lua. This script didn't work with the elder builds.
And now it works ! Fantastic !

You found the problem in the sources, and so I adapted the script to the new directory structure of the S90.

Attached you'll find the script. I renamed it from br_dev05.lua to s90dev05.lua, because it's especially designed for the S90. Hope it works on your camera, too ! Perhaps it works on other cams like G11.

For those who are interested : This script allows to shoot and process HDR's directly in the camera. A german description can be found at http://www.wirklemms.de/chdk/forum/viewtopic.php?p=8072#8072.
« Last Edit: 26 / April / 2010, 16:15:21 by schnurrhahn »
Canon S100, Firmware 101A


Re: S90 Porting Thread
« Reply #308 on: 26 / April / 2010, 21:39:42 »
Update: Even with this patch, the script failes later. It throws a error because of the function getImageDirs().
It look likes this function searches for all image directorys by removing all dirs from the list which are not contains the substring "CANON".
But this is a problem on the S90/G11. Because Canon now uses another sheme to name the directorys (without the CANON substring, it is now some sort of day/month string used). So the script needs also a adaption for the S90/G11 image directory naming.

Ah, that explains why chdk raw mode saving doesn't work well for me; it makes a mess of 100___4, 100canon, 101___4, 101canon etc directories. It seems if there is a 10<n>canon directory, the camera completely ignores 10<n-1>___4, so there's far too few images in image-viewing mode.

If I remove all 101* and 102*, the s90 will still make a new 101___4 for some reason I don't understand, but at least all the piccies in 100___4 are accessed by the system again.

Re: S90 Porting Thread
« Reply #309 on: 27 / April / 2010, 10:30:17 »
Is there a way to prevent the Aperture and Shutter info from blinking when the overexposed areas blink in Zebra/Blink mode? I find that the exposure info may blink even though there are no overexposed areas blinking. Overexposed Threshold is set to 1 and Underexposed is set to 0. (V5, 100c) Many thanks for the help.

 

Related Topics