supplierdeeply

S90 Porting Thread

  • 397 Replies
  • 78342 Views
  • Publish
    Re: S90 Porting Thread
    « Reply #140 on: 13 / April / 2010, 17:28:39 »
    Advertisements
    it
    all my tests with 4 and 16 gig have failed. i've only been able to get a 1 gig card working.


    I'm using a 4Gb card on 101a, and the first build worked almost flawlessly...

    I'll try at home again with my 4 gig i have different versions of Mac os between home and work.
    At work the 4 GIG card isn't recognized by SMDinstaller, but the 16 gig is.
    i've tried to make 2 partitions on the card manually, but no luck.
    *shrug*

    *

    Offline ERR99

    • ****
    • 339
  • Publish
    Re: S90 Porting Thread
    « Reply #141 on: 13 / April / 2010, 17:38:01 »
    I think i found the problem regarding the 100c build. Please check if with the attached file,
    booting from a two partition/SDM-Installer prepared card works.

  • Publish
    Re: S90 Porting Thread
    « Reply #142 on: 13 / April / 2010, 17:46:08 »
    I think i found the problem regarding the 100c build. Please check if with the attached file,
    booting from a two partition/SDM-Installer prepared card works.

    my Genius :)

    now i can run my 16gb sd card with chdk.

    but my german language choice adapted from my g11 chdk pack don`t run .. now i have to wait for the s90 package...EDIT...now its working...had to put the files in the bigger part...my mistake!

    Thanks ERR99 for your work again again again :)
    « Last Edit: 13 / April / 2010, 17:50:20 by genervi »

    *

    Offline jblc

    • *
    • 20
  • Publish
    Re: S90 Porting Thread
    « Reply #143 on: 13 / April / 2010, 21:15:43 »

    The A570IS has a hardware switch to select play/rec mode. Most newer Canon cameras do this by push-button and therefore are not set in a mode as definite as the old ones. For some reason, they all boot in play mode when CHDK is loaded (except when the power button is held for a few seconds).

    If that's true, and ERR99 had a way to get it into Capture mode immediately as before in his first chdk version, can I suggest that we leave the lens-extend on playback, so that the camera powers up to Capture mode immediately?  That is a far better alternative it seems to me...


  • Publish
    Re: S90 Porting Thread
    « Reply #144 on: 13 / April / 2010, 22:18:09 »
    I think i found the problem regarding the 100c build. Please check if with the attached file,
    booting from a two partition/SDM-Installer prepared card works.
    my camera does not turn on with the 100c build. is there a diffrence between 100c and 100a?
    excuse the noobness here

  • Publish
    Re: S90 Porting Thread
    « Reply #145 on: 13 / April / 2010, 22:53:22 »
    okay so i've tried both my 4 gig and 16 gig cards, and neither one of them work.
    SDM installer does not recognize the 16 gig card and has a copy error on the 4 gig

    *

    Offline ERR99

    • ****
    • 339
  • Publish
    Re: S90 Porting Thread
    « Reply #146 on: 14 / April / 2010, 03:21:56 »
    so, i hope i finally was able to get a 101c dump. err99 it would be great if you could tell me if it looks ok, as i'm not really sure.
    i'm now working on a mac, prepared a 4gb sdhc card with sdminst (tow partitions), and used your modified udumper.
    http://www.zshare.net/download/749308691d23073c/

    Yes, 101c dump looks good! It needs only to be cleaned/stripped, to remove the trailing bytes from the empty.dum file.

    *

    Offline ERR99

    • ****
    • 339
  • Publish
    Re: S90 Porting Thread
    « Reply #147 on: 14 / April / 2010, 03:25:42 »
    I think i found the problem regarding the 100c build. Please check if with the attached file,
    booting from a two partition/SDM-Installer prepared card works.
    my camera does not turn on with the 100c build. is there a diffrence between 100c and 100a?
    excuse the noobness here
    You have to use the correct diskboot.bin file for you camera firmware.
    If you camera hat 101a firmware, you have to use the 101a port. 100c port does not work on cameras with 101a firmware.


  • Publish
    Re: S90 Porting Thread
    « Reply #148 on: 14 / April / 2010, 03:41:36 »
    so, i hope i finally was able to get a 101c dump. err99 it would be great if you could tell me if it looks ok, as i'm not really sure.
    i'm now working on a mac, prepared a 4gb sdhc card with sdminst (tow partitions), and used your modified udumper.
    http://www.zshare.net/download/749308691d23073c/

    Yes, 101c dump looks good! It needs only to be cleaned/stripped, to remove the trailing bytes from the empty.dum file.

    great, thanks for having a look. i hope you maybe find some time to try to make a port for the 101c (neither the 100c nor the 101a prots work).

    some general (maybe) useful information:
    i got the dump with the modified g11 udumper on a 4gb card, i found out that somewhere in the doc the max. capacity of a card for using udumper is 2gb. as my dumping process worked i suppose the limitation is not the card size but the partition size.
    as i'm using a mac i prepared the card with sdminst and copied the modified g11 udumper and the empty.dum to the first partition.
    that's the reason for the dummy bites left in my dump file.
    « Last Edit: 14 / April / 2010, 03:46:00 by mercurio »

    *

    Offline ERR99

    • ****
    • 339
  • Publish
    Re: S90 Porting Thread
    « Reply #149 on: 14 / April / 2010, 10:50:35 »
    great, thanks for having a look. i hope you maybe find some time to try to make a port for the 101c (neither the 100c nor the 101a prots work).
    Okay, here a first try for a 101c port: Test if the attached file boots. If everything is correct, camera should boot without card write protect message.

     

    Related Topics