problem during chdk start-up. Firmware version? - General Help and Assistance on using CHDK stable releases - CHDK Forum supplierdeeply

problem during chdk start-up. Firmware version?

  • 2 Replies
  • 2324 Views
problem during chdk start-up. Firmware version?
« on: 27 / November / 2009, 23:12:08 »
Advertisements
I'm trying to use CHDK for the first time, on my SX200 IS.  The Canon firmware version of my camera is 1.00d

So I downloaded http://mighty-hoernsche.de/bins/sx200is-100d-0.9.8-844_BETA.zip and put the unzipped relevant files (DISKBOOT.BIN, PS.FI2, CHDK, vers.txt) in the root directory on a bootable locked 4GB SD card.

I put the SD card in the camera, and get these unexpected results.

1. when I press the playback button, the camera starts to boot, and I get a brief display of a CHDK screen.  I was not expecting that.  I expected that the camera would boot normally, and I would have to select "firmware update" from the menu before it would get involved with CHDK.

2.  After about 3 seconds, the CHDK dialog panel disappears, and the camera displays my most recent picture.   When I hit the "menu" button, there is no "firmware update" choice on any menu.  I was expecting there to be a choice for that, and selecting it would cause CHDK to start.

3.  Half pressing the shutter switches the camera into "take pictures" mode, and I see the extra icons (battery % etc) that suggest CHDK is working OK.   The "little flower" icon (for macros) is displayed, and doesn't want to go away, regardless of me switching off macro.

4.  Pressing the main ON/OFF switch turns the camera on into playback mode.  I was expecting it to start in "take pictures" mode as usual.

I was able to get a picture of the CHDK start up screen (it is below).  It shows the string "100c" which suggests that the CHDK download is for a 1.00c firmware camera.   However I double-checked that what I downloaded was the 1.00d version.   I also downloaded the "complete" and the "small" CHDK versions for 1.00d sx200IS.   Both of the supposed 1.00d downloads show this 100c string.

Can anyone offer any suggestions on what to try next?   Is there a way to check the firmware version of the download?  

I am also particularly puzzled about what causes CHDK to try to start, unbidden.

Also, I have been correcting and clarifying the FAQ and other wiki pages, based on what I find.  For example, the SX200IS formats an SD card with FAT32.  So the wiki advice about formatting in the camera to get a bootable SD card is no longer accurate if you have an SX200.  I corrected that page.

Thanks for any ideas

   Peter

 
« Last Edit: 27 / November / 2009, 23:25:46 by pvdl »

Re: problem during chdk start-up. Firmware version?
« Reply #1 on: 27 / November / 2009, 23:29:07 »

So I downloaded http://mighty-hoernsche.de/bins/sx200is-100d-0.9.8-844_BETA.zip and put the unzipped relevant files (DISKBOOT.BIN, PS.FI2, CHDK, vers.txt) in the root directory on a bootable locked 4GB SD card.

I put the SD card in the camera, and get these unexpected results.

1. when I press the playback button, the camera starts to boot, and I get a brief display of a CHDK screen.  I was not expecting that.  I expected that the camera would boot normally, and I would have to select "firmware update" from the menu before it would get involved with CHDK.
Because you made the card bootable and it is locked (the lock tells it to autoload)  CHDK autoloads, no need to use the firmware update method.  If you onlock the card, it will start normally and you would have to use the firmware update to run CHDK.
Note, this behaviour is a feature, not a bug.

Quote
2.  After about 3 seconds, the CHDK dialog panel disappears, and the camera displays my most recent picture.   When I hit the "menu" button, there is no "firmware update" choice on any menu.  I was expecting there to be a choice for that, and selecting it would cause CHDK to start.
It seems that some of the newer cameras startup in playback mode by default (My SX10 does too). There has been some work to resolve this so it starts in record mode, but I haven't seen the results yet or it hasn't been added to the build yet.
As above, because it is bootable and autoloaded, CHDK has already started, you don't need the firmware update.

Quote
3.  You can playback, and call up Canon menus, but there is no way to persuade the camera to go into picture taking mode.
You can either half press shoot to go to record, or hold the start button when starting up to go to record mode.

Quote
I was able to get a picture of the CHDK screen (it is below).  It shows the string "100c" which suggests that the CHDK download is for a 1.00c firmware camera.   However I double-checked that what I downloaded was the 1.00d version.   I also downloaded the "complete" and the "small" CHDK versions for 1.00d sx200IS.   Both of the supposed 1.00d downloads show this 100c string.
From what I can see on the builds, 1.00c and 1.00d are the same, so the 1.00d build is just a copy of the 1.00c build.


*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: problem during chdk start-up. Firmware version?
« Reply #2 on: 29 / November / 2009, 07:17:50 »
So I downloaded http://mighty-hoernsche.de/bins/sx200is-100d-0.9.8-844_BETA.zip and put the unzipped relevant files (DISKBOOT.BIN, PS.FI2, CHDK, vers.txt) in the root directory on a bootable locked 4GB SD card.
Unzip the complete zip file content to the card; otherwise you (or others reading this thread) will report missing files or features here (e.g. game levels, sample scripts, language files)  ;)

Quote
When I hit the "menu" button, there is no "firmware update" choice on any menu.
The firmware update menu item is only available when there's a ps.fi/ps.fi2 file on the card's root and the camera is started in playback mode (lens is retracted).

Quote
4.  Pressing the main ON/OFF switch turns the camera on into playback mode.  I was expecting it to start in "take pictures" mode as usual.
Hold the power button a bit longer to start in record mode.

Quote
Also, I have been correcting and clarifying the FAQ and other wiki pages, based on what I find.  For example, the SX200IS formats an SD card with FAT32.  So the wiki advice about formatting in the camera to get a bootable SD card is no longer accurate if you have an SX200
No; the resulting fs format of the camera's format feature depends from the card size.
Cards up to 2GB will be formatted with FAT16, cards over 2GB will be formatted with FAT32.

When you extract the files from the "official" CHDK download locations to the SD card, there's no need to "prepare" files on the card - just when you want to use the CHDK autoboot feature, the card itself need to be prepared (format / bootable / lock)...
« Last Edit: 01 / December / 2009, 06:49:40 by fe50 »

 

Related Topics