sd550 scripts stalling out - Script Writing - CHDK Forum supplierdeeply

sd550 scripts stalling out

  • 2 Replies
  • 2067 Views
sd550 scripts stalling out
« on: 13 / December / 2009, 22:24:14 »
Advertisements
Howdy

Just learned about CHDKthe other day and already having lots of luck, but having trouble running any scripts.

I know little about authoring scripts, but all the samples Ive tried on my SD550 seem to stall out after the first process.  I want to use an interval script but even the default script and the badpixel script behave the same way.  camera just hangs until script is interrupted.

by accident I found that each time the mode selector knob is moved from M to Auto, etc., the script will progress to the next process, only to stall again until i move the knob again.  not exactly automated :(

Odd behavior.. anyone experience this?  is there a workaround?

thanks

*

Offline fe50

  • ******
  • 3139
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: sd550 scripts stalling out
« Reply #1 on: 14 / December / 2009, 05:08:54 »
Hello & welcome, slackard !

I guess you've stumbled over the "Ixus shoot issue"...
On some of the older Ixus (SDxx / SDxxx / IXY xx) cameras the shoot scripting command do not work correctly, the script stops directly after the shoot command. Sometimes this happens only when the flash is set to auto or on, sometimes shoot stops always...

Workaround: replace
  shoot   with
  click "shoot_full"    (in uBasic scripts) respectively
  shoot()  with
  click("shoot_full")   in Lua scripts.

(see also http://chdk.setepontos.com/index.php/topic,2380.new.html)

Re: sd550 scripts stalling out
« Reply #2 on: 15 / December / 2009, 01:05:25 »
working good now, using the revisions.

Thanks very much for the help.

 

Related Topics