A480 Porting - page 6 - DryOS Development - CHDK Forum  

A480 Porting

  • 75 Replies
Re: A480 Porting
« Reply #50 on: 29 / April / 2010, 13:37:57 »
ewavr, firstly let me thank you for building CHDK for A480. I've bought this camera 7 days ago and VERY happy with CHDK :)

My question is,
Is it possible to override aperture value in CHDK for A480 1.00b ?
If not, could you please implement it in next release (if it is possible) ?
« Last Edit: 29 / April / 2010, 13:40:00 by iPrank »

Re: A480 Porting
« Reply #51 on: 29 / April / 2010, 13:47:36 »
Hello and welcome.

Unfortunately, the A480 does not have an aperture diaphragm, just a neutral density filter.

Re: A480 Porting
« Reply #52 on: 29 / April / 2010, 14:01:49 »
Hello and welcome.
Thank you!   :)
Unfortunately, the A480 does not have an aperture diaphragm, just a neutral density filter.
But hey! it costs just $120.  What more can I ask from it ? :D

Funny thing is, when I was 'thoroughly'  testing the camera in the shop, the salesperson joked, "do you want to kill the baby?"
I wish he could see my CHDK-ed 'baby' now,  :lol
« Last Edit: 29 / April / 2010, 14:07:58 by iPrank »


Offline c10ud

  • ***
  • 245
Re: A480 Porting
« Reply #53 on: 03 / May / 2010, 13:59:12 »
i'll report an issue i've encountered while playing with a480+ptp:

once i successfully switch to record mode, scripts work as expected. however, my problem is in the switch itself. i chosed a simple thing for those tests: setting zoom level.

here's what i'm doing:
- initializing the camera
- checking the current mode (executing the get_mode() script on the camera and checking the result)
- if mode is record already, i just skip to the subsequent steps (set_zoom(x))
- if mode is playback, i call ptp_chdk_switch_mode

now, here's my problem: switching to record mode works fine.
however, after the switch_mode is requested, the camera shows in the lcd the modechange with the usual animation (in my case it shows "auto" since i'm not requesting any special mode, and this happens even if chdk osd is active instead of canon's).
now, if i ask for the execution of another script while this visual stuff is going on (i.e. set_zoom(level), where level is a big step) the camera become crazy (i.e. the zoom slows down when reaching the target, then the camera turns off and the usb connection dies while linux thinks the device has been disconnected).
instead, if i wait until those "auto" stuff disappear from camera screen, everything's fine.
the problem is reproducible also with mweerden's ptpcam-built-in-chdk-shell (./ptpcam --chdk); just power on the camera, then connect and:
> mode 1
> lua set_zoom(long_interval);cls();exit_alt()

quickly after the mode switch. you should have the zoom moving slower and then the poweroff.

i tried with a sx200is and everything's fine, so i guess this is a camera(firmware?) specific issue.

note: i solved by moving zoom with little steps, that seem to work without making the camera explode, in the end the result is the same :)

Re: A480 Porting
« Reply #54 on: 06 / May / 2010, 09:17:19 »

Can someone tell me how low can you go with ISO



Offline dh

  • *
  • 6
Re: A480 Porting
« Reply #55 on: 09 / May / 2010, 15:39:01 »
I am trying to use the 'shoot' (form button) function from chdkcam with SVN R885 firmware with ewavr's PTP'ized patch applied, that I have built.

While it seems to not complain the first time the button is selected, I suspect it does not successfully complete.  If I select 'shoot' (program form) button it reports that another script is running.  (I have not been able to identify any files created from it, and no image is 'frozen' in chdkcam as I expected.  Although I wasn't sure what to expect.)

Any suggestions about what I may be doing wrong?  Is there a particular mode the camera should be in? Alt-mode or not?

I suppose I should ask, what should be taking place when the 'script' commands 'shoot();cls();exit_alt();' is sent to the camera from chdkcam? Think I figured out the answer to this from the uBasic page @http://chdk.wikia.com/wiki/UBASIC/TutorialScratchpad.

« Last Edit: 09 / May / 2010, 15:58:08 by dh »

Re: A480 Porting
« Reply #56 on: 01 / June / 2010, 01:43:36 »
I'm using the current Autobuild version (0.9.9-894).

I turned on Subject Distance override and set SD = 1 and Value Factor = 1. My understanding is that this should move the focus by 1mm.

I half press the shutter button and the camera focuses. It then completely throws the focus off. I get the same result regardless of the SD value and factor settings.

Is this my misunderstanding of how this is supposed to work or is there a problem? I wouldn't have expected a 1mm change in the focus to cause a seemingly large change.

thanks, Andy

Re: A480 Porting
« Reply #57 on: 02 / June / 2010, 19:08:21 »
I'm using version 0.9.9-893 on a 1.00B A480 flawlessly.
This feature works fine on mine (setting manually the focus distance).

I'm only a bit disappointed regarding the speed of this camera (not relation with CHDK by the way): in continuous mode, even with bright light (short exposure) and high ISO (1600), I have to wait something like 1 second between 2 shots. And the SDHC speed has nothing to do with that :-(

Re: A480 Porting
« Reply #58 on: 02 / June / 2010, 19:11:59 »
Can you please describe exactly how you are using the subject distance override so I can try to reproduce it here? Thanks.


Re: A480 Porting
« Reply #59 on: 02 / June / 2010, 19:28:19 »
Well, just as you mentioned it in your example: SD=1, factor=1 (make sure overrides are not disabled).

Half pressing the shutter button makes you see the focus to be used (releasing the shutter button does not change the focus setting).


Related Topics