SX200 1.00D - cannot setup autoload - General Help and Assistance on using CHDK stable releases - CHDK Forum

SX200 1.00D - cannot setup autoload

  • 11 Replies
  • 5176 Views
SX200 1.00D - cannot setup autoload
« on: 11 / January / 2010, 16:40:55 »
Advertisements
Hello all, I just purchased a SX200IS and I love it so far. 

I am trying to have CHDK autoboot from my two SD cards, one is 8GB and the other is 16GB.  I tried to follow the directions on the chdk wiki for cards greater than 4GB, but to no avail.  When I load CHDK and try to click on "Make two partitions" in the CHDK menu, it asked me if I am sure, and I press yes and nothing happens.  I have tried this several times, doing a deep format from the camera each time, but it never works.   

Any suggestions?   

P.S.  I also noticed that in the RAR info in the download and the boot screen for CHDK for the 1.00D FW CHDK says 1.00C.  I checked the 1.00C download and it also says 1.00C everywhere, is this just a matter of not updating this text, or have the downloads been confused?

Thanks in advance,

Schmit

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: SX200 1.00D - cannot setup autoload
« Reply #1 on: 11 / January / 2010, 18:08:23 »
Hi Schmitty,

Partitioning:

On Windows, you could use SDMINSTE.EXE, from the Stereo Data Maker site,
(it does partitioning, formatting, making bootable, and can also 'swap partitions')
it's in this archive there: http://stereo.jpn.org/eng/sdm/file/common_files.zip

About the versions:

for all practical (read CHDK) purposes, 100c and 100d are equal. Current source in trunk generates both
binaries from the same source, that's why yours reports in as 100c (100c was ported first)


cheers,

wim

PS tip: if you put SDMINSTE.EXE on both of your partitions, you will 'always' be able to swap partitions,
    (as long as you have access to a PC & card reader) - and it takes only ~1% of the space of 1 JPG
« Last Edit: 18 / January / 2010, 06:10:52 by whim »

Re: SX200 1.00D - cannot setup autoload
« Reply #2 on: 18 / January / 2010, 04:27:48 »
Hi

I couldn't get the built in partitioning to work on an SX200 either but SDMINSTE worked a treat.

Thanks

Alan

Re: SX200 1.00D - cannot setup autoload
« Reply #3 on: 06 / February / 2010, 12:15:38 »
Just my opinion, but while autobooting into CHDK may sound like a good thing, it may not be that great in practice. I find that my battery runs down much faster when using CHDK. I prefer to just start it when I need it, even though I could easily autoboot it on my 4 g sdhc card if I wanted to. I only need raw files when I'm in a more creative mood, not for everyday pictures.


Re: SX200 1.00D - cannot setup autoload
« Reply #4 on: 07 / February / 2010, 17:31:31 »
I've tried to make swap partions with SDMINSTE on a 8 Gb card using USB card reader. I've made one partition, then made it bootable:
Partition1: Type:1 (FAT12) Capacity: 7646 Mb

After that I've made two partions, windows recognise it as a drive, but can not read.
SDMINSTE can read it:
Partition1: Type:1 (FAT12) Capacity: 2 Mb
Partition2: Type:11 (FAT32) Capacity: 7644 Mb

I've clicked on "Swap partitons", and after that SDMINSTE showed this:
Partition1: Type:11 (FAT32) Capacity: 7644 Mb
Partition2: Type:1 (FAT12) Capacity: 2 Mb

And windows can read it now!

Then I took Cardtricks, but It said that "Your card needs to be formatted with the FAT32 file system. CHDK can not start from this card, and 'CHDK->Card' option has been disabled."

How to transfer and make bootable this card?
(A 410), SX 200, (SX 280), SX 700

*

Offline reyalp

  • ******
  • 13443
Re: SX200 1.00D - cannot setup autoload
« Reply #5 on: 07 / February / 2010, 17:46:52 »
Partition1: Type:1 (FAT12) Capacity: 7646 Mb
A FAT12 partition cannot be 7+gb. This is impossible.
Don't forget what the H stands for.

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: SX200 1.00D - cannot setup autoload
« Reply #6 on: 07 / February / 2010, 18:15:30 »
@mastodon

- open your card again in SDMINSTE

Make sure it looks like in your first quoted position ( do another Swap Partitions if need be )
Quote
Partition1: Type:1 (FAT12) Capacity: 2 Mb
Partition2: Type:11 (FAT32) Capacity: 7644 Mb

the trick is, the small partition should be active (that is, it is called "Partition 1" )

now, format it (if it isn't formatted yet), and than click Make Bootable  -> you now have a formatted bootable FAT12 partition (under the drive select box it should now say (Bootable Card !!! - or something like it)

then, do another Swap Partitions, and format the large partition. Close SDMINSTE and open the card in explorer.
Copy all your CHDK files to the large partition.

Now open card again in SDMINSTE and do Swap Partitions - the small partition will again be "Partition 1"
Close SDMINSTE again, and open card in explorer - your large partition will be 'gone' (Windows does not see it)
but you should be able to see to see the small partition.
Copy "DISKBOOT.BIN" (and "PS.FI2", if available for your cam) to the small partition.
Lock your card (slide the write-protect tab away from the electrical connectors) and put it in your cam

Your camera should now boot CHDK

Note that every time you need to access your pictures you will need to do a Swap Partitions again to make the large
partition visible for Windows, and another one to swap back to make CHDK boot after that.

HTH,

wim




Re: SX200 1.00D - cannot setup autoload
« Reply #7 on: 07 / February / 2010, 18:50:07 »
@mastodon

Now open card again in SDMINSTE and do Swap Partitions - the small partition will again be "Partition 1"
Close SDMINSTE again, and open card in explorer - your large partition will be 'gone' (Windows does not see it)
but you should be able to see to see the small partition.
Copy "DISKBOOT.BIN" (and "PS.FI2", if available for your cam) to the small partition.
Thanks, reyalp, I've misstyped.

Thanks, whim, everything you wrote is clear, I should be able to do it.

But I have the same problem, as before. I have swapped the parttions, and SDM see partition1 as 2 Mb FAT12 and bootable, but windows does not read it, although it shows it as a drive.
(A 410), SX 200, (SX 280), SX 700


*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: SX200 1.00D - cannot setup autoload
« Reply #8 on: 07 / February / 2010, 19:03:26 »
@mastodon

Windows can only see 1 partition at a time, the active one, ("Partition 1" in sdminste)
to see which one is visible via Windows explorer, check it's size (right click - Properties)
If sdminste can format the small partition  and make it bootable, then explorer should
be able to access it

wim

Re: SX200 1.00D - cannot setup autoload
« Reply #9 on: 08 / February / 2010, 02:45:26 »
Unfortunately Windows does not recognise the partition formatted as FAT12. It said that disk is not formatted.
(A 410), SX 200, (SX 280), SX 700

 

Related Topics