Fast MD with burst/preview mode - page 18 - Completed and Working Scripts - CHDK Forum

Fast MD with burst/preview mode

  • 232 Replies
  • 173925 Views
Re: Fast MD with burst/preview mode
« Reply #170 on: 30 / May / 2009, 18:30:05 »
Advertisements
On page 11, 5th messeage - May / 2009, 19:04:22 -  user Obihoernchen posted photo of some program, which shows delay of the triggering. Can you anyone tell me the name of this program? I want measure delay of triggering of my A590is.
Thanks.

*

Offline fe50

  • ******
  • 3107
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Fast MD with burst/preview mode
« Reply #171 on: 31 / May / 2009, 05:17:37 »
On page 11, 5th messeage - May / 2009, 19:04:22 -  user Obihoernchen posted photo of some program, which shows delay of the triggering. Can you anyone tell me the name of this program? I want measure delay of triggering of my A590is.
Dataghost's webbased MD-meter; you'll find it (and some other apps) here: CHDK wikia: Software - Motion Detection

Re: Fast MD with burst/preview mode
« Reply #172 on: 31 / May / 2009, 09:00:09 »
Hi, I've been posting about this in a separate thread here but I think that this might be the right place for it, in case anyone else has had the same problem. I downloaded the MD script from this post.

I'm using an SD1100IS / IXUS 80, which means it has no separate video button but rather a slider. I'm using the script for the cameras with no video button.

The motion detection script works very well in photo mode, but it doesn't work in video mode at all. It simply exits immediately when I try to run it. I think that maybe it isn't detecting that the camera is in video mode. Has anyone else had this problem, or know how to fix it? I really want to use the motion detector with video. (Alternately, if anyone knows of another script that would work that would also be great, but I really like how this one works with the photos and I'd love to use it with video).

Thanks!
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

*

Offline fudgey

  • *****
  • 1705
  • a570is
Re: Fast MD with burst/preview mode
« Reply #173 on: 31 / May / 2009, 15:07:18 »
CanonBlue,

Quote
First of all, I noticed that in all modes I get a red message in the top left corner of the camera screen that says "uBASIC:9 Parse err". I don't think I've ever noticed that before. Did I do something wrong in copying the script?
Yes, either your script is corrupt (memory card could be corrupt or you may have copied or edited the script incorrectly) or you are running an incompatible CHDK version. Anything that goes wrong for you may be due to this.

Quote
I think this matches the error I've been getting from the motion detector script when in video mode. Its difficult to read but I think I have noticed the word exiting. Does that mean that it thinks I'm in play mode when I'm in video mode? Is there some setting that I should change to make it realize its in video mode? I've looked for something like that but couldn't find anything...
 
Yes. If this is correct, the ixus80_sd1100 get_mode is broken in CHDK. You can probably make things printed by the test script prevail on the screen longer by duplicating each of the if M=? then print "something" lines...say, 20 times each.

Quote
(Btw is there a reason that the motion detector script I am using, the first one, doesn't seem to be on the main scripts page? I went there to check and I found a different one instead, but I think the one I've been using works better.)

Because the wiki doesn't allow file attachments and I don't want to read support requests from people who break my scripts incorrectly copy pasting them using weird browsers on even more weird operating systems with increasingly weird character sets. And because I'm downright lazy.

Quote
The motion detection script works very well in photo mode, but it doesn't work in video mode at all. It simply exits immediately when I try to run it. I think that maybe it isn't detecting that the camera is in video mode. Has anyone else had this problem, or know how to fix it? I really want to use the motion detector with video. (Alternately, if anyone knows of another script that would work that would also be great, but I really like how this one works with the photos and I'd love to use it with video).

You should try an older version of the MDFB script from here:
http://chdk.setepontos.com/index.php/topic,471.msg17797.html#msg17797. It has a separate still/video setting instead of an automatic mode check. So if video record from scripts works in video mode for your camera by pressing the shutter once for rec and once again later for stop, I believe this older version should work.


Re: Fast MD with burst/preview mode
« Reply #174 on: 31 / May / 2009, 16:22:41 »
Quote
You should try an older version of the MDFB script from here:

I tried that, and it worked, thanks! I haven't tested it extensively, but on my first try it worked to record video. I'll have to experiment with the various settings and stuff later. Thanks for all your help, I'm really glad to have this working!

Quote
Because the wiki doesn't allow file attachments and I don't want to read support requests from people who break my scripts incorrectly copy pasting them using weird browsers on even more weird operating systems with increasingly weird character sets. And because I'm downright lazy.

Fair enough, hehe. I only heard about this script because I asked someone on flickr who had posted lightening shots. I'm telling my friends about it.

Quote
Yes, either your script is corrupt (memory card could be corrupt or you may have copied or edited the script incorrectly) or you are running an incompatible CHDK version. Anything that goes wrong for you may be due to this.

Anything's possible, but I don't know why my card would be corrupt or the CHDK would be incompatible. I only installed it a couple weeks ago so it should be the most recent version. I did have some trouble installing it but in the end I think I got everything right... but I certainly wouldn't be surprised to find out something else went wrong. Also, as far as copying the script, I used TextEdit (I'm on a mac) and I made sure it was in text only mode and all of that. So I think it was copied correctly, but I don't have a ton of experience with this, so again, who knows... Anyway, it was the only script where I've gotten that uBASIC error, so maybe that points to me copying it wrong? I'll have a look at it again later (I'm rather rushed now with exams and travel coming up) and see if I can figure out the problem.

Quote

Yes. If this is correct, the ixus80_sd1100 get_mode is broken in CHDK. You can probably make things printed by the test script prevail on the screen longer by duplicating each of the if M=? then print "something" lines...say, 20 times each.

I'll try that later when I have more time and report back. I *think* that I was getting the same error message in play and video modes, which would point to that being the problem.
My Flickr Page
I use the chdk on my SX230 and SD1100 cameras, and I installed them using a Macbook, currently running 10.6.8.

Re: Fast MD with burst/preview mode
« Reply #175 on: 14 / June / 2009, 11:46:21 »
Hello all, I have been a user of CHDK for over a year and have been getting into it more and more. I have an S5 IS with the latest (as of 3 days ago) build. I got into MD bug after seeing a fantastic lightning storm. I am not that good at code and such but as MX3 said, "If you want to contribute" so I am going to. What might take most of you a few minutes will likely take me several hours/days. But I love CHDK and am bound and determined to learn. I have everything ready, even the compiler shell all setup.

The roadblock I seem to be running into now is simply just getting the dump! I have <ALT> set and press the +/- button and nothing happens. However, if I press <ALT> FUNC it writes a 32+ meg JPG file that I am guessing must be the dump file. Question is, now what do I do? Sorry to be such a neub but we all gotta start somewhere...

Re: Fast MD with burst/preview mode
« Reply #176 on: 14 / June / 2009, 12:55:02 »
Nevermind, I found this and I think I will go in that direction for a while to see if I can sort it out....
http://chdk.setepontos.com/index.php/topic,688.msg17782.html#msg17782


Re: Fast MD with burst/preview mode
« Reply #177 on: 21 / June / 2009, 12:42:06 »
Just tried this http://chdk.setepontos.com/index.php/topic,471.msg21328.html#msg21328 on A720IS with the latest build of CHDK and it works a treat :)

Thanks fudgey


Re: Fast MD with burst/preview mode
« Reply #178 on: 30 / June / 2009, 16:09:50 »
Nice! Fast MD works well! Small Lightnings Gallery
I wait for the next storm. :)

« Last Edit: 30 / June / 2009, 16:16:17 by .:olo:. »

*

Offline Anaglyphic

  • ***
  • 129
  • Anaglyphic lives!
Re: Fast MD with burst/preview mode
« Reply #179 on: 10 / July / 2009, 14:24:59 »
Since we cannot know all that there is to be known about anything,
 we ought to know a little about everything.
-- Blaise Pascal

 

Related Topics