A1100 IS Porting thread - page 2 - DryOS Development - CHDK Forum

A1100 IS Porting thread

  • 646 Replies
  • 173785 Views
Re: A1100 IS Porting thread
« Reply #10 on: 29 / January / 2010, 08:51:27 »
Advertisements
How can I help?

Re: A1100 IS Porting thread
« Reply #11 on: 31 / January / 2010, 05:31:02 »
I put the ver.req file at the root of SD card.Mostly like ohters,but I get E18 error.why?But it work fine!

*

Offline fe50

  • ******
  • 3132
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: A1100 IS Porting thread
« Reply #12 on: 31 / January / 2010, 07:09:58 »

Re: A1100 IS Porting thread
« Reply #13 on: 31 / January / 2010, 07:25:47 »
thanks!


Re: A1100 IS Porting thread
« Reply #14 on: 02 / February / 2010, 06:01:18 »
Hey FireDevil
Hi, I have extensive knowledge in Assembly and Usage of IDA, being a Malware Analyst by profession, but I have no experience with CHDK. Maybe I can help with the Disassembling and reverse engineering process.

Hey FireDevil Thanks for the offer. I'm digging through the the code now. But as I mentioned above it has been a long time since I've coded in assembly.
Here is a link to my current IDA idb file.
http://www.littlecrackpot.com/PRIMARY.rar

I've already applied the sigs file and the CHDK.idc and code fix script on the DryOS porting page. I'm currently still digging through it to fix the broken subroutines. I've also been updating the loader and platform code to match the proper memory addresses but I still have to find many subroutines.

Currently tracking down the fix to this compile error.(Basically trying to find a subroutine that reads the MBR of the SD card at least that is what I think it is trying to do.)
Code: [Select]
../platform/a1100is/sub/100c/libplatformsub.a(boot.o): In function `loc_FFC40014':
boot.c:(.text+0x105c): undefined reference to `mbr_read_dryos'

Any assistance is appreciated. Thanks
I also begin to port the a1100 is.
How can I help you GiAire?
Now, I am debuging the code with IDA.

Re: A1100 IS Porting thread
« Reply #15 on: 02 / February / 2010, 09:16:55 »
Hi GiAire, The IDB file does not seem to be supported by my version of IDA (5.2). Guess I will have to perform all the steps to get the IDA  file 

yes!I also notice that! First I user IDA5.2 to run the idc script.But Nothing happy!
Than I change to IDA5.5,I run the chdk.idc script.It works!
I get the  assembly code success.
I do not know why.

Re: A1100 IS Porting thread
« Reply #16 on: 03 / February / 2010, 03:39:25 »
Hi GiAire, The IDB file does not seem to be supported by my version of IDA (5.2). Guess I will have to perform all the steps to get the IDA  file 
the IDA5.5 can open the GiAire's idb file.I have tried.

Re: A1100 IS Porting thread
« Reply #17 on: 06 / February / 2010, 02:33:04 »
Hey guys sorry but I have had very little computer access for the last 2 weeks. First my monitor blew up and then I was forced to move my office. I have my PC running again and I'll get back to work on this but I'll only have an hour or so a day to work on it.(hopefully more in a week or two) I'll try to post the code I've gone through so far.(not much) but it is a start.

For those of you with IDA I think the best help you could provide is finding the Addresses of any functions not found automatically by the idc.(I can slosh through it but I'm still facing a learning curve.) Once I post the current code you'll have a better idea of which ones have not been found yet. (currently boot.c is the focus see my last comment as that was right before I lost my monitor.)

Reference cameras I have been using are the a720is(mainly for code layout), sx10is and sx200is(both of these are DIGIC IV cameras and have some similar functionality) but all of these are different cameras and everything must be verified. 

Anyway just wanted to post an update and let everyone know I have not given up just delayed a little.


Re: A1100 IS Porting thread
« Reply #18 on: 08 / February / 2010, 03:33:54 »
Hey guys sorry but I have had very little computer access for the last 2 weeks. First my monitor blew up and then I was forced to move my office. I have my PC running again and I'll get back to work on this but I'll only have an hour or so a day to work on it.(hopefully more in a week or two) I'll try to post the code I've gone through so far.(not much) but it is a start.

For those of you with IDA I think the best help you could provide is finding the Addresses of any functions not found automatically by the idc.(I can slosh through it but I'm still facing a learning curve.) Once I post the current code you'll have a better idea of which ones have not been found yet. (currently boot.c is the focus see my last comment as that was right before I lost my monitor.)

Reference cameras I have been using are the a720is(mainly for code layout), sx10is and sx200is(both of these are DIGIC IV cameras and have some similar functionality) but all of these are different cameras and everything must be verified. 

Anyway just wanted to post an update and let everyone know I have not given up just delayed a little.
Good! 

Re: A1100 IS Porting thread
« Reply #19 on: 12 / March / 2010, 07:10:56 »
Hi..
Any progress? I also have the a1100is, what can i do to help..test it..

 

Related Topics