A1100 IS Porting thread - page 63 - DryOS Development - CHDK Forum

A1100 IS Porting thread

  • 646 Replies
  • 186406 Views
*

Offline nafraf

  • *****
  • 1308
Re: A1100 IS Porting thread
« Reply #620 on: 30 / October / 2014, 22:56:15 »
Advertisements
Please test this patch.

*

Offline koshy

  • *****
  • 1086
Re: A1100 IS Porting thread
« Reply #621 on: 31 / October / 2014, 06:59:36 »
Please test this patch.
I applied the patch to a fresh download of trunk 3702.

It resulted in the following compilation error:

Code: [Select]
../platform/a1100/sub/100c/libplatformsub.a(lib.o): In function `vid_get_bitmap_active_buffer':
lib.c:(.text+0x78): multiple definition of `vid_get_bitmap_active_buffer'
../platform/a1100/libplatform.a(lib.o):lib.c:(.text+0x1b0): first defined here
collect2: ld returned 1 exit status
C:\Users\web\Downloads\gcc451\bin\gmake.exe[1]: *** [main.elf] Error 1
gmake: *** [all-recursive] Error 1
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
Re: A1100 IS Porting thread
« Reply #622 on: 31 / October / 2014, 10:01:07 »
Sorry, my fault. Please test this patch.

*

Offline koshy

  • *****
  • 1086
Re: A1100 IS Porting thread
« Reply #623 on: 31 / October / 2014, 12:01:09 »
Sorry, my fault. Please test this patch.
This patch does it. Menu colors after reset are what they should be. Custom palette is present both in play and Rec mode. CHDKPTP Palette matches Palette on camera. Well done. Thanks.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)


*

Offline nafraf

  • *****
  • 1308
Re: A1100 IS Porting thread
« Reply #624 on: 31 / October / 2014, 12:14:59 »
Thanks. Changes committed to trunk, changeset 3705

*

Offline koshy

  • *****
  • 1086
Re: A1100 IS Porting thread
« Reply #625 on: 02 / November / 2014, 12:11:06 »
Thanks. Changes committed to trunk, changeset 3705
>No longer works in trunk 3708. More details on IXUS 980 thread. A1100 in Rec mode is fine. Here only Play mode is affected. In CHDKPTP play mode is fine again, but on the camera it's not.
Koshy had a little ELPH which wasn't white as snow but everywhere that Koshy went the ELPH was sure to go. (actually an SD, but that detail ruins the rhyme...)

*

Offline nafraf

  • *****
  • 1308
Re: A1100 IS Porting thread
« Reply #626 on: 02 / April / 2015, 18:12:22 »
Test version for 100a.
"firmware update" method is not supported on this version then "bootable SD card" is required.

Re: A1100 IS Porting thread
« Reply #627 on: 04 / November / 2015, 16:17:20 »
Any news on this development?

Any hints how I can install/start the version from one post before?

I have a A1100IS with firmware 1.00a as far as I can see. Link said ´no firmware update, use bootable-sd´, so I tried as follows:
I unpacked the .zip to the fat(16)-formatted sd-root and made it bootable with eoscard.exe, hexvalue after bootdisk seems correct, everything seems right - but when I lock the sd-card and put it back into the camera it does not start, cam looks like dead.

What can I try to get it to work with chdk? Many thanks already.

« Last Edit: 04 / November / 2015, 16:18:59 by Micha1982 »


Re: A1100 IS Porting thread
« Reply #628 on: 04 / November / 2015, 21:36:05 »
Any news on this development?
As there is nothing else posted here,  it's safe to assume there is no news six months later.  The last post was from nafraf with a test version that it appears nobody tried and reported on.  Sad.

Quote
Any hints how I can install/start the version from one post before?
Download the posted zip file and follow the instructions here :  http://zenoshrdlu.com/stick/stickx.html


Quote
I have a A1100IS with firmware 1.00a as far as I can see. Link said ´no firmware update, use bootable-sd´, so I tried as follows:
I unpacked the .zip to the fat(16)-formatted sd-root and made it bootable with eoscard.exe, hexvalue after bootdisk seems correct, everything seems right - but when I lock the sd-card and put it back into the camera it does not start, cam looks like dead.
If you did not get an "SD Card Locked" message then you setup the card boot sector correctly and the camera tried to load the CHDK boot loader / executable.  But it failed to load so either because you do not actually have a camera with 1.00a firmware or the CHDK install file is broken.

Why do you think you have 1.00a?  Did you use ACID to make sure ?

Ported :   A1200    SD940   G10    Powershot N    G16

Re: A1100 IS Porting thread
« Reply #629 on: 05 / November / 2015, 12:26:40 »
Download the posted zip file and follow the instructions here :  http://zenoshrdlu.com/stick/stickx.html
Ok, Stick found the fw after I renamed it exactly like described here (Test100a.zip) and ´Stick´ found the card after starting the right file (.cmd for x64) -
but it does not work anyway, the cam does not start on my first try - black like dead,


Quote
I have a A1100IS with firmware 1.00a as far as I can see.
If you did not get an "SD Card Locked" message then you setup the card boot sector correctly and the camera tried to load the CHDK boot loader / executable.  But it failed to load so either because you do not actually have a camera with 1.00a firmware or the CHDK install file is broken.

Why do you think you have 1.00a?  Did you use ACID to make sure ?
Because menu showed ´GM1.00A´ with ver.req ´installed´...but I will read more about ACID now and try the other 2 fw´s...


Edit: ACID says A1100 IS, fw: 100a.
« Last Edit: 05 / November / 2015, 12:36:03 by Micha1982 »

 

Related Topics