A1100 IS Porting thread - page 58 - DryOS Development - CHDK Forum

A1100 IS Porting thread

  • 647 Replies
  • 220589 Views
*

Offline philmoz

  • *****
  • 3450
    • Photos
Re: A1100 IS Porting thread
« Reply #570 on: 29 / June / 2013, 04:58:21 »
Advertisements

Get the latest version from SVN.

Phil.

I redownloaded it from

Code: [Select]
svn checkout https://tools.assembla.com/svn/chdk/trunk chdk
But i still get the same error

Code: [Select]
<< Leaving platform/a1100
>> Entering to platform/a1100/sub/100a
boot.c -> boot.o
stubs_min.S -> stubs_min.o
stubs_auto.S -> stubs_auto.o
../../../../tools/finsig_dryos.o: file not recognized: File format not recognize
d
collect2: ld returned 1 exit status
C:\chdk\gcc451\bin\gmake.exe[1]: *** [../../../../tools/finsig_dryos] Error 1
gmake: *** [all-recursive] Error 1

C:\chdk\src\chdk>gmake PLATFORM=a1100 PLATFORMSUB=100a fir

EDIT:I've tried to compile the 100c firmware and it works.

It would appear you've messed up the makefiles somewhere - finsig_dryos.o is part of the CHDK tools and is compiled as x86 code. It is not meant to be included as part of the ARM code on the camera.

If you can build the 1.00c version then compare your files to see what might have changed - WinMerge is good for this if you use Windows.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: A1100 IS Porting thread
« Reply #571 on: 29 / June / 2013, 07:44:37 »
Finally i succesfully compiled it!  :D

I run the 3 test script and everything's working! Thanks to nafraf, waterwingz and philmoz for the help.  :)


*

Offline nafraf

  • *****
  • 1308
Re: A1100 IS Porting thread
« Reply #572 on: 29 / June / 2013, 08:14:20 »
Finally i succesfully compiled it!  :D

I run the 3 test script and everything's working! Thanks to nafraf, waterwingz and philmoz for the help.  :)
Good! next steps:  test it more (RAW, photo overrides, etc ), report and share your code ( a patch file or a  zip of a1100/sub/100a/ ). ;)
 

Re: A1100 IS Porting thread
« Reply #573 on: 29 / June / 2013, 13:06:59 »
I've tested the port for about 3 hours, and i didn't found any problem. :D

Thanks again for the help! Here's my a1100/sub/100a/ folder: 100a.zip


*

Offline nafraf

  • *****
  • 1308
Re: A1100 IS Porting thread
« Reply #574 on: 29 / June / 2013, 14:04:45 »
I've tested the port for about 3 hours, and i didn't found any problem. :D

Thanks again for the help! Here's my a1100/sub/100a/ folder: 100a.zip
The link points to a wrong address ... if you zip only source code (without bin files) it is possible to attach it to the post.  Thanks

Re: A1100 IS Porting thread
« Reply #575 on: 29 / June / 2013, 14:21:12 »
Ops... correct link: https://www.dropbox.com/s/dw2v6nt9zbdvj22/100a.rar

I've also attached the file to this post.
« Last Edit: 29 / June / 2013, 14:29:11 by Switch01 »

Re: A1100 IS Porting thread
« Reply #576 on: 10 / August / 2013, 02:40:34 »
Not sure if this is particular to A1100 port, but the bracketing feature does not work using the timer. In other words, when I enable the continuous bracketing in the Alt menu, then set the custom timer in the regular camera menu to take x number of shots, it does not take x number of shots at the varying exposures specified in the Alt menu; it just takes x number of shots at the same exposure. From reading the forums and features and CHDK user guide, this should work properly in Custom Timer mode.

For what it's worth, bracketing does work if I'm just holding the shoot button down in Continuous mode; of course the problem is that without a timer, this means the shots are handheld and thus there is too much movement between each.

I too have this problem,i tried diiferent versions of chdk.
Can smebody help me  :(
« Last Edit: 10 / August / 2013, 02:47:22 by muzirian »

*

Offline reyalp

  • ******
  • 14072
Re: A1100 IS Porting thread
« Reply #577 on: 10 / August / 2013, 02:45:23 »
Not sure if this is particular to A1100 port, but the bracketing feature does not work using the timer. In other words, when I enable the continuous bracketing in the Alt menu, then set the custom timer in the regular camera menu to take x number of shots, it does not take x number of shots at the varying exposures specified in the Alt menu; it just takes x number of shots at the same exposure. From reading the forums and features and CHDK user guide, this should work properly in Custom Timer mode.

For what it's worth, bracketing does work if I'm just holding the shoot button down in Continuous mode; of course the problem is that without a timer, this means the shots are handheld and thus there is too much movement between each.

Im too have this problem,i tried diiferent versions of chdk.
Can smebody help me  :(
This camera probably needs #define CAM_DRIVE_MODE_FROM_TIMER_MODE  1 in platform_camera.h, I can post a test build if you tell me which Canon firmware version your camera has.
Don't forget what the H stands for.


Re: A1100 IS Porting thread
« Reply #578 on: 10 / August / 2013, 02:49:57 »
Its "c" GM1.00C :)

Re: A1100 IS Porting thread
« Reply #579 on: 10 / August / 2013, 02:51:20 »
Its "c" GM1.00C :)
Good - that's the only ported version :)
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics