Partitions in 8 GB card not working - General Help and Assistance on using CHDK stable releases - CHDK Forum

Partitions in 8 GB card not working

  • 15 Replies
  • 4773 Views
*

Offline dvip

  • ****
  • 451
Partitions in 8 GB card not working
« on: 18 / February / 2010, 20:51:46 »
Advertisements
Hello,

I just got a SanDisk 8 GB card for my A590IS-101b and using a590-101b-0.9.9-874-full.
I have been trying to create a partition using the instructions found in the following link, but no luck:

http://chdk.wikia.com/wiki/Bootable_SD_card
 (Windows: Case #4)


I can start CHDK manually (Firmware update). But after going to
"Miscellaneous stuff -> Debug Parameters -> Create card with two partitions"
I can't access the card any more from the PC (XP) and in the camera it reports "Memory card error".
I even did a "Miscellaneous stuff -> Swap partitions" but it didn't help.
After this, the only way to get to use the card again is by doing a low level format in camera.

I can use the 8 GB card fine without CHDK.

I also have a 4 GB card with CHDK in it and no problem there either.

Am I missing something?


 

*

Offline dvip

  • ****
  • 451
Re: Partitions in 8 GB card not working
« Reply #1 on: 19 / February / 2010, 00:12:53 »
Just to let anyone know with the same problem.

I got it done with sdminste.exe in:

http://stereo.jpn.org/eng/sdm/file/common_files.zip

But for some reason sdminste.exe doesn't work well in my XP laptop. It works fine in my Windows 7 laptop. But in XP I can't even read the card, it asks me if I want to format it. Then I plug the card in my Windows 7 laptop and even in a Win98SE PC and read the card/download pictures without problems.

Any idea why it won't work on my XP laptop? I would like to read the card there too :(

 

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Partitions in 8 GB card not working
« Reply #2 on: 19 / February / 2010, 05:28:53 »
@dvip

Probably the card reader in your XP laptop does not support SDHC cards.
You might be lucky and be able to find an updated driver, but most likely
the easiest solution is a cheap USB SDHC card reader.

hth,

wim

*

Offline dvip

  • ****
  • 451
Re: Partitions in 8 GB card not working
« Reply #3 on: 19 / February / 2010, 08:54:10 »
Hi whim,

Well the XP laptop reads the 8 GB card fine if it doesn't have
the partition. It also reads a 4 GB card with chdk that I use all
the time. So I know that the built-in card reader is fine.  I think it
has something to do with the partition but I am not sure. Also in
the XP laptop sdminste.exe doesn't work right either.

In Windows 7 it works fine, I got it done there.

In the Win98SE machine, it is nice, I see both partitions with
Windows Explorer and work on them without problems (lol,
Win98SE better that XP?).

It is just weird that the card can't be read in the XP laptop, and that it asks to format it.
I don't know what driver to install to make it work :(



 


*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Partitions in 8 GB card not working
« Reply #4 on: 19 / February / 2010, 09:25:48 »
Quote
I don't know what driver to install to make it work

I was referring to the card reader driver - if your XP laptop has a built-in card reader,
see if you can find it in Device Manager, if it uses a non-Microsoft driver, you
can try and find driver updates (google manufacturer and/or product name/id)

As i said before though, it's usually not worth the trouble - just get a cheap USB reader,
that will work on any machine (and comfortably fits your pocket)

That way, you can access your card on any computer with an USB port,
if you put SDMINSTE.EXE on both partitions in case of a multi-partition card (to swap between partitions)

HTH,

wim

*

Offline dvip

  • ****
  • 451
Re: Partitions in 8 GB card not working
« Reply #5 on: 19 / February / 2010, 16:26:55 »
whim,
I like your idea about using a card reader with the XP laptop, it
is a fast solution. I will give that a try. It's what I use in the
Win98SE machine but I am away now and I can't try it.

Since you have the same cam I have (A590IS-101b), have you
ever done the partitions in the cam? Following the instructions in:

http://chdk.wikia.com/wiki/Bootable_SD_card
(Windows: Case #4)

In any case, I feel better now after being able to do it in
Windows 7. I was already wishing I would have gotten a 4 GB
card instead of an 8 GB.

Thanks!







*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Partitions in 8 GB card not working
« Reply #6 on: 19 / February / 2010, 17:25:29 »
@dvip

Quote
Since you have the same cam I have (A590IS-101b), have you
ever done the partitions in the cam? Following the instructions in:

http://chdk.wikia.com/wiki/Bootable_SD_card
(Windows: Case #4)

I have, although not on this cam, i tend to put my 8 GB card in my ixus870 (Li batteries last longer than 2 AA)

Since at one point you still need a PC, I tend to use SDMINSTE - less menu to wade through  :D

have fun,

wim

*

Offline dvip

  • ****
  • 451
Re: Partitions in 8 GB card not working
« Reply #7 on: 19 / February / 2010, 22:37:21 »
@whim,
The card reader idea worked in the XP laptop! :)

It just feels weird to have to plug a card reader in the USB when
the laptop has a built-in card reader :)

The driver for the SD card in my XP laptop is a generic driver. It
reads the 8 GB card without problems but once the patition is
created it won't read it anymore, and it asks to reformat.
The same happens if I create the partition in the A590IS with chdk.

You don't like the AA batteries huh? :) Well I carry 4 Eneloop,
they retain the charge well, even after months.
 
Thanks again!



*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Partitions in 8 GB card not working
« Reply #8 on: 20 / February / 2010, 04:28:20 »
Quote
You don't like the AA batteries

I do, but since A590 has only 2, they run out more quickly ... and once you need to
open the cover anyway, might as well change cards.

(Pure theory though, don't think i ever filled a card within a day)

wim
« Last Edit: 20 / February / 2010, 04:31:57 by whim »

*

Offline dvip

  • ****
  • 451
Re: Partitions in 8 GB card not working
« Reply #9 on: 20 / February / 2010, 12:33:54 »

 

Related Topics