Partitions in 8 GB card not working - page 2 - General Help and Assistance on using CHDK stable releases - CHDK Forum

Partitions in 8 GB card not working

  • 15 Replies
  • 4774 Views
*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Partitions in 8 GB card not working
« Reply #10 on: 20 / February / 2010, 14:14:11 »
Advertisements
@dvip

About video: keep in mind that any single video can not be larger than 4 GB

whim

*

Offline dvip

  • ****
  • 451
Re: Partitions in 8 GB card not working
« Reply #11 on: 20 / February / 2010, 22:02:37 »
>About video: keep in mind that any single video can not be larger than 4 GB

Thanks for the advise, Whim.

I also wonder if those two AA batteries have enough juice to create
a 4 GB video. Maybe if I turn the LCD display off... and attach a solar panel? :)

On the other hand, the A590IS is not the best when it comes to
videos, but they are acceptable.

What I like about the A590IS is the manual control and how with chdk
it can do so many things.  I like the Canon G11 too, could be my next one,
but no AA batteries there, lol :)  Maybe a G12 in a year or so with chdk :)

The A590IS are now more expensive and hard to fine. I take good care of mine.




Re: Partitions in 8 GB card not working
« Reply #12 on: 02 / March / 2010, 23:44:02 »
i'm trying to use a 16GB card and I'm having trouble formatting it properly for either my a650 or g9. i can format it into two partitions on my mac but images aren't saved to the second partition.

i'm trying to use SDI installer but its not giving me the New Install button, only Format. Has anyone fixed this problem?

Re: Partitions in 8 GB card not working
« Reply #13 on: 07 / March / 2010, 11:25:35 »
Here's what works for me -

1) Format with the SDI installer.
This is a necessary step BUT the partitions won't display on either windows or os x. I suspect it has something to do with the partitions lacking labels.

2) Format the partitions under OS X, giving them labels.
For reasons I don't understand, formatting under os x alone isn't enough. Perhaps its because it Disk Utility will only do FAT16 and not FAT12.

3) Make small partition bootable.

4) Both partitions will be seen by the OS now. copy the small install to the small partition and the CHDK directory to the large partition.

5) Boot CHDK and use the menus to go Misc -> Debug Params -> Create card with two partition. Restart. Even though it warns that its going to erase everything on the card, it doesn't.

6) Images should now save to the larger partition.


*

Offline reyalp

  • ******
  • 13500
Re: Partitions in 8 GB card not working
« Reply #14 on: 07 / March / 2010, 18:03:30 »
Here's what works for me -
The above suggestion gives a high risk of creating a card with invalid partitions, leading to data loss. In particular, if the partitions created/formatted #1 and #2 don't exactly match the partitions created in the #5), it may appear OK at first but Bad Things will happen when you fill up the card. A safer approach would be to use "make card with two partitions" first, and then format in the mac.

I suggest reading and understanding http://chdk.wikia.com/wiki/Bootable_SD_card and http://chdk.wikia.com/wiki/FAQ/Mac and taking the appropriate steps under your OS to achieve the required partition layout. Throwing a bunch of tools at it without understanding what they are doing is a recipe for problems.

It should also be made clear that #3 is the canon BOOTDISK string, not any normal disk tools "make bootable" option.
Don't forget what the H stands for.

Re: Partitions in 8 GB card not working
« Reply #15 on: 08 / March / 2010, 19:47:58 »
>>I suggest reading and understanding

I'll read them now that I know where the Mac page is. I've updated the Bootable SD card page to link to the Mac FAQ - which is 90% install directions.

Yes, this is much better and easier.

 

Related Topics