IXUS 130 (SD1400 IS) Porting Thread - page 8 - DryOS Development - CHDK Forum  

IXUS 130 (SD1400 IS) Porting Thread

  • 288 Replies
  • 77768 Views
*

Offline an0n

  • ***
  • 152
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #70 on: 10 / November / 2010, 01:56:45 »
Advertisements
hi emlyn, good work on the port. The User Guide will be helpful to you to learn some of the functions. The rectangle at the bottom of the screen is one of the file space indicators, it can be switched off, see page 33 of the guide, download a copy from here > http://chdk.wikia.com/wiki/File:CHDK_UserGuide_April_2009_A4.pdf it has been updated again recently.
A720IS.

Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #71 on: 10 / November / 2010, 03:07:27 »
That was just the way of proceeding I had in mind. Take the User Guide and go point by point checking what each function is suposed to do, and then, check if in deed, it does it properly.

Emlyn, I didn't have another cam to take a picture of my screen. But next time I will so that you can see it...
And yes, it is needed to register a github account. I will do it and write the issues I find, as precise as possible.

And the functions that work, I'll write them here for morale  ;)

*

Offline emlyn

  • **
  • 88
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #72 on: 10 / November / 2010, 04:50:31 »
hi emlyn, good work on the port. The User Guide will be helpful to you to learn some of the functions. The rectangle at the bottom of the screen is one of the file space indicators, it can be switched off
OK, in fact I now see there is a black bar inside indicating used space.

Quote
see page 33 of the guide, download a copy from here > http://chdk.wikia.com/wiki/File:CHDK_UserGuide_April_2009_A4.pdf it has been updated again recently.
Thanks, I've printed out the booklet version and will read through it.

*

Offline emlyn

  • **
  • 88
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #73 on: 11 / November / 2010, 18:20:39 »
I've been looking into the RAW file saving, there is something in capt_seq_task that I don't understand. Just after the big jump table, in case 0:

Code: [Select]
"loc_ff87a3dc:\n" // jumptable entry 0
"bl sub_ff87aca0\n"
        "bl     shooting_expo_param_override\n" // added
"bl sub_ff8780ac\n"

        // this code added to avoid some incorrect behavior if overrides are used.
        // but it can cause some unexpected side effects. In this case, remove this code!
        //"mov    r0, #0\n"
        //"str    r0, [r4, #36]\n"  // 0x24 fixes overrides  behavior at short shutter press

"ldr r0, [r4, #36]\n"
"cmp r0, #0\n" // 0x0
"beq loc_ff87a5f8\n" // <---- here.
"bl sub_ff879b80\n"
"mov r5, r0\n"
"ldr r0, [r4, #36]\n"
"cmp r0, #0\n" // 0x0
"beq loc_ff87a424\n"
"ldr r0, =0xc\n" // was: "mov ..., #12"
"bl sub_ff87f174\n"
"tst r0, #1\n" // 0x1
"strne r9, [r6, #16]\n"
"ldrne r0, [r5, #8]\n"
"orrne r0, r0, #1073741824\n" // 0x40000000
"strne r0, [r5, #8]\n"
"bne loc_ff87a5f8\n"
"loc_ff87a424:\n"
"mov r0, r5\n"
"bl sub_ff879e24\n"
"mov r0, r5\n"

//"bl sub_ff95f120\n"
"bl sub_ff95f120_my\n" // taskcreate_ShutterSoundTask()
        "bl     capt_seq_hook_raw_here\n" // added

The line marked "<---- here" always takes the branch, therefore execution never gets to capt_seq_hook_raw_here, which looks to me like where the RAW stuff takes place (at least it sets a flag that is picked up by the spy task).
But the commented out lines "to fix override behaviour" would also force the same thing, in which case I don't understand how the RAW capture would work...

So is what I see causing a problem? If it is normal, how does the RAW capture get triggered?


*

Offline reyalp

  • ******
  • 12106
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #74 on: 11 / November / 2010, 23:45:47 »
How did you decide to put raw hook there ? Normally it's in jumptable entry 1, which will happen in a completely different iteration of the main capt_seq loop.

Look at D10 for example.
Don't forget what the H stands for.

*

Offline emlyn

  • **
  • 88
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #75 on: 12 / November / 2010, 04:05:24 »
How did you decide to put raw hook there ? Normally it's in jumptable entry 1, which will happen in a completely different iteration of the main capt_seq loop.

I copied that from the pixeldoc2000's Ixus 300 / SD 4000 port. I know it's not complete, but it's still more advanced than my code, and is easier to follow than older cameras as the code is very similar.

Quote
Look at D10 for example.

OK that looks a bit different. I've implemented the changes and now it does get further. When I take a photo the screen goes black for quite a while then eventually the red led flashes, and it seems it switches off but does not retract the lens. At least it gives me something else to look into.

Thanks for the help.

*

Offline reyalp

  • ******
  • 12106
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #76 on: 12 / November / 2010, 12:59:57 »
Look at the romlog.

If raw saving takes to long, the camera may shut down because of watchdog or possibly an assert.

edit:
I think raw still isn't working in pixeldocs port, so probably not a good one to copy in this area ;)
Don't forget what the H stands for.

*

Offline pixeldoc2000

  • ****
  • 356
  • IXUS900Ti 1.00C, IXUS300HS 1.00D
    • pixel::doc homebase
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #77 on: 13 / November / 2010, 02:56:18 »
I think raw still isn't working in pixeldocs port, so probably not a good one to copy in this area ;)
You are right, raw isn't working on SD4000 yet.  :'(
But SX210 use simular code and RAW seems to work.

When I take a photo the screen goes black for quite a while then eventually the red led flashes, and it seems it switches off but does not retract the lens. At least it gives me something else to look into.
I had this issus too.
You need to verify if PARAM_FILE_COUNTER is correct. Use "Debug Paramenters -> Debug data display -> Params" to verify (parameter is a long numer which increase with every shot).
« Last Edit: 13 / November / 2010, 03:01:45 by pixeldoc2000 »


*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #78 on: 13 / November / 2010, 03:17:04 »
« Last Edit: 13 / November / 2010, 04:53:25 by asm1989 »

Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #79 on: 14 / November / 2010, 07:07:18 »

 

Related Topics