IXUS 130 (SD1400 IS) Porting Thread - page 21 - DryOS Development - CHDK Forum

IXUS 130 (SD1400 IS) Porting Thread

  • 288 Replies
  • 88971 Views
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #200 on: 15 / July / 2012, 19:34:51 »
Advertisements
Alright! The 960 bitmap width worked for my SD 1400IS... original firmware version C...

Excellent !   This is so much easier with an enthusiastic tester.  Yesterday morning it did not look like anyone had notice this camera for almost a year.

I'll rebuild the other f/w version and update the svn and post new builds.

Quote
There's a few little glitches when scrolling through menus... Also, it jumps back into the main shooting by itself window if you wait too long between menu changes... All features seem to be working (so-far)...
CHDK normally has "glitches" on the LCD when the Canon firmware writes to the display.  This tends to be worse in shooting mode than playback. 

The "jump back" thing is a new one on me -  I guess we will have to work on that.

« Last Edit: 15 / July / 2012, 19:44:34 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline reyalp

  • ******
  • 12739
Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #201 on: 15 / July / 2012, 19:42:51 »
The "jump back" thing is a new one on me -  I guess we will have to work on that.
May just be seeing the regular shooting screen after the menu gets blown away by a Canon screen update. It's easy to think you've left the menu at that point.
Don't forget what the H stands for.

Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #202 on: 15 / July / 2012, 19:45:06 »
The "jump back" thing is a new one on me -  I guess we will have to work on that.
May just be seeing the regular shooting screen after the menu gets blown away by a Canon screen update. It's easy to think you've left the menu at that point.
Press the Up or Down key ...
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #203 on: 15 / July / 2012, 19:51:27 »
New working versions are here :

link > ixus130 sd1400 firmware 1.00a

link > ixus130 sd1400 firmware 1.00c

If you download one of these, please provide some feedback here in the forum !! 
I don't own the camera and can't test the changes.  Thanks to soundsmith89 for helping here !

Even if your post is just one line saying "It works on my camera"  it will be very helpful.

Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #204 on: 15 / July / 2012, 21:23:35 »
The "jump back" thing is a new one on me -  I guess we will have to work on that.
May just be seeing the regular shooting screen after the menu gets blown away by a Canon screen update. It's easy to think you've left the menu at that point.
Press the Up or Down key ...

I see what you mean... I think it is the screen refreshes that you are talking about...

Anyways, only other issue I had was the method of booting into the firmware... I had to make an auto-boot card with CHDK on it, rather then being able to manually select wether or not I wanted to load CHDK...

Basically, I could not get a "load/update firmware" option to show up on the camera when I would boot into playback mode... The only way I can get the CHDK to load is to make an auto-boot SD card...

I'll try doing a manual load card a few more times, with different methods, but I ended up getting a 2GB card with one partition (FAT16) to auto-load fine... Gonna try a manual load on this card again, as well as using my usual 16GB card as a dual partition (FAT16-FAT32) card, both auto and manual load...

Thanks again for updating this model... (I like the compactness, and its flat black finish for shooting backstage while I'm working concerts and such)...

Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #205 on: 15 / July / 2012, 21:40:19 »
Anyways, only other issue I had was the method of booting into the firmware... I had to make an auto-boot card with CHDK on it, rather then being able to manually select wether or not I wanted to load CHDK...

Basically, I could not get a "load/update firmware" option to show up on the camera when I would boot into playback mode... The only way I can get the CHDK to load is to make an auto-boot SD card...
For reasons that vaguely have to do with encryption law,  I don't create the necessary ps.fi2 files myself.  So you can't do a "firmware update" boot.  If/when this gets into the autobuild it will be there.

Thanks again for updating this model... (I like the compactness, and its flat black finish for shooting backstage while I'm working concerts and such)...
I'm biased,  but the "high water mark" for me with Canon P&S cameras is the SD940 in flat black ... I have yet to see a Canon cam that comes close when you combine optics, size and battery life.  After the SD940, they went on a "cost down" effort - slightly larger, plastic rather than metal body ...etc..

« Last Edit: 15 / July / 2012, 21:52:29 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #206 on: 15 / July / 2012, 22:04:30 »
For reasons that vaguely have to do with encryption law,  I don't create the necessary ps.fi2 files myself.  So you can't do a "firmware update" boot.  If/when this gets into the autobuild it will be there.

I see... The auto-boot is fine with me anyways... I'll still have to fiddle with it to get it working on my 16GB card though... Sure its something that I'm missing when going through the process... no worries though...

Thanks again for updating this model... (I like the compactness, and its flat black finish for shooting backstage while I'm working concerts and such)...
I'm biased,  but the "high water mark" for me with Canon P&S cameras is the SD940 in flat black ... I have yet to see a Canon cam that comes close when you combine optics, size and battery life.  After the SD940, they went on a "cost down" effort - slightly larger, plastic rather than metal body ...etc..

I got my SD 1400IS as a clearance item, so I didn't pay full-price, but I did get it sealed new in-box... The SD940 and SD1400 are very similar looking bodies... Just an upgraded chip in the SD1400 I'm guessing (haven't compared  specs yet)...

Thanks again for the work...

Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #207 on: 15 / July / 2012, 22:22:06 »
I see... The auto-boot is fine with me anyways... I'll still have to fiddle with it to get it working on my 16GB card though... Sure its something that I'm missing when going through the process... no worries though...
Are you looking at this : http://chdk.wikia.com/wiki/Prepare_your_SD_card

I'd recommend the SDMinste.exe solution .. its what I use.

Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #208 on: 16 / July / 2012, 11:33:07 »
Hallo again,

just checked out with CHDK-Shell the 1993, compiled and installed with PTPCamGUI.
I see a Menu, and the few functions i tested were ok.

That is very fine work, thanks a lot.


One warning:
Code: [Select]
========== C:\CHDKSHELL\TRUNK\TRUNK1993\BIN\LOGS\ERR-IXUS130_SD1400-100C.TXT ==========

kbd.c: In function 'my_kbd_read_keys':
kbd.c:97:6: warning: implicit declaration of function '_GetKbdState' [-Wimplicit-function-declaration]



IXUS 970 IS 100b

Re: IXUS 130 (SD1400 IS) Porting Thread
« Reply #209 on: 16 / July / 2012, 17:14:19 »
Hallo,
there are two more issues here,

the minor one is with the color palette, some choices are not useful.
e.g. : the cursor bar in the menu only differs slightly from the underground.
The overrides area is nearly unvisible.

The second is hard to explain:
All CHDK stuff is visible on the screen on the right place.
When I press the shoot button half, all areas belonging to CHDK jump about two lines up.
The next halfshoot they jump back downwards.
This is always repeatable.

While I am writing a third thing:
The free storage field and the bar at the bottom and the raw quantity field are always flickering with random values.


So, enough for today.

IXUS 970 IS 100b

 

Related Topics