PowerShot SX210 IS - Porting Thread - page 32 - General Discussion and Assistance - CHDK Forum

PowerShot SX210 IS - Porting Thread

  • 589 Replies
  • 255079 Views
*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: PowerShot SX210 IS - Porting Thread
« Reply #310 on: 23 / October / 2010, 04:54:28 »
Advertisements
alvm, I upgraded it to the latest trunk958, the fulls source code and trunk its here:

http://es.drop.io/asm1989  -> sx210-ixus1000asm1989trunk958.zip

Only need to find out  fi2.inc  at platform folder, this cam uses d4a
« Last Edit: 23 / October / 2010, 05:19:26 by asm1989 »

Re: PowerShot SX210 IS - Porting Thread
« Reply #311 on: 23 / October / 2010, 19:57:07 »
Have GM1.00C firmware and CHDK RCv1.2.3. Camera hangs during recording, after shutter (focus) button followed zoom button.
« Last Edit: 23 / October / 2010, 19:59:48 by tachiorz »

*

Offline alvm

  • ***
  • 123
Re: PowerShot SX210 IS - Porting Thread
« Reply #312 on: 25 / October / 2010, 03:34:26 »
alvm, I upgraded it to the latest trunk958, the fulls source code and trunk its here:

http://es.drop.io/asm1989  -> sx210-ixus1000asm1989trunk958.zip

Only need to find out  fi2.inc  at platform folder, this cam uses d4a

Thanks, I've merged your code and 958 too, sx210is works. Will you use trunk958 for your further porting sx210?

Alex.
« Last Edit: 25 / October / 2010, 04:43:00 by alvm »

*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: PowerShot SX210 IS - Porting Thread
« Reply #313 on: 25 / October / 2010, 05:23:24 »
yes, i will use 958 from now on


*

Offline pixeldoc2000

  • ****
  • 356
  • IXUS900Ti 1.00C, IXUS300HS 1.00D
    • pixel::doc homebase
Re: PowerShot SX210 IS - Porting Thread
« Reply #314 on: 25 / October / 2010, 11:18:20 »
@asm1989
did you test Multi Partition Support yet? (boot with second FAT32 partition, Make bootable and swap partitions)?

On SD4000 looks like WriteSDCard firmware function does not work as expected. (Make bootable does nothing, swap partitions cause shutdown and create card with two partitions also cause shutdown).

*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: PowerShot SX210 IS - Porting Thread
« Reply #315 on: 25 / October / 2010, 11:57:03 »
no, didnt test it yet, just copied code


Radup, here you have two more dng tests: http://es.drop.io/chdk_sx210_rc   ->sx210dngtest2.zip
« Last Edit: 25 / October / 2010, 13:57:00 by asm1989 »

Re: PowerShot SX210 IS - Porting Thread
« Reply #316 on: 25 / October / 2010, 17:13:51 »
I have been following the thread and while I don't have anything to offer on programming, I do have this camera, and am willing to put it through some tests if someone would guide me to where and how I can load it up.

Looks like you guys are doing great!

Thanks

*

Offline RaduP

  • *****
  • 908
Re: PowerShot SX210 IS - Porting Thread
« Reply #317 on: 29 / October / 2010, 02:15:18 »
I got my SX210 and I am generally happy with it (because of CHDK) :D
Anyway, there is a small bug with the RAW capture, it seems that the first 10 or so pixels from each row are missing. Can you take a look at it?


*

Offline asm1989

  • *****
  • 527
  • SX720, SX260, SX210 & SX200
Re: PowerShot SX210 IS - Porting Thread
« Reply #318 on: 29 / October / 2010, 03:17:21 »
 @RaduP: maybe something related to the crpping at camera.h will take a look
- if you want to join dev 4 things missig
1.- iso override with flash active, seams to be a flaw of chdk in the new cams
2.- zebra didt dig into it yet
3.- edge, only correctly in 16:9
4.- include source in the trunk

hoping to get your expertise into sx210!

 @photogeek:
 -download CHDK-sx210is-ASM1989-RCv1.2.3.zip
from 
http://es.drop.io/chdk_sx210_rc

-unzip it in the root of the sd card
-start the cam in review - press menu - go down - firmware update
-test it and reoport issues/ tricks

*

Offline RaduP

  • *****
  • 908
Re: PowerShot SX210 IS - Porting Thread
« Reply #319 on: 29 / October / 2010, 05:37:46 »
I would love to, but unfortunately I am busy over my head with my work :/
I think you did an excellent job so far, only minor issues left. As for the source in the trunk, that I had a problem with even with my SD980 port, I suck at making patches.

 

Related Topics