A480 firmware problem?(solved now) - CHDK Releases - CHDK Forum
supplierdeeply

A480 firmware problem?(solved now)

  • 2 Replies
  • 3418 Views
A480 firmware problem?(solved now)
« on: 28 / April / 2010, 16:30:11 »
Advertisements
I tried A480 firmware.
It seems there is a bug.
 ubasic command set_prop 16, do not work.
set_prop 16 2
get_prop 16 x
 It can set up the value , but it can not control the flash. The flash can be turn on or off only by camera's menu(not chdk menu) setting.
Is there anybody else to try and  confirm it?
« Last Edit: 29 / April / 2010, 08:22:00 by color999 »

*

Offline fe50

  • ******
  • 3119
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: A480 firmware problem?
« Reply #1 on: 28 / April / 2010, 17:25:03 »
Hello & welcome, color999 !

It seems there is a bug.
No ;)
Quote
ubasic command set_prop 16, do not work.
#16 is the wrong propcase for your camera.
The A480 uses propset 2, so the flash can be controlled with propcase 143 on this camera !

--> http://chdk.wikia.com/wiki/PropertyCase#Digic_III_.26_Digic_IV

Here's a little sample script, written by msl, published in the german forum ([1]).
This script should work with all cameras using propset 1 or propset 2; propset 3 is not yet supported, but can be added easily when somebody add the propcase to the wikia table...

Code: (lua) [Select]
--[[
@title flash row sample
]]

function fastshoot()
   press("shoot_half")
   repeat
     sleep(1)
   until get_shooting() == true
   press("shoot_full")
   release("shoot_full")
   release("shoot_half")
   repeat
   sleep(1)
   until get_shooting() ~= true
end

function set_flash_mode(n)
if get_propset() == 2 then
set_prop(143,n)
else
set_prop(16,n)
end
end

flash_state = get_flash_mode()
set_flash_mode(2)
fastshoot()
set_flash_mode(1)
fastshoot()
set_flash_mode(flash_state)


Re: A480 firmware problem?
« Reply #2 on: 29 / April / 2010, 08:18:19 »
@fe50:
I tried propcase 143. It works well now.
Thank you very, very much.

 

Related Topics