SX20: "No image" in play mode, when saving as RAW is enabled - RAW Shooting and Processing - CHDK Forum supplierdeeply

SX20: "No image" in play mode, when saving as RAW is enabled

  • 2 Replies
  • 2978 Views
*

Offline henkg

  • *
  • 10
Advertisements
When I disable RAW, I can view previously recorded JPG images in play mode.
When RAW is enabled, I can view the JPG's that are taken in the current camera session. However, after a camera OFF / ON these JPG's aren't playable in the camera anymore. On startup, a "No image" message is displayed. (Using a cardreader I can see that JPG and DNG files still exist on the card).

CHDK settings:
- Save RAW: enabled
- Only first RAW in series: enabled
- RAW file in dir with JP: enabled
- RAW file prefix: CRW_
- RAW file extension: .CRW
- RAW substract pref: CRW_
- RAW substract extension: CRW
- DNG format: enabled
- DNG file extension: enabled
Card: 8Gb, formatted as FAT16 4 Gb (only one partition, auto boot)

Any suggestions?

(Not sure if this is a RAW forum, or a SX20 porting thread question ...)
« Last Edit: 01 / May / 2010, 07:12:33 by henkg »

*

Offline reyalp

  • ******
  • 13353
Re: SX20: "No image" in play mode, when saving as RAW is enabled
« Reply #1 on: 01 / May / 2010, 17:57:12 »
Try changing the prefix and/or extension of the DNG files.
I would suggest starting CRW_xxxx.CRW (turn DNG extension off). Note that the extension doesn't affect the actual format of the files. If you want them to have DNG extension on your PC, you'll have to batch rename them.
Don't forget what the H stands for.

*

Offline henkg

  • *
  • 10
Re: SX20: "No image" in play mode, when saving as RAW is enabled
« Reply #2 on: 13 / May / 2010, 06:44:31 »
Thanks.
Tried some settings.
Problem solved with:
- RAW file prefix: CRW_
- RAW file extension: .CR2
- Raw substract pref: IMG_
- Raw substract exte: .JPG
- DNG format: ON
- DNG file extension: OFF

About setting the DNG file extension to OFF:
Now files will be saved as DNG, with extension .CR2. I chose this to allow copying files using the USB camera <-> PC connection. Then .DNG files are not recognized, and .CR2 are. After copying I change the file extension from . CR2 to .DNG

 

Related Topics