PS G9: Completely black LCD Screen and Photos after upload of CHDK - General Help and Assistance on using CHDK stable releases - CHDK Forum  

PS G9: Completely black LCD Screen and Photos after upload of CHDK

  • 4 Replies
  • 1827 Views
Advertisements
Hello,

I am a completely CHDK newbie.

Ver.req says I have a G9 with firmware GM1.00g which I bought 2 years ago from Hong Kong and had worked fine until now.
After uploading the 1.00G version from the autobuild server using CardTricks and running the firm update the LCD is completely black and photos I take also are completely black. The LCD is ok since it still displays photos from the memory card. But photos taken with the camera are completely black on the PC.

Starting the camera with a second SD card without CHDK did not make a difference. I read CHDK does not alter the camera firmware. Which suggests the problem is not related to CHDK. However, it is very unlikely that the camera failed at the same time that I try out CHDK without there being a relationship between the two events.

These are questions I think might lead to a solution:
1. Has anybody heard of a similar phenomena?

2. Is there anything to completely reset the camera to factory defaults?

3. In order to remove CHDK from the camera is there more to it than inserting a blank SD card?

Thanks for your help.

*

Offline ERR99

  • ****
  • 339
Re: PS G9: Completely black LCD Screen and Photos after upload of CHDK
« Reply #1 on: 19 / May / 2010, 08:53:51 »
3. In order to remove CHDK from the camera is there more to it than inserting a blank SD card?
No. Because CHDK does not write something into the camera flash. It is only loaded from the SD-CARD into the RAM. If you remove the SD-CARD and remove the battery from the camera, CHDK is completely gone.

Did you also got a black pictures if you set the camera into complete automatic mode (P-Mode or the green square)? What happens if you try to record movies, are there also black without sound?

Re: PS G9: Completely black LCD Screen and Photos after upload of CHDK
« Reply #2 on: 19 / May / 2010, 15:08:19 »
Hello,

thanks for your reply.
Yes, the problem exists in the P-mode as well. In the video mode, the sound is fine only the pictures are all black too.

Any other suggestions?

*

Offline fe50

  • ******
  • 3105
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: PS G9: Completely black LCD Screen and Photos after upload of CHDK
« Reply #3 on: 20 / May / 2010, 01:53:11 »
Looks like the shutter stays closed, maybe a mechanical issue;
does the camera report an error in the advanced firmware info page (vers.req method) ?

Does the display show the liveview or is it also black in record mode ?

Maybe shaking the camera a bit or maybe knocking (softly ;) ) to the side of the camera body could help...


Re: PS G9: Completely black LCD Screen and Photos after upload of CHDK
« Reply #4 on: 21 / May / 2010, 15:56:28 »
Hello,

thanks for your answer.
I don't think it's the shutter:
When I look into it, i see it close when I take a photo and open afterwards? Hey, i don't think I completely understand - shouln't it open when I take a photo. Anyway, I see something moving inside the lens.
Also, the live is black. The finder however is not which is another reason I assume, the shutter is ok.

The canon support is very brief. They said, there is nothing I can do myself apart from taking it to a repair shop.
:-(

 

Related Topics