D10 porting thread - page 3 - DryOS Development - CHDK Forum supplierdeeply

D10 porting thread

  • 131 Replies
  • 60686 Views
Re: D10 porting thread
« Reply #20 on: 04 / July / 2010, 02:57:42 »
Advertisements
Hey reyalp, that works fine but I'd still like to use a script to avoid possible motion from keeping the button pressed in for the number of shots needed.  Alignment becomes a problem if camera movement is introduced while keeping the shutter button pressed in even with a tripod because the D10's waterproof button is kind of hard to press.  The custom timer function doesn't work with bracketing either,  all shots have the same exposure.  A simple script with a start delay, total number of shots, and bracketing values would do the job nicely, but none of the scripts I have tried has worked.  All shots have the same exposures.  I will dig a little further to see if I can figure what is happening.  Thanks again for bringing us this port!

*

Offline reyalp

  • ******
  • 13457
Re: D10 porting thread
« Reply #21 on: 04 / July / 2010, 16:30:14 »
Hey reyalp, that works fine but I'd still like to use a script to avoid possible motion from keeping the button pressed in for the number of shots needed.
Absolutely, if script overrides don't work, this needs to be fixed.

It's probably best to start by testing a trivial script (e.g. one that just sets Tv and shoots) rather than a whole bracketing script.
Quote
Alignment becomes a problem if camera movement is introduced while keeping the shutter button pressed in even with a tripod because the D10's waterproof button is kind of hard to press.
Agreed.
Speaking of buttons, has anyone else noticed that the zoom buttons frequently skip a step ? I initially thought there was only 5 zoom levels, wondering if this is just my camera.
Quote
  The custom timer function doesn't work with bracketing either
Bracketing should work with the customer timer, I'll have to look at that.
Don't forget what the H stands for.

Re: D10 porting thread
« Reply #22 on: 04 / July / 2010, 19:35:01 »
I appreciate your time reyalp.

Here is a link to a lua script that I found that finally worked.

http://chdk.setepontos.com/index.php/topic,2806.0.html
« Last Edit: 04 / July / 2010, 21:36:07 by sbpoole »

Re: D10 porting thread
« Reply #23 on: 10 / July / 2010, 02:46:31 »
This is fantastic progress. Thank you.

Only thing high on my wishlist now is multi partition support so I can use all of my 8Gb cards when I go cycle touring!
Is this difficult to add?

If I can add one thing... the little OSD thingies are very difficult to read. I adjusted the menu font to max (20pt) which makes the menus just fine. Any chance the OSD items can be made bigger? Or is it there already staring me in the face?


Re: D10 porting thread
« Reply #24 on: 10 / July / 2010, 06:04:24 »
Thank you, Reyalp.
I have been waiting for this and have ordered a D10 this morning to replace my ageing Pentax WP.

Re: D10 porting thread
« Reply #25 on: 10 / July / 2010, 16:10:53 »
I got it to work Reyalp! 

woo-Wooooo!  I'm going to try some scripts now...
-- -----------
7D, D10

*

Offline reyalp

  • ******
  • 13457
Re: D10 porting thread
« Reply #26 on: 10 / July / 2010, 17:35:19 »
This is fantastic progress. Thank you.

Only thing high on my wishlist now is multi partition support so I can use all of my 8Gb cards when I go cycle touring!
Is this difficult to add?
Not hard, just time. I'll see if I can get to it this weekend, but no promise.
Quote
If I can add one thing... the little OSD thingies are very difficult to read. I adjusted the menu font to max (20pt) which makes the menus just fine. Any chance the OSD items can be made bigger?
Maybe. The D10 (like the SD990 and some other cameras) has a higher resolution OSD display, which makes the OSD elements smaller. Some cameras have various workarounds related to this, but I haven't fully digested how they work.
Don't forget what the H stands for.

Re: D10 porting thread
« Reply #27 on: 13 / July / 2010, 00:03:26 »
shot yesterday with a MD script

-- -----------
7D, D10


Re: D10 porting thread
« Reply #28 on: 13 / July / 2010, 17:33:46 »
New D10 arrived today, along with the overpriced but in fairness appropriate Canon neoprene case (both bought just to run Reyalps firmware - see message a couple of days back)

Got the firmware running with no issues.
Spent AGES trying to display a CRW file on the PC, trying DNG4PS2, DCRaw, DCRawMS, RawTherapee, and DNG Converter until I finally realised I could convert to DNG in camera.

Spent 4 minutes modifying Pixmantec RawShooter to work with the DNG file. I love that program.

Spent AGES trying to get the firmware to autoboot with "make card bootable", reformatting the SD card with various methods. It simply would not work. Had to resort to CardTricks which worked first time.

In summary - delighted with DNG, thank you, and am looking forward to using it in anger in the Black Sea next week, but am unable to use the "make card bootable" function on a Sandisk Ultra II 2GB Fat16 card.

BlinkTooFast

Re: D10 porting thread
« Reply #29 on: 14 / July / 2010, 08:32:29 »
so.. does chdk have to be loaded on each sd card separately?

 

Related Topics