S5IS issue: "uBasic: 2 Unk stmt" - General Help and Assistance on using CHDK stable releases - CHDK Forum  

S5IS issue: "uBasic: 2 Unk stmt"

  • 2 Replies
  • 2371 Views
S5IS issue: "uBasic: 2 Unk stmt"
« on: 07 / June / 2010, 16:12:36 »
Advertisements
Hi guys,
I have successfully installed CHDK on my S5IS. Getting to alt mode is OK, the menus appear as they are supposed to, but when I try to run a script the machine freezes and will not shoot a photo. In the left upper corner the message "uBasic: 2 Unk stmt" appears. Any ideas to get it work would be much appreciated.

*

Offline fe50

  • ******
  • 3115
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: S5IS issue: "uBasic: 2 Unk stmt"
« Reply #1 on: 07 / June / 2010, 17:16:19 »
Hello & welcome, gocsal !

when I try to run a script the machine freezes and will not shoot a photo. In the left upper corner the message "uBasic: 2 Unk stmt" appears.
The script you've loaded is not a valid script, at least line 2 is incorrect; probably the file is not a plain text file.
The camera does not freze - just press the shutter to stop/exit the script, then load a valid uBasic or Lua script.
Read also here for CHDK scripting, for Lua scripts you'll find more informations here.

CHDK scripts are
  • plain text files, no MS Word, Wordpad or similar documents; use a simple text editor, e.g. Notepad or Notepad++ on MS Windows.
  • save the text files with ANSI encoding (NOT unicode !)
  • for uBasic scripts, use .bas as filename extension, for Lua use .lua

Re: S5IS issue: "uBasic: 2 Unk stmt"
« Reply #2 on: 08 / June / 2010, 11:58:53 »
Many thanks for your reply - we discovered a very simple error that we made. The error message occurred when we tried to shoot when still in alt mode. After leaving alt mode - shooting worked. Thanks again!

 

Related Topics