Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!! - page 11 - Feature Requests - CHDK Forum

Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!

  • 213 Replies
  • 86060 Views
*

Offline Pier

  • ***
  • 128
Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #100 on: 01 / December / 2013, 13:31:13 »
Advertisements
Tested with SX130 IS 101C my build from trunk 3258 and videxp3.lua (the last one)
Tested only indoor with ISO till 1600.No crash occured during tests
Exelent, brilliant job.Thanks very very much to all made this possible.

Pier
« Last Edit: 01 / December / 2013, 13:35:23 by Pier »

*

Offline hue

  • *
  • 2
Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #101 on: 02 / December / 2013, 06:42:46 »
Hey everyone, i tried this script in my sx150is today and i am getting stuck at ": 225 : native calls disabled"
on sx150is-100a-1.3.0-3259, can you guys please if you can help me out on this? And thank you for making this possible. (if not for my own cam but others  :))

Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #102 on: 02 / December / 2013, 07:17:42 »
One thing i do not like on my canons(a590is, sx130): one cannot adjust default-video-exposure. In nikon p50 i can adjust that value. I dont like to adjust that value every time when starting to shoot. depending the situation i have the feeling than canon-videos are overexposing. Yes i know sometime reducing contrast and saturation helps.
had to adjust exposure for this 3dstereovideo(still unofficial-its SDM186-with moviesynch/sensorcable used to adjust synch-lasers were too speedy in that shoot)
www.3dmusic.ch or channel www.3dmedia.ch more will come.
will start testing a590is. hesitate sx130 since i only have two cams...!
Confusing:
: for CHDK v1.3.0 or greater
i see-some threads earlier- that someone succesfully tested SX130. but there is neighter for SX130 nor A590is version 1.3.0 available.
both still 1.2.0.
 
« Last Edit: 02 / December / 2013, 07:29:24 by europanorama »
A590 IS-1.01b(x5), SX130IS-101c(x3), 101f(x2)
3dstereo-aeropanorama-Jungfraujoch
http://www.stereopan.tk

Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #103 on: 02 / December / 2013, 07:58:11 »
Hey everyone, i tried this script in my sx150is today and i am getting stuck at ": 225 : native calls disabled"
on sx150is-100a-1.3.0-3259, can you guys please if you can help me out on this? And thank you for making this possible. (if not for my own cam but others  :))
Go to the CHDK Miscellaneous menu and set Enable Lua Native Calls.
Ported :   A1200    SD940   G10    Powershot N    G16


Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #104 on: 02 / December / 2013, 07:59:26 »
i see-some threads earlier- that someone succesfully tested SX130. but there is neighter for SX130 nor A590is version 1.3.0 available.
both still 1.2.0.
http://mighty-hoernsche.de/trunk/
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline hue

  • *
  • 2
Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #105 on: 02 / December / 2013, 08:38:30 »
-
Go to the CHDK Miscellaneous menu and set Enable Lua Native Calls.
wow, i should have looked around, thanks! It's working flawlessly on my SX150IS, thanks alot.

i see-some threads earlier- that someone succesfully tested SX130. but there is neighter for SX130 nor A590is version 1.3.0 available.
both still 1.2.0.
http://mighty-hoernsche.de/trunk/
This, v1.3.0 are the developer/unstable versions listed in the wikia.

Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #106 on: 02 / December / 2013, 10:28:22 »
This, v1.3.0 are the developer/unstable versions listed in the wikia.
Yes they are.  These new versions contain new features required by the script.   Don't worry about the term "unstable" - these builds are very usable and you should not have any problems.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #107 on: 04 / December / 2013, 07:05:06 »
An SDM user has asked if this feature is supported.
It is not and I would be very reluctant to add it.

Quite simply, why should it be added  ... because it can be or because it is genuinely useful ?

Consider this from a Pro canon 5d user :-

"in filmmaking, your shutter speed will always be half your frame rate for normal film capture.
Anything more or less will reduce the filmic look of your footage"

http://kriskoster.com/2010/08/optimising-your-5d-mark-ii-for-filmmaking/

High shutter speeds produce a jerky effect, stopping-down the aperture reduces sharpness.



« Last Edit: 04 / December / 2013, 07:31:55 by Microfunguy »


Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #108 on: 16 / January / 2014, 13:47:25 »
This is very exciting! Has anyone tested this script out on an Elph 300HS (Ixus 220)?

Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #109 on: 17 / January / 2014, 15:19:37 »
I tested this out on my Elph 300HS(Ixus 220) and sadly it only works until the video recording starts. Then the settings no longer work and auto exposure kicks into gear. Can someone help me fix the script so that it can work?

 

Related Topics