Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!! - page 8 - Feature Requests - CHDK Forum
supplierdeeply

Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!

  • 213 Replies
  • 85987 Views
sx40 canon full manual video controll can it be made?
« Reply #70 on: 25 / November / 2013, 03:32:23 »
Advertisements
hi can any one make the canon sx40 to record video on full manual control ?
when i go to manual mode and take a pic i see very good pic but as soon that i record the video the camera go's to automatic control and its bad ,the pic jast is not good.
can some one make a script for it or is it not possible  to do it.
do i need a different camera
thanks

Re: sx40 canon full manual video controll can it be made?
« Reply #71 on: 25 / November / 2013, 08:31:48 »
Manual exposure control in video mode is not currently available with CHDK.   It might be technically possible and people have probably experimented with the idea,  but its not supported.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: sx40 canon full manual video controll can it be made?
« Reply #72 on: 25 / November / 2013, 17:17:09 »
hi waterwingz
can you explain more on it ? i saw a post on canon a series can't remember the no,but they say hear that you can record manualy on it with the chdk and can select iso Shutter ...
so if you can explain on what may be the problem,i knew a lot will like it if it can be made full manual
thanks uzi 

*

Offline srsa_4c

  • ******
  • 4426
Re: sx40 canon full manual video controll can it be made?
« Reply #73 on: 25 / November / 2013, 17:29:35 »
hi can any one make the canon sx40 to record video on full manual control ?
I don't know whether it's working on your camera, but there is this script:

http://chdk.setepontos.com/index.php?topic=5295.msg68622#msg68622

Don't expect too much reliability, it can crash the camera easily.


Re: sx40 canon full manual video controll can it be made?
« Reply #74 on: 25 / November / 2013, 17:56:51 »
hi can any one make the canon sx40 to record video on full manual control ?
I don't know whether it's working on your camera, but there is this script:

http://chdk.setepontos.com/index.php?topic=5295.msg68622#msg68622

Don't expect too much reliability, it can crash the camera easily.
This actually runs pretty well on my A1200 & G10 - once I change lines 256/257 to adjust for not having a video button.   With a little cleanup of the GUI (using Lua drawing maybe) and some additional code to allow the zoom to operate,  this could be quite useful.  Especially now that we can enable native calls without a special build.
« Last Edit: 25 / November / 2013, 18:12:27 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Online reyalp

  • ******
  • 13438
Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #75 on: 25 / November / 2013, 22:51:23 »
By request, merged sx40 discussion into this thread.
Don't forget what the H stands for.

Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #76 on: 26 / November / 2013, 14:23:25 »
I took a few minutes to play with fudgey's script and convert the GUI (attached below).  Works with cameras that have a video button (if they are in video mode) and with cameras without a seperate video button.  It also adds the ability to use the zoom while the script is running.

It runs well on my G10, A1200 and SD940.  As a bonus, on the A1200 & SD940, adjusting the aperture engages the ND filter as those cameras do not have an adjustable aperture. (Note: that if you run the script while not in video mode,  the exposure adjusts but the ND filter does not engage when Av is adjusted).




Sadly,  with the same script loaded on my SX50 it does not want to stay in AELock - resetting the exposure a few seconds after I adjust it manually.   The SX50 also locked up when I ran the ISO up to 3200.  I did not see either of these issues with my other cameras so YMMV.

Update : The initialization of the Tv, Av, & Sv values is still not quite correct.  To be safe, I think that you need to adjust them each up & down prior to starting recording.
« Last Edit: 26 / November / 2013, 15:36:42 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline srsa_4c

  • ******
  • 4426
Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #77 on: 26 / November / 2013, 14:51:11 »
Sadly,  with the same script loaded on my SX50 it does not want to stay in AELock - resetting the exposure a few seconds after I adjust it manually.
Does it make a difference if you lock AE using the Canon UI before recording?


Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #78 on: 26 / November / 2013, 15:28:48 »
Does it make a difference if you lock AE using the Canon UI before recording?
Not sure that Canon AE lock is an option in video mode - nothing about it in the manual and I can't seem to convince it otherwise. 

Using a half press and the UP button on the mode dial engages AEL for the next still shot.  Activating video recording in that mode seems to just reset it.
« Last Edit: 26 / November / 2013, 15:35:11 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline srsa_4c

  • ******
  • 4426
Re: Video Manual Control: ISO, APERTURE & SHUTTER SPEED CONTROL, PLEASE!!!!
« Reply #79 on: 26 / November / 2013, 15:47:42 »
Using a half press and the UP button on the mode dial engages AEL for the next still shot.  Activating video recording in that mode seems to just reset it.
It should be available in movie mode (mode dial explicitly set to movie mode), but they don't call this AE lock, see manual page 110.

 

Related Topics