Canon Powershot A540 lens protection flaps stucks - Hotwire! Hardware Mods, Accessories and Insights - CHDK Forum supplierdeeply

Canon Powershot A540 lens protection flaps stucks

  • 2 Replies
  • 3268 Views
Canon Powershot A540 lens protection flaps stucks
« on: 04 / August / 2010, 10:36:53 »
Advertisements
Hi,

I think my A540 is starting to die on me. About 50% of the times it doesn't close or open the lens protection flaps as it should. I attach an image of how it looks. Does anybody have any ideas for how to fix it?

You can see an image here: http://static.olalindberg.com/2010/canon-a540-lens-protection-problem.jpg

Thanks in advance

*

Offline fvdk

  • ***
  • 146
  • Ixus 70 1.01b / 1.02a & Powershot A590is 1.01b
    • My Flickr photo page
Re: Canon Powershot A540 lens protection flaps stucks
« Reply #1 on: 04 / August / 2010, 12:38:16 »
Hi,

I think my A540 is starting to die on me. About 50% of the times it doesn't close or open the lens protection flaps as it should. I attach an image of how it looks. Does anybody have any ideas for how to fix it?

You can see an image here: http://static.olalindberg.com/2010/canon-a540-lens-protection-problem.jpg

Thanks in advance

Does it also happen without CHDK?
I once had this problem with one of my A590's and it was solved with a reformat of the card and a new install.

Frans

Re: Canon Powershot A540 lens protection flaps stucks
« Reply #2 on: 04 / August / 2010, 16:57:17 »
Yes it happens even when I'm not running chdk. I think it's a hardware failure or maybe some dirt at the open / close mechanisms?

 

Related Topics