Powershot A3100 - Porting thread - page 9 - DryOS Development - CHDK Forum  

Powershot A3100 - Porting thread

  • 139 Replies
  • 48085 Views
*

Offline nafraf

  • *****
  • 1308
Re: Powershot A3100 - Porting thread
« Reply #80 on: 13 / December / 2012, 17:42:27 »
Advertisements
Hi.. What about the 100b version of A3100? I have that one.. Is the build still under construction? I saw that there is an untested bootable sd card version. What about firmware version?
casrap ported 100b, but it was not tested. Check reply 64 of this thread.  Source is available in svn repository.

Quote
Is there a guide about how to build CHDK for cameras? Is it so difficult? I want to learn about it.
For_Developers
Compiling the CHDK under GNU/Linux
Compiling the CHDK under Mac OS X
Compiling the CHDK under Windows

Re: Powershot A3100 - Porting thread
« Reply #81 on: 13 / December / 2012, 20:23:48 »
So the 100b firmware really exists :D
Can you let us know if the port works or not?

Re: Powershot A3100 - Porting thread
« Reply #82 on: 04 / January / 2013, 14:04:00 »
Hi! It's really nice to see that you people are working at the A3100, sadly CHDK doesn't work with my precious cam, as it has a firmware 1.00A.
I beg the masters of bits and bytes to check if you can port CHDK also to this firmware.
I've dumped the 1.00A-firmware to: DUMP_FF810000_A3100_1.00A.BIN.7z - 1.7 Mb
Thanks and Greetz!

*

Offline fe50

  • ******
  • 3131
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Powershot A3100 - Porting thread
« Reply #83 on: 05 / January / 2013, 05:54:11 »
Hello & welcome, Nonatoka !

Thanks for the dump...
Added the
  • A3100 1.00A
full 8MB dump (dumped with cBasic udumper) by Nonatoka from this forum post to the CHDK P&S FW dumps repository.


Re: Powershot A3100 - Porting thread
« Reply #84 on: 05 / January / 2013, 10:32:01 »
CHDK ported to 100a, full package (use bootable sdcard method to install);
<links removed, see below>

Source (if working to be included in the trunk by some kind soul);
<links removed, see below>

Please remember to leave feedback!
« Last Edit: 05 / January / 2013, 18:40:01 by casrap »

Re: Powershot A3100 - Porting thread
« Reply #85 on: 05 / January / 2013, 10:52:38 »
Source (if working to be included in the trunk by some kind soul);
https://www.box.com/s/tmq2zq8kmi9dga6sn21u
Built a patch file for you from this. Submit it when you are ready.

Have you looked at using the svn tools for this (TortoiseSVN for window) ?
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Powershot A3100 - Porting thread
« Reply #86 on: 05 / January / 2013, 13:31:32 »
I tried tortoise, but i don't think its for me. I would only use it for chdk and i'm all out of unsupported camera's.. :P
+ i'm always busy working on other projects.

Re: Powershot A3100 - Porting thread
« Reply #87 on: 05 / January / 2013, 16:13:59 »
Wow, you're are faster than light!
Thanks to fe50 and casrap for all the work!
But sadly the firmware doesn't work as intended...  :'(
I've used the "LICKS"-Java-programm to format (FAT16) and copy the data from the full package. I hope that I did everything right. - If you want to check; there is an image of the sdcard that I'm using here (756.0 Kb/2.0 Gb).
If the cam is started (lock to "on") there is a very short time of displaying build number, date and target "A3100 100a" - most times only partially - and then the cam just switches off, independent of pushing the buttons play or on. If I push "on" long time the lens starts to move but stops suddendly - next cycle I've got quite disturbing sounds from the motor/gears. I can also activate the clock by pressing func on start up - lasts about 2s before shut down, too.
Anyhow - If I put the lock to off, the cam starts normally.
Are there any special bits to activate some kind of "crash message"? I had understand that the "update firmware" method needs another build, could this show some additonal information? The DISKBOOT.BIN of 100a is quite smaller than 100d. Is this ok?
Thanks again and greetz!


Re: Powershot A3100 - Porting thread
« Reply #88 on: 05 / January / 2013, 16:38:52 »
I'll check the source once more in a few hours. I'll keep you updated.
..
..
I've found a missed copy&paste of a call to a subroutine in boot.c, try this updated package;
https://www.box.com/s/8f63cd7k09cct7n3675y

(src: https://www.box.com/s/bjf1cr8ek22zqdlmo69v)
« Last Edit: 05 / January / 2013, 18:39:12 by casrap »

Re: Powershot A3100 - Porting thread
« Reply #89 on: 06 / January / 2013, 12:06:54 »
Thanks for this fast bugfixing!
I would say, we are almost there... Now I do see the CHDK-logo and the full build/version text ... but after that the cam switches off. I did a small movie (1.6 Mb) to show the behaviour.
Do you want to check the sources again, or is there anything I can do from here?

 

Related Topics