Camera damaged!!!!!!!did chdk do it!!!!!! - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum  

Camera damaged!!!!!!!did chdk do it!!!!!!

  • 6 Replies
  • 3379 Views
Camera damaged!!!!!!!did chdk do it!!!!!!
« on: 17 / August / 2010, 06:43:09 »
Advertisements
hi ,iam a newbee ,i started using chdk on my powershot a550 few mnths  back,really loved the great new features,but something happened yesterday ,i was taking some fast shutter shots ,i cranked up the shutter speed to 1/100k tooka few shots and then suddenly after a few shots i saw picture coming out as film negetives ,so i removed chdk  a took some shots again  though this time the photos were normal on first glance but on further inspection it was seen that it had some white horizontal lines ,daytime shota were hugely overexposed totally burnt,so today i went to canon service cente and they said the shutter may have been busted and total lens assembly has to be change,total charge wud be  about 80 dollars ,so iam asking can chdk ever cause this problem???????

*

Offline reyalp

  • ******
  • 13387
Re: Camera damaged!!!!!!!did chdk do it!!!!!!
« Reply #1 on: 17 / August / 2010, 12:51:32 »
http://chdk.wikia.com/wiki/FAQ#Q._Can_CHDK_damage_your_camera.C2.A0.3F

This could fall under
"By commanding physical hardware to do something it was not designed to do"

Or it could be coincidental, the a550 is pretty old, so it wouldn't be entirely surprising if it had just reached the end of it's life.

Very difficult to tell.

Do you know how many exposures the camera had it in it's lifetime ?

edit:
A fairly large number of people have used high speed overrides at least a few times without destroying their camera.
« Last Edit: 17 / August / 2010, 12:54:05 by reyalp »
Don't forget what the H stands for.

Re: Camera damaged!!!!!!!did chdk do it!!!!!!
« Reply #2 on: 17 / August / 2010, 13:25:34 »
see i bought the camera on july 2007,uptill now i guess about 4-5000 photos have been taken,i also visited an unofficial repair shop ,they r saying it wud cost me around 40 dollars to get it repaired ,how can i post some images here for reference!!!!!!the video mode is fine!!!!!!

*

Offline fudgey

  • *****
  • 1705
  • a570is
Re: Camera damaged!!!!!!!did chdk do it!!!!!!
« Reply #3 on: 17 / August / 2010, 13:35:39 »
My a570 has >120000 shots in its counter and it's alive and well. in the past I have experimented with these extremely fast shutter speeds for hundreds of shots. I don't remember anyone reporting anything similar, but it's quite clear that your camera is broken. :(

It's of course possible that one of the reasons Canon limits Tv mode to not much faster than 1 ms is endurance. But note that the way these cameras are built, the mechanical shutter doesn't actually determine exposure time, the electronic shutter does. The mechanical shutter is there to cover the sensor during readout and during a dark frame noise reduction exposures after the electronic shutter has started & ended the actual exposure.

Therefore it may be assumed that exposure time doesn't affect the mechanical shutter's stress at all, even at the extremely fast override end. But only Canon would know for sure, I'm afraid.


*

Offline reyalp

  • ******
  • 13387
Re: Camera damaged!!!!!!!did chdk do it!!!!!!
« Reply #4 on: 17 / August / 2010, 13:37:41 »
see i bought the camera on july 2007,uptill now i guess about 4-5000 photos have been taken
If it has been treated well (not exposed to a lot of dirt/dust, not handled roughly etc), this would be very early for it to fail.
Quote
,i also visited an unofficial repair shop ,they r saying it wud cost me around 40 dollars to get it repaired ,how can i post some images here for reference!!!!!!
Use an image hosting site. Images will not help determine whether this was caused by CHDK or not.
Quote
the video mode is fine!!!!!!
This would expected if the mechanical shutter failed.

edit:
I've updated the FAQ entry slightly, and added this to http://chdk.wikia.com/wiki/Camera_failures_suspected_to_be_caused_by_CHDK
« Last Edit: 17 / August / 2010, 13:42:56 by reyalp »
Don't forget what the H stands for.

*

Offline fudgey

  • *****
  • 1705
  • a570is
Re: Camera damaged!!!!!!!did chdk do it!!!!!!
« Reply #5 on: 17 / August / 2010, 13:42:06 »
how can i post some images here for reference!!!!!!the video mode is fine!!!!!!

Seems like forum file/photo attachments are disabled at the moment, so you'd have to use an external photo upload site and add links.

If the video mode is fine (even exposure is correct), then the fault really probably is in the shutter -- the video mode doesn't use the shutter at all (well the shutter must remain fully open of course, but it's never closed, and I guess you have a problem with the shutter not reliably fully closing in time or at all -- you can get those weird stripes you mentioned when the CCD isn't covered during readout. You can actually see the same thing happening in video mode even with a shiny new camera if you point it at a light source).

Re: Camera damaged!!!!!!!did chdk do it!!!!!!
« Reply #6 on: 18 / August / 2010, 01:38:55 »
@ reyalp,thanks for linking it .here r two photos  IMG_1934
IMG_1931 if you see the full size u can see the lines iam talking about!!!!!!!

 

Related Topics