A495 porting thread - page 11 - DryOS Development - CHDK Forum supplierdeeply

A495 porting thread

  • 346 Replies
  • 114086 Views
Re: A495 porting thread
« Reply #100 on: 30 / May / 2011, 09:50:00 »
Advertisements
Hi waterwings,

good idea to move the diskussion.

I have photographed the two screens. (sry for bad quality - was my handycam) ^^

1) no - it looks not that - it is without the logo (look to attachement)

2) the cam crashes totaly - no buttons are responding - to turn it off i have to remove the batteries

3) jep - white text on black screen - seens to be a message from the standart canon firmware

I have also tried to start the Firmware with the firmware update, but then the cam totaly crashes without any messages and show a black screen (or go maybe to off-status)

Hope this answers help a bit

Re: A495 porting thread
« Reply #101 on: 30 / May / 2011, 10:01:02 »
I have photographed the two screens. (sry for bad quality - was my handycam) ^^
The pictures are perfect - great idea !  The German words for "Memory Card Locked" are interesting - you don't normally see them when booting CHDK from a locked card as far as I know.  Maybe I have a bug in boot.c where both CHDK and the Canon firmware are running at the same time.

Quote
1) no - it looks not that - it is without the logo (look to attachement)
2) the cam crashes totaly - no buttons are responding - to turn it off i have to remove the batteries
3) jep - white text on black screen - seens to be a message from the standart canon firmware
The camera is crashing during the startup of the spy_task.   It normally draws the text box you see and then the logo as part of startup .   This might give me a clue as to which stub is not right but we could be in for a bunch of work here as I have no way to debug this other than send updates for you to try.   Another forum member has volunteered to try the 1.00e version as well today - we will see what he finds out.
Quote
I have also tried to start the Firmware with the firmware update, but then the cam totaly crashes without any messages and show a black screen (or go maybe to off-status)
This will not work without a ps.fi2 file on the card.  I do not have the ability to generate one of those - there is some concern on the forum about copyright etc when using that file.


« Last Edit: 30 / May / 2011, 10:04:35 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A495 porting thread
« Reply #102 on: 30 / May / 2011, 10:27:21 »

Re: A495 porting thread
« Reply #103 on: 30 / May / 2011, 11:10:31 »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: A495 porting thread
« Reply #104 on: 30 / May / 2011, 11:30:37 »
Just got a PM from astrosalva - he got similiar results although the full logo displayed before the camera crashed.

    

He likely has a faster SD card than HankeyPoo so the boot gets farther before the Canon firmware catches it.   This is good news - I'm not looking for a stub.S problem - more likely something I missed in the boot.c task.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: A495 porting thread
« Reply #105 on: 30 / May / 2011, 11:46:37 »

Re: A495 porting thread
« Reply #106 on: 30 / May / 2011, 11:52:35 »
Took a careful look at boot.c but did not find anything.  There was one spot that was a bit different in the 100f so I merged that in.  I also turned off all the other tasks CHDK normally runs - so this version, if it loads at all,  will really only let you play with menus, games and thinks like the file browser.  No shooting functions.

http://www.box.net/shared/g8ni1r4p92

But if it works better we are one step farther down the road ...
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A495 porting thread
« Reply #107 on: 30 / May / 2011, 12:06:31 »
Thanks for that !

Hmmm - looks not so good.

Now the cam boots with the "Card Error" - then after 2-3 seconds the CHDK Screen (same as before) appears and after a little longer time as before the Cam crashes with the "Card Error" Screen.



Re: A495 porting thread
« Reply #108 on: 30 / May / 2011, 12:28:18 »
Tried turning off the keyboard task too - after that I'm out of ideas for a while. 

http://www.box.net/shared/7o90n4u396

Think I'll go do some yard work or something and see how this looks later.

Sorry.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: A495 porting thread
« Reply #109 on: 30 / May / 2011, 12:45:38 »
I get the same messages and hang but the initial splash screen of chdk stays longer on the screen

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal