A495 porting thread

  • 346 Replies
  • 47214 Views
*

Offline KPOT

  • *
  • 10
  • Publish
    Re: A495 porting thread
    « Reply #270 on: 23 / June / 2011, 05:27:41 »
    Advertisements
    anyone else use script "fast motion detector"? for me script work strange,
    after decting motion i have black screen, and after ~10sec, shoot
    anyone know how to fix it?

  • Publish
    Re: A495 porting thread
    « Reply #271 on: 23 / June / 2011, 06:07:26 »
    after decting motion i have black screen, and after ~10sec, shoot

    I don't use CHDK but that sounds like the time-out for detecting switch release in 'synch' mode..
    Can 'synch' mode be turned-off in CHDK ?

    *

    Offline KPOT

    • *
    • 10
  • Publish
    Re: A495 porting thread
    « Reply #272 on: 23 / June / 2011, 11:46:52 »
    No it did not help, think this is some special problem because "MD" and "fast MD" have same way bug:
    sync, wait, motion, detect, turned on AEL or FEL, ~10 sec wait,shoot

  • Publish
    Re: A495 porting thread
    « Reply #273 on: 23 / June / 2011, 12:26:17 »
    What happens if you have a really simple script that just does a "shoot" instruction ?


    *

    Offline KPOT

    • *
    • 10
  • Publish
    Re: A495 porting thread
    « Reply #274 on: 23 / June / 2011, 13:17:36 »
    What happens if you have a really simple script that just does a "shoot" instruction ?
    Brilliant and why I did not think to myself? ... this is the same,
    earlier shoot script works fine, i just reinstall CHDK and all beginning wors!
    Thank you waterwingz you are genius!!!

  • Publish
    Re: A495 porting thread
    « Reply #275 on: 23 / June / 2011, 14:11:00 »
    Brilliant and why I did not think to myself? ... this is the same,
    earlier shoot script works fine, i just reinstall CHDK and all beginning wors!
    Why do I have a feeling that we have not really seen the last of this ?

  • Publish
    Re: A495 porting thread
    « Reply #276 on: 27 / June / 2011, 14:46:21 »
    Hi guys!
    I have a PowerShot A495 with 100f firmware. I've been testing CHDK for this model, but I cannot run it from a 16gb card. The best I achieved is when i try to load it manually, but it says "Memory card error" and "Memory card locked" even with an unlocked card.
    Without loading CDHK the camera works perfectly with this card.
    I also have a 2gb card that works with CDHK perfectly.

    I think the problem is the FAT32 partition. Is there a way to make it work? I dont care to load CDHK manually, if needed.
    I tryed with CardTricks and sdminst.exe, but both failed to bring CHDK to this card...

    By the way, I can make any test you guys need in this model! :)

  • Publish
    Re: A495 porting thread
    « Reply #277 on: 27 / June / 2011, 16:02:53 »
    I think the problem is the FAT32 partition.
    CHDK will not boot from a FAT32 partition.  You need to either use the "firmware update" method or partition the card in to a small FAT 16 and a large FAT32 partition.  Details on how to do that are here >  SDmMInstallation Guide   or in several place on the wiki.



  • Publish
    Re: A495 porting thread
    « Reply #278 on: 27 / June / 2011, 16:38:31 »
    You need to either use the "firmware update" method or partition the card in to a small FAT 16 and a large FAT32 partition.

    I tryed both methods. Both fails. I think the more pratical for me is to use the "firmware update" option, but it says my card is locked (even with a unlocked card) and dont shoot...

    Any clues on what am I doing wrong?

    Thanks!

    *

    Offline whim

    • ******
    • 2013
    • A495/590/620/630 ixus70/115/220/230/300/870 S95
  • Publish
    Re: A495 porting thread
    « Reply #279 on: 27 / June / 2011, 17:24:00 »
    @ricardomenzer

    To run CHDK with manual start, no special treatment of the card is needed, try following:

     1- save any pics on your 16GB card, and insert in camera
     2- format card in the camera, make sure to activate "low level format"
     3- insert card in card reader
     4- open your CHDK zip file and find "PS.FI2" (or get it from your 2 GB card, if CHDK is still on it)
     5- copy it to the root of your freshly formatted card
         (copying the "CHDK" directory with contents is not necessary for a function test)
     6- put card in camera (do not write protect)
     7- start camera with the playback (not the on/off !) button
     8- open Canon menu (press MENU)
     9- goto left-most tab & scroll down all the way
    10- select "Firm Update" and follow prompts


    hope that helps,

    wim

     

    Related Topics