supplierdeeply

A495 porting thread

  • 346 Replies
  • 47232 Views
  • Publish
    Re: A495 porting thread
    « Reply #90 on: 27 / May / 2011, 05:52:46 »
    Advertisements

    I read this thread and the one on the German site, but failed to
    find anyone reporting success so far with 100 D version. Maybe it just does not work

    I cannot read German, but are you saying that even though it is on the autobuild server it does not work at all ?

    *

    Offline whim

    • ******
    • 2013
    • A495/590/620/630 ixus70/115/220/230/300/870 S95
  • Publish
    Re: A495 porting thread
    « Reply #91 on: 27 / May / 2011, 06:54:45 »
    Hi David
    Quote
    I cannot read German, but are you saying that even though it is on the autobuild server it does not work at all ?
    Notice I said maybe - I was just trying to sollicit comments from 100 D users to address THUNDer's problems,
    since I don't have access to this camera ...

    wim

  • Publish
    Re: A495 porting thread
    « Reply #92 on: 27 / May / 2011, 09:43:27 »
    In that case, it is difficult to know what can be done.
    Can you tell from the German forum if the 100d boots at all or if anyone made comments when 100d was added ?

  • Publish
    Re: A495 porting thread
    « Reply #93 on: 27 / May / 2011, 22:11:35 »
    FYI, I looked at the German version and it appears to be almost identical to a previous non-working 100d build. My guess is that no actual work has been done. I would like to make a port, but I'm kinda busy with other stuff right now...


  • Publish
    Re: A495 porting thread
    « Reply #94 on: 29 / May / 2011, 10:42:51 »
    Does the 100f port work correctly ?   

    I've kind of volunteered to help somebody port the 100f to the 100e.   If the 100f is actually a good port,  it won't be a lot more work to also do a 100d build if that helps.

    *

    Offline msl

    • *****
    • 1177
    • A720 IS, SX220 HS 1.01a
      • CHDK inside
  • Publish
    Re: A495 porting thread
    « Reply #95 on: 29 / May / 2011, 11:53:46 »
    Does the 100f port work correctly ?

    Yes, the 100f port was tested and most of functions works fine. Only the Lua libtest was not completly successfull, if I remember correctly. We have also made a test version of 100d version - over 40 downloads but not one reaction.  :(

    After testing of 100f we made a changeset for the A495 with a note, that 100d was untested. We also have the A495 classified as ALPHA-version.

    The source was the port by syahmixp -> http://gitorious.org/canon-powershot-a495-chdk

    msl
    German CHDK pages:  CHDK forum | CHDK inside | CHDK Twitter News by msl | Download CHDK-DE (Autobuild)
    Note: SDM violates the GPL rules!

  • Publish
    Re: A495 porting thread
    « Reply #96 on: 29 / May / 2011, 11:56:23 »
    Yes, the 100f port was tested and most of functions works fine. Only the Lua libtest was not completly successfull, if I remember correctly. We have also made a test version of 100d version - over 40 downloads but not one reaction.  :(

    Thanks msl - I just pulled the latest source from your svn and am working with it now.


  • Publish
    Re: A495 porting thread
    « Reply #97 on: 29 / May / 2011, 21:03:19 »
    Yes, the 100f port was tested and most of functions works fine. Only the Lua libtest was not completly successfull, if I remember correctly.  
    We have also made a test version of 100d version - over 40 downloads but not one reaction.
    After testing of 100f we made a changeset for the A495 with a note, that 100d was untested.
    Update : Did some more work on the A495 today.  I believe that camera is the least expensive Canon P&S currently available in retail stores so there should be some interest in it.

    The 100f version does not look too bad but at this point I would say that many of  the entries in  the stub_min.S file probably need a little work.

    The 100d version is bad enough that I'm surprised it even loads. Stubs_entry_2.S is clearly a "work in progress".  And the stubs_min.S seems to be a copy of the file from the A480.    I'll take a look at that when I finish with the 100e firmware port.




    « Last Edit: 29 / May / 2011, 21:38:08 by waterwingz »


  • Publish
    Re: A495 porting thread
    « Reply #98 on: 29 / May / 2011, 22:50:12 »
    A495 fw 100e first attempt : http://www.box.net/shared/k3ic8xzer6

    Please download and let me know what works.


  • Publish
    Re: A495 porting thread
    « Reply #99 on: 30 / May / 2011, 09:02:54 »
    « Last Edit: 30 / May / 2011, 09:04:25 by waterwingz »

     

    Related Topics