A495 porting thread

  • 346 Replies
  • 46806 Views
  • Publish
    Re: A495 porting thread
    « Reply #180 on: 01 / June / 2011, 11:08:41 »
    Advertisements
    My camera is also firmware 100d and will be happy to help with testing too ... as you allready know mr. waterwingz :)

    This is really cool.

  • Publish
    Re: A495 porting thread
    « Reply #181 on: 01 / June / 2011, 13:08:40 »
    Maybe this help.

    While you record video you don't use the obturator.
    When you take a photo you close the obturator.
    Perhaps this difference makes the camera hang

  • Publish
    Re: A495 porting thread
    « Reply #182 on: 01 / June / 2011, 14:42:28 »

  • Publish
    Re: A495 porting thread
    « Reply #183 on: 01 / June / 2011, 16:09:18 »


  • Publish
    Re: A495 porting thread
    « Reply #184 on: 01 / June / 2011, 18:30:50 »
    I 've tested the ptp operation of the camera using chdk, It works and is a wonderful way of using it.

    I  even can stop the camera from the pc!

    But if I try to take a photo by any way the camera hangs

    Maybe in the ptp console you get any help

  • Publish
    Re: A495 porting thread
    « Reply #185 on: 01 / June / 2011, 22:17:53 »
    I dissassembled 137 stubs entries tonight and compared them to a reference port I trust (IXUS120-SD940-1.03c).   Found 23 questionable entries for the 1.00f port.

    So at this point,  I am sorry to say that I am done working on the A495 port for the 1.00e or 1.00d.   At least for now.  I'm willing to port a working version to a different camera but this is starting to feel like fixing a partially working port.

    If somebody can tell me they have the 1.00f version that I posted working and answer some questions about that then I will continue.  But for now I am out of time.

    Sorry and my apologies to astrosalva and HankeyPoo for not being able to make this happen right now.

    EDIT :  As you can tell,  I'm frustrated.  In a couple of days,  I might just go buy an A495 if they go on sale at my local discount store.  Trying to fix a port for a camera I don't own is too frustrating.


    « Last Edit: 01 / June / 2011, 23:29:33 by waterwingz »

  • Publish
    Re: A495 porting thread
    « Reply #186 on: 02 / June / 2011, 02:14:20 »
    Please Waterwingz.
    Before leaving.
     can you fix the 23 bad entries you said for the 1.00e as a final beta?
    maybe is enough.......

    If it works, maybe is a test for the 100d and 100f

    Anyway , Thank you for all!

  • Publish
    Re: A495 porting thread
    « Reply #187 on: 02 / June / 2011, 03:28:32 »


  • Publish
    Re: A495 porting thread
    « Reply #188 on: 02 / June / 2011, 04:35:40 »

  • Publish
    Re: A495 porting thread
    « Reply #189 on: 02 / June / 2011, 07:34:40 »

     

    Related Topics