A3000IS poring thread - page 9 - DryOS Development - CHDK Forum  

A3000IS poring thread

  • 142 Replies
  • 29930 Views
Re: A3000IS poring thread
« Reply #80 on: 19 / March / 2011, 01:11:04 »
Advertisements
So far, consensus seems to be that CHDK hardly has any influence on power consumption, see the
wiki FAQ here
This FAQ also has a link to detailed measurements for some camera's

hope that helps,

wim

I... guess? I thought it was an issue with the beta status of this release. Ah well, I'll have fun with it anyway.

Re: A3000IS poring thread
« Reply #81 on: 16 / May / 2011, 13:53:09 »
Okay, back again with an issue... I've been using a 2GB microSD card for storage and I found that when the card gets more than about a quarter full, CHDK becomes very unstable. By the time it gets up to about 1/3 full, it's nearly impossible to get it to even boot.

*

Offline reyalp

  • ******
  • 11897
Re: A3000IS poring thread
« Reply #82 on: 16 / May / 2011, 16:22:30 »
I... guess? I thought it was an issue with the beta status of this release. Ah well, I'll have fun with it anyway.
If you can show, with actual reproducible measurements that CHDK draws more power, that would be very interesting and we would welcome reliable data. Experience has shown that anecdote is not a useful substitute.

Okay, back again with an issue... I've been using a 2GB microSD card for storage and I found that when the card gets more than about a quarter full, CHDK becomes very unstable. By the time it gets up to about 1/3 full, it's nearly impossible to get it to even boot.
Sounds like it is running out of RAM, or encountering the infamous startup crash  http://chdk.setepontos.com/index.php?topic=6179.0

You can check available memory in from memory info in the misc menu. Implementing exmem might improve the situation: http://chdk.setepontos.com/index.php?topic=5980.0

You can also build a stripped down build without games and other features you don't want.
Don't forget what the H stands for.

*

Offline ERR99

  • ****
  • 339
Re: A3000IS poring thread
« Reply #83 on: 31 / May / 2011, 06:39:19 »
I found again some time for the A3000IS port, so:
I did not changed a single line of the A3000IS related stuff, but i rebased the port to the current chdk trunk version (1194).
Short test looks promising, i did not get a single crash/assert during shooting or booting (even with a 3/4 filled 2GB SD card).
Also shooting RAW works several times without having a crash/shutdown during raw saving process.

Please test the attached builds, i am interested to hear if other people also see here stability improvements.
1.00D build:


*

Offline ERR99

  • ****
  • 339
Re: A3000IS poring thread
« Reply #84 on: 31 / May / 2011, 06:41:29 »
1.00C (1194) build:

*

Offline ERR99

  • ****
  • 339
Re: A3000IS poring thread
« Reply #85 on: 31 / May / 2011, 06:42:40 »
1.00B (1194) build:

Re: A3000IS poring thread
« Reply #86 on: 22 / June / 2011, 15:34:42 »
Running the 1.00D version, I've found a very strange bug -- if you don't set CHDK to save RAW pictures to the same directory as the JPEGs, CHDK will not start on the next boot.

*

Offline dok

  • *
  • 4
Re: A3000IS poring thread
« Reply #87 on: 25 / June / 2011, 11:05:36 »
Hello everyone,

I'm a brand new chdk user since when I bought this A3000 IS camera a few days ago. Incredible soft/firmware you made!

I have two problems :

- as a linux user, I simply cannot manage to use properly dng4ps2 (windows version with wine) even after editing the registry with all the information provided by Ursus82 on page 3 of this topic.
- sadly, I also have the DNG bug. I can have RAW pictures, but it is impossible to get DNG conversion with the camera : it shuts down before the end of the treatment (I suppose).

BUT! I think I found something. Indeed, I have been able to get DNG pictures only the first time I used this option. And when it's the first time, the software asks first for the creation of the badpixel.bin file : then, it was OK. But after shutting off the camera and when I restarted it, DNG conversion would fail.

What did I do then ? I deleted the badpixel.bin file (on my computer, sadly the integrated filebrowser doesn't work, that's a third problem), restarted the camera, launched the badpixel.bin file creation and tada !! I was able to shoot DNG during this whole session. I repeated this operation several times and it worked.

Hoping this will help...


*

Offline dok

  • *
  • 4
Re: A3000IS poring thread
« Reply #88 on: 02 / July / 2011, 08:22:17 »
I'd like to add two points :

- the filebrowser sometimes does work. I once have been able to delete the badpixel file through the filebrowser so as to be able to shoot once more in DNG.

- I noticed a problem in exposure bracketing: no problem in "+/-" mode, but the "-" and "+" modes are respectively inverted.

*

Offline reyalp

  • ******
  • 11897
Re: A3000IS poring thread
« Reply #89 on: 02 / July / 2011, 16:02:08 »
What is the size of the badpixel file, and how much memory is free (misc -> show memory info) ?
Don't forget what the H stands for.

 

Related Topics