S95 Porting Thread - page 4 - DryOS Development - CHDK Forum

S95 Porting Thread

  • 1015 Replies
  • 249628 Views
*

Offline reyalp

  • ******
  • 13058
Re: S95 Porting Thread
« Reply #30 on: 11 / October / 2010, 12:30:01 »
Advertisements
I know, I tried that first but, or I'm missing something, or the S95 does not have a "firm update" option within it's menus... I can't find it!
Make sure you start the camera with the play button, not the normal power button.
Don't forget what the H stands for.

Re: S95 Porting Thread
« Reply #31 on: 11 / October / 2010, 12:55:52 »
This time trying with 4GB card and making shure it is FAT16 formatted:
I'm starting from Play mode.
I formatted the card on the Mac terminal since the camera does format it as FAT32.
So, once being 1 partition FAT16 I copied the two CHDK files, created the ver.req, created DCIM and MISC folders and locked the card.
Started camera in Play mode and I still don't have an "firm update" option nor CHDK will boot...

I used CHDK on another camera so the process is not completely new to me, but maybe I'm doing something wrong... sorry for the bandwidth noise guys
« Last Edit: 11 / October / 2010, 12:58:57 by Fernando »

Re: S95 Porting Thread
« Reply #32 on: 11 / October / 2010, 13:25:53 »
Hi Everyone!Is it possible to activate 1280x720 30p mode on canon s95 using CHDK?

*

Offline whim

  • ******
  • 2040
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: S95 Porting Thread
« Reply #33 on: 11 / October / 2010, 13:38:49 »
@Fernando

Don't have a Mac myself, but I'm pretty sure this Wiki page will solve your problems

http://chdk.wikia.com/wiki/FAQ/Mac

HTH,

wim


Re: S95 Porting Thread
« Reply #34 on: 11 / October / 2010, 14:46:18 »
Hello,


If it helps someone, here how I did :
- downloaded installed some recent CHDK on my 16 Gb card
- overwrote DISKBOOT.BIN and PS.FI2 with Waldo's
- started the cam from play mode, then "Menu", and the last item "Firm update..."



I did not had time to test yet, only tried to start some scripts (Lotto and eggs), got through the menus etc... Seems to work, but I have some display bugs:
- overlays become a white rectangles, then display correctly after a while,
- when going into the menu, if built-in graph is on, it goes on top of menu.

Didn't try to shoot or perform complex tasks, write on card, but will do that ASAP...

Thank you, thank you so much Waldo !

Re: S95 Porting Thread
« Reply #35 on: 11 / October / 2010, 15:32:56 »
Finally got a few minutes...
What I tried, sorted by what worked and what did not, at least for me (may be I did something wrong).
KO :
- both aperture and speed overrides, whatever the setting (small or large value).
- zebra
OK :
- focus button while capturing a video
- Histogram

Did not try any advanced stuff.

Re: S95 Porting Thread
« Reply #36 on: 11 / October / 2010, 20:37:17 »
I can only make it work with two partitions but then it will not swap the partitions to write pictures in the larger one.
The only way I'm being able to get here is preparing the card with the command line in chdk_prep.dmg
Then CHDK is autoloading but won't switch partitions (I think is not implemented yet) I get the warning "there is only one partition" (but I have the correct FAT16 and FAT32 partitions)

All other methods (using the "CHDK MAC INSTALLER script (07082009).scpt" or manually from th eTerminal following instructions here and in http://chdk.wikia.com/wiki/FAQ/Mac) will not let CHDK to boot either manually (no "firm update" button) or auto.

So, no idea what is happening. I tried with both 4GB and 16GB cards. I'm running OSX 10.6.4 and I'm the admin of the system.

...
« Last Edit: 11 / October / 2010, 20:58:41 by Fernando »

Re: S95 Porting Thread
« Reply #37 on: 11 / October / 2010, 21:25:25 »
Hello,


If it helps someone, here how I did :
- downloaded installed some recent CHDK on my 16 Gb card
- overwrote DISKBOOT.BIN and PS.FI2 with Waldo's
- started the cam from play mode, then "Menu", and the last item "Firm update..."



I did not had time to test yet, only tried to start some scripts (Lotto and eggs), got through the menus etc... Seems to work, but I have some display bugs:
- overlays become a white rectangles, then display correctly after a while,
- when going into the menu, if built-in graph is on, it goes on top of menu.

Didn't try to shoot or perform complex tasks, write on card, but will do that ASAP...

Thank you, thank you so much Waldo !

Firstly....Waldo, thanks for all your work and efforts..well done!

1) I wanted to ask which recent CHDK did you install?
2) Where can I find Waldo's DISKBOOT.BIN and PS.FI2, I noticed page 2 had some download links but didn't see those files.

Thanks m4mmon for posting the info.

Cheers.




*

Offline waldo

  • ***
  • 238
Re: S95 Porting Thread
« Reply #38 on: 11 / October / 2010, 21:33:17 »
1. If you mean what version of the trunk it was derived from, that is shown on the splash screen.
2. On zShare, click Download Now, wait a little while, click the word "here".

*

Offline waldo

  • ***
  • 238
Re: S95 Porting Thread
« Reply #39 on: 11 / October / 2010, 21:46:16 »
I'm attempting to implement the Capt Seq task.  This code has changed in the S95 firmware relative to the S90 so it's a little difficult to locate where to patch it.  I have found where the call to shooting_expo_param_override() should go, so I put just that in, but the overrides still do not work.  I have confirmed that shooting_expo_param_override() gets called.  Is there anything else I need to make the overrides work?

 

Related Topics