S95 Porting Thread - page 8 - DryOS Development - CHDK Forum

S95 Porting Thread

  • 1015 Replies
  • 251183 Views
Re: S95 Porting Thread
« Reply #70 on: 29 / October / 2010, 22:58:49 »
Advertisements
@Hollywood:
Any changes like what you are requesting would not come from me - I'm just porting functionality developed by others.

Thanks Waldo for the response.  I figured I would just ask for the heck of it.

Your work is really appreciated, big thanks.

Cheers.

Re: S95 Porting Thread
« Reply #71 on: 29 / October / 2010, 23:36:43 »
I just tried running a few timelapse scripts such as Ultra Intervalometer and when I hit the shutter button to start shooting the camera turns off with the lens still extended.

I have to restart the camera to get back into CHDK the menu.  Can anyone offer any suggestions...thanks.

Re: S95 Porting Thread
« Reply #72 on: 30 / October / 2010, 05:07:22 »
I just tried running a few timelapse scripts such as Ultra Intervalometer and when I hit the shutter button to start shooting the camera turns off with the lens still extended.

I have to restart the camera to get back into CHDK the menu.  Can anyone offer any suggestions...thanks.


same happens to me. The port is not finished it may be that

Re: S95 Porting Thread
« Reply #73 on: 30 / October / 2010, 08:30:30 »
Have this version:

Canon PowerShot S95
P-ID:3212 PAL D

Version 1.00H
Firmware Ver GM1.00H (1.0.0.0)
Adj. Ver.008.003

Build Sep 14

NoError

Mecha Firm Ver. 2.18

Does it help if i dump it and in that case how do i do that? Is there a "dump for dummies" when using the cBasic udumper?


*

Offline waldo

  • ***
  • 238
Re: S95 Porting Thread
« Reply #74 on: 30 / October / 2010, 09:56:10 »
I just tried running a few timelapse scripts such as Ultra Intervalometer and when I hit the shutter button to start shooting the camera turns off with the lens still extended.

I have to restart the camera to get back into CHDK the menu.  Can anyone offer any suggestions...thanks.


Remove the print statements and retry.

*

Offline waldo

  • ***
  • 238
Re: S95 Porting Thread
« Reply #75 on: 30 / October / 2010, 10:00:58 »
Is there a "dump for dummies" when using the cBasic udumper?

http://chdk.wikia.com/wiki/Canon_Basic

You should also try the current S95 version - it may work as-is.

Re: S95 Porting Thread
« Reply #76 on: 30 / October / 2010, 10:54:44 »
Got Ultra Intervalometer to work by removing the "Print" lines.  Of course, that means the shot number and start time don't show up on the screen.

Also, tweaked the interval delay to make it more accurate.  Around J=-1000 seems to work best.

Still not sure how to exit the script setup screen.    I scroll down to  <-exit but no button press seems to exit the screen.

The script I'm using is as follows:

rem Author - Keoeeit
rem Upgraded by Mika Tanninen
rem Time accuracy for S-95 Martlet
rem h-accuracy for delay, j-accuracy for interval
h=0
j=-1000
@title Ultra Intervalometer
@param a Delay 1st Shot (Mins)
@default a 0
@param b Delay 1st Shot (Secs)
@default b 0
@param c Number of Shots (0 inf)
@default c 0
@param d Interval (Minutes)
@default d 0
@param e Interval (Seconds)
@default e 10
@param f Interval (10th Seconds)
@default f 0
n=0
t=(d*600+e*10+f)*100+j
if c<1 then let c=0
if t<100 then let t=100
g=(a*60)+b+h
if g<=0 then goto "interval"
for m=1 to g
 sleep 930
 next m
:interval
  n=n+1
  shoot
  if n=c then shut_down
  sleep t
  goto "interval"

Re: S95 Porting Thread
« Reply #77 on: 30 / October / 2010, 11:03:02 »

This is a known issus with newer camera.
Maybe Power Button detection in boot.c needs to be fixes.
Example: my SD4000 http://github.com/pixeldoc2000/chdk/commit/4d5ceba194ae300dee5afb7a429a43cb5e72a5d6 .
[/quote]

Hah, it does work.  Now, is there a way to swap that command so the short press is the fast start...seems more logical to get shooting on startup.


s95 zoom locks up
« Reply #78 on: 30 / October / 2010, 12:24:12 »
When trying the zoom commands from a script, the camera locks up.  I have the matching firmware version.

*

Offline waldo

  • ***
  • 238
Re: S95 Porting Thread
« Reply #79 on: 30 / October / 2010, 12:27:46 »
Still not sure how to exit the script setup screen.    I scroll down to  <-exit but no button press seems to exit the screen.

All CHDK builds I am familiar with do this when entering the script menu with the Set button.  \Workaround is to use the Menu button to enter menu mode or to press the ALT (Shortcut) button to exit.

 

Related Topics