S95 Porting Thread - page 100 - DryOS Development - CHDK Forum
supplierdeeply

S95 Porting Thread

  • 1000 Replies
  • 237105 Views
Re: S95 Porting Thread
« Reply #990 on: 23 / February / 2013, 08:21:35 »
Advertisements
Hello, guys.
Could you help me?

I have 32Gb SD card and have created 2 partitions - fat16 and fat32 - and marked fat16 as bootable (see pic. 1) in Ubuntu with GParted. I've put CHDK archive content in the root of the fat16 and fat32 directories (see pic. 2). Unfortunately, I can't start CHDK automatically when I switch s95 on. I can do it only with Firmware update method.

What did I do wrong? How can I get CHDK autostarted?
« Last Edit: 23 / February / 2013, 08:26:27 by kontiky »

*

Offline msl

  • *****
  • 1269
  • A720 IS, SX220 HS 1.01a
    • CHDK-DE links
Re: S95 Porting Thread
« Reply #991 on: 23 / February / 2013, 09:28:57 »
and marked fat16 as bootable (see pic. 1)

This method will not work. The FAT16 partition need the entry 'BOOTDISK' at offset 0x40. There are many ways creating a bootable partition. Read more her: http://chdk.wikia.com/wiki/Bootable_SD_card

msl
CHDK-DE:  CHDK-DE links

Re: S95 Porting Thread
« Reply #992 on: 23 / February / 2013, 11:41:41 »
and marked fat16 as bootable (see pic. 1)

This method will not work. The FAT16 partition need the entry 'BOOTDISK' at offset 0x40. There are many ways creating a bootable partition. Read more her: http://chdk.wikia.com/wiki/Bootable_SD_card

msl

Only "Mark partition bootable" from CHDK menu helped me.

Re: S95 Porting Thread
« Reply #993 on: 07 / March / 2013, 00:38:13 »
Hello, my CHDK always starts S95 in preview mode and I can't find any option to change it. I prefere to start S95 just in shooting mode as I switch on it. How can I set up CHDK to do this?


*

Offline fe50

  • ******
  • 3117
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: S95 Porting Thread
« Reply #994 on: 07 / March / 2013, 01:12:43 »
Hello, my CHDK always starts S95 in preview mode and I can't find any option to change it. I prefere to start S95 just in shooting mode as I switch on it. How can I set up CHDK to do this?
That's the default behaviour with CHDK, there's no setup option to change this. To start directly in record mode, hold the power button for ~1s.

Re: S95 Porting Thread
« Reply #995 on: 18 / July / 2013, 18:04:59 »
Hello, I have a question :
My S95 shut's down at 26% battery, so the meter is not right do I have to calibrate it ?

Re: S95 Porting Thread
« Reply #996 on: 18 / July / 2013, 18:09:37 »
Hello, I have a question :
My S95 shut's down at 26% battery, so the meter is not right do I have to calibrate it ?
Yes.   

You can to that in the battery submenu of the OSD menu.
Ported :   A1200    SD940   G10    Powershot N    G16

luar set_record(1) fails in ptpcam
« Reply #997 on: 07 / May / 2016, 13:35:37 »
Hi!

I'd like to control an S95 using a Raspberry PI via USB, but I am having problems switching the camera into record mode by running a lua command. Here's how the ptpcam session looks like:

Code: [Select]
<conn> luar get_buildinfo()
script:9
9:ret:'platform s95
build_date Apr 18 2016
build_number 1.4.1
build_time 00:55:36
version CHDK
platsub 100e
build_revision 4599
platformid 12818
os dryos
'
<conn> luar set_record(1)
script:11
11:ret:nil
<conn> luar get_mode()
script:12
12:ret:false

I found a hint that set_record does not work when the camera is connected via USB and that set_mode_usb(1) should be used instead. However, this workaround seems no longer to be needed with modern CHDK (and does not work either – it behaves exactly the same: it has no effect). Do you have any idea what I could try next?

Thanks for CHDK!
Jan


*

Offline reyalp

  • ******
  • 12690
Re: luar set_record(1) fails in ptpcam
« Reply #998 on: 07 / May / 2016, 14:18:15 »
I found a hint that set_record does not work when the camera is connected via USB and that set_mode_usb(1) should be used instead. However, this workaround seems no longer to be needed with modern CHDK (and does not work either – it behaves exactly the same: it has no effect).
Yes, in modern CHDK, set_record will call switch_mode_usb automatically if USB is present, so they are expected to behave the same.

Quote
Do you have any idea what I could try next?
Does the screen on the camera go black when the USB is connected to the raspberry pi? If so, there is probably some other software accessing the camera, and you need to adjust the udev configuration to prevent it. See "Interactions with default software" under https://www.assembla.com/spaces/chdkptp/wiki/Install (this page is for chdkptp, but the udev stuff applies to ptpcam as well)
Don't forget what the H stands for.

Re: luar set_record(1) fails in ptpcam
« Reply #999 on: 07 / May / 2016, 15:38:02 »
Does the screen on the camera go black when the USB is connected to the raspberry pi? If so, there is probably some other software accessing the camera, and you need to adjust the udev configuration to prevent it.

Ah! Thanks! Yes, it goes black indeed. Actually, I am currently testing on OSX. I guess I have to kextunload a kernel module. No clue which one however ... Thanks anyway, you put me on the right path!

 

Related Topics