S95 Porting Thread - page 81 - DryOS Development - CHDK Forum supplierdeeply

S95 Porting Thread

  • 1015 Replies
  • 273226 Views
*

Online philmoz

  • *****
  • 3332
    • Photos
Re: S95 Porting Thread
« Reply #800 on: 26 / April / 2011, 08:46:04 »
Advertisements
Below should be the firmware addresses for some of the missing functions in the S95 ports for 1.00e and 1.00h.
I haven't tested these as I don't have an S95; but the code at these addresses matches the G12 firmware.

1.00e
=====
strrchr      0xFF8140D8
srand      0xFFA4FEA4
rand      0xFFA4FEB0

1.00h
=====
strrchr      0xFF8140D8
srand      0xFFA4FEB0
rand      0xFFA4FEBC

This should allow the custom versions of these functions to be removed in platform/generic/wrappers.c and platform/s95/wrappers.c

Phil.


CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: S95 Porting Thread
« Reply #801 on: 27 / April / 2011, 07:40:42 »
Thanks Phil,

Will try'em out !

wim

Re: S95 Porting Thread
« Reply #802 on: 01 / May / 2011, 09:02:06 »
Hi guys, first, many thanks for chdk.
I have noticed some bug in version for s95:
function "dark frame substruction [on\off\auto]" in folder "raw operations" seems doesn't work :(
when long exposition camera always waits for some time for acquiring dark frame no matter what mode I choose.
btw, this function worked well in chdk versions for a590is and a3000is...
 

Re: S95 Porting Thread
« Reply #803 on: 11 / May / 2011, 01:40:14 »
Hi,

I'm looking for the memory location of the ExpCtrlTool_StopContiAE function in the 100h firmware for the S95.

The location of the related ExpCtrlTool_StartContiAE function is already defined [1], but the not the ExpCtrlTool_StopContiAE function.

The ExpCtrlTool_StopContiAE function is also defined for the S90 [2], for firmware 101c.

How would I go about finding this memory location? Is it a case of comparing the firmware from the S90 and the S95?

If so, how would a noob go about doing this? Can you recommend a disassembler? (I'm on Mac OS X 10.6.7).

Background: I'm looking for values to plug into a video exposure control script [3], to be able to set the shutter speed in movie mode, to control motion blur.

Thanks in advance for any advice.

-Matt

[1] http://tools.assembla.com/chdk/browser/trunk/platform/s95/sub/100h/stubs_entry_2.S  (line 92 in rev 1059)
[2] http://tools.assembla.com/chdk/browser/trunk/platform/s90/sub/101c/stubs_entry_2.S
[3] http://chdk.setepontos.com/index.php?topic=6113.0


Re: S95 Porting Thread
« Reply #804 on: 11 / May / 2011, 10:41:08 »
Background: I'm looking for values to plug into a video exposure control script [3], to be able to set the shutter speed in movie mode, to control motion blur.
It's a nonsence.
There is no such thing as shutter speed in video mode.
The shutter is always open while recording video.

*

Offline reyalp

  • ******
  • 13438
Re: S95 Porting Thread
« Reply #805 on: 11 / May / 2011, 12:31:53 »
It's a nonsence.
There is no such thing as shutter speed in video mode.
The shutter is always open while recording video.
Mechanical shutter is open. There is still electronic control of exposure time.
Don't forget what the H stands for.

Re: S95 Porting Thread
« Reply #806 on: 11 / May / 2011, 20:37:36 »
@cppasm: As @reyalp pointed out, I'm talking about the exposure time for each video frame. "Shutter speed" is still the commonly used term for this in the context of video.

This tutorial video on Vimeo explains the effect of changing shutter speeds in the context of film, contrasting it with framerate:

Re: S95 Porting Thread
« Reply #807 on: 12 / May / 2011, 02:32:32 »
reyalp found the ExpCtrlTool_StopContiAE function at FF8474E4, for both the 100e and the 100h firmware.

I'll field test this with the video exposure control script mentioned above, and post any findings.


Re: S95 Porting Thread
« Reply #808 on: 12 / May / 2011, 08:19:26 »
reyalp found the ExpCtrlTool_StopContiAE function at FF8474E4, for both the 100e and the 100h firmware.

I'll field test this with the video exposure control script mentioned above, and post any findings.

If you need any testing of any script that might work for setting shutter speed etc. for video - I'm here ;)
rly looking forward to your success

ps: did you check http://chdk.setepontos.com/index.php?topic=5295.45 ?

Re: S95 Porting Thread
« Reply #809 on: 17 / May / 2011, 08:47:51 »
Hello everyone!

new here and i'm very anxious to try this out on my new S95 but i'm having a bit of a issue with it. I'm assuming that none of the beta versions are the same one as my firmware on my camera? is there anyway to bypass this? my firmware is

GM1.00I (1.0.0.0)

Build March 2011.

if anyone could help, it would be greatly appreciated!

 

Related Topics