Chdk for SX130 IS ? - page 103 - CHDK Releases - CHDK Forum

Chdk for SX130 IS ?

  • 1095 Replies
  • 368234 Views
Re: Chdk for SX130 IS ?
« Reply #1020 on: 26 / August / 2012, 17:56:53 »
Advertisements
Hey guys, i am needing to use the remote capture in my camera to take too close pictures of tiny eggs of animals for my college project. The camera is fixed in a suport with a machine that moves the eggs on a small frame pushed by a mat. Along the way the camera takes three photos to get a panoramic view of the frame. I need to take this photos from my computer with the capture remote mode. Somebody can help me?
the c version of chdk (753kb) states that it can enable a remote shutter via usb. havent tested this feature though
but you can use countdown to shutter as well. 10 sec ex.

Hi, alternatively you could take a look at chdkptp (http://chdk.setepontos.com/index.php?topic=6231.225)), which allows you to control your camera from your computer either from a command line or graphical interface (the gui also supports live view if you using the reyalp-ptp-live build of CHDK).

*

Offline reyalp

  • ******
  • 13840
Re: Chdk for SX130 IS ?
« Reply #1021 on: 26 / August / 2012, 18:14:08 »
which allows you to control your camera from your computer either from a command line or graphical interface (the gui also supports live view if you using the reyalp-ptp-live build of CHDK).
This functionality is now supported in the stable  (1.1) version of CHDK, no need for a special branch.
Don't forget what the H stands for.

Re: Chdk for SX130 IS ?
« Reply #1022 on: 01 / September / 2012, 10:30:11 »
SX 130( needless to say in this thread :) )

while in the video mode if i run a command via the ptp interface and use either

press ('set') or click ('set')

the camera shuts down
the same command works in Program,Auto, Manual mode
up,left, down, menu, disp, shoot buttons have no problem in the video mode (ptp of course)

i need to set the white balance in the video mode remotely (i never have access to the physical camera) and i cant do it without the set button

is this a known bug(if it is such). or is there a workaround.

thanks in adv.

*

Offline reyalp

  • ******
  • 13840
Re: Chdk for SX130 IS ?
« Reply #1023 on: 01 / September / 2012, 17:27:25 »
while in the video mode if i run a command via the ptp interface and use either

press ('set') or click ('set')

the camera shuts down
This is quite odd, I've never heard of this before. Are you using live view when this happens ? If so, try without.

If you get a crash log as described here http://chdk.wikia.com/wiki/Debugging#Camera_crash_logs_.28romlog.29 that may provide some useful information.
Don't forget what the H stands for.


Re: Chdk for SX130 IS ?
« Reply #1024 on: 02 / September / 2012, 08:10:49 »
while in the video mode if i run a command via the ptp interface and use either

press ('set') or click ('set')

the camera shuts down
This is quite odd, I've never heard of this before. Are you using live view when this happens ? If so, try without.

If you get a crash log as described here http://chdk.wikia.com/wiki/Debugging#Camera_crash_logs_.28romlog.29 that may provide some useful information.

yes i am using the live view - will do as you say and pause live view (it is on a timer control) and report back
will also get the crash log - as soon as i go thru the link you provided.


Re: Chdk for SX130 IS ?
« Reply #1025 on: 02 / September / 2012, 08:15:57 »
no.
disabling the live view has no effect on the result it still shuts down as soon as i do a
press ('set') or a click('set') in video mode

let me see if i can get that crash log...

Re: Chdk for SX130 IS ?
« Reply #1026 on: 02 / September / 2012, 08:25:34 »
As of changeset 1432, the romlog can be saved from the CHDK menu, using "miscellaneous stuff->Debug Parameters->Save ROM crash log"

I do not find the option for 'Save ROM crash log' under Miscellneous stuff-> Debug Parameters. has it been shifted to some other submenu in the recent builds ?

Re: Chdk for SX130 IS ?
« Reply #1027 on: 02 / September / 2012, 08:32:19 »
ok there is a file in the Root of the card saying ROMLOG.LOG, Hope it is the right one.

Tried some other things in the Video mode and changing the Zoom in the Video mode does the same thing - shuts down the camera.

pls disregard the time in the romlog - i found that it was not set.
« Last Edit: 02 / September / 2012, 08:37:35 by ntstatic »


*

Offline srsa_4c

  • ******
  • 4450
Re: Chdk for SX130 IS ?
« Reply #1028 on: 03 / September / 2012, 10:28:36 »
@ntstatic
For cameras which have more than one supported firmware revision, it's useful to include that in the bugreport. From the addresses found in the romlog, I assume yours is 1.01f.
Which version of CHDK are you using? (1.1, 1.2)
Is this a new issue or just something you haven't tried and noticed before?

If it's new, can you try older CHDK revisions?

Re: Chdk for SX130 IS ?
« Reply #1029 on: 03 / September / 2012, 10:56:43 »
yes the firmware rev is 1.01f

i am using the trunk 755 of the DE version (i probably should try using the latest ver), i have been using this version with Mweerden's live view patch ( i know it is outdated and live view is officially supported in the newest version - however did not find the time to tinker with something that was working excellently otherwise )

The issue is not a new issue previously there was little use of the video mode. however noticed that zoom crashed the camera and i worked around it by disabling zoom in video mode ( allowed the UI to zoom then switch to video  :))

however since i now need to set the white balance in the video mode i am in a fix.

it is not a specific camera problem as i have tried it on not less than 10 pieces
« Last Edit: 03 / September / 2012, 11:07:14 by ntstatic »

 

Related Topics