Chdk for SX130 IS ? - page 105 - CHDK Releases - CHDK Forum
supplierdeeply

Chdk for SX130 IS ?

  • 1095 Replies
  • 276456 Views
Re: Chdk for SX130 IS ?
« Reply #1040 on: 23 / September / 2012, 10:44:45 »
Advertisements
i have located the ..\bin\logs directory shall i upload these txt files and the romlog ? (hope a zip is ok as they are 5 mb + for each camera

pressing the set button on the camera while the camera is in the video mode (dial is on video) beautifully bring up the standard set menu for the video mode depicting the

video resolution
WB
MyColours
Resolution

menu

Re: Chdk for SX130 IS ?
« Reply #1041 on: 23 / September / 2012, 10:48:56 »
wait ....
something happened

i just connected the SX 130
fired up the CHDKPTP - meaning to crash it to generate the rom
Pressed Connect
Checked Viewfinder
selected Video_STD from drop down ( the mode dial is on SCN)
Pressed SET on chdkptp (expecting it to crash)

and it didnt
the set menu came up

give me a minute to test the thing further.....
'-----------------------
every other mode crashes the camera
the camera does not crash if the mode dial is on either VIDEO or SCN (by the way it shows SCN_SMART_SHUTTER) in the drop down in ptpcam

now back to creating that romdump...



« Last Edit: 23 / September / 2012, 10:58:49 by ntstatic »

*

Offline srsa_4c

  • ******
  • 4146
Re: Chdk for SX130 IS ?
« Reply #1042 on: 23 / September / 2012, 10:56:00 »
i have located the ..\bin\logs directory shall i upload these txt files and the romlog ? (hope a zip is ok as they are 5 mb + for each camera
Only upload the romlogs first, I suspect that CHDK is not directly involved here (it probably left the camera in a confused state). Keep those txt files for a while, in case I'm wrong.
Quote
pressing the set button on the camera while the camera is in the video mode (dial is on video) beautifully bring up the standard set menu for the video mode depicting the
video resolution
WB
MyColours
Resolution

menu
Well, yes. See my above sentence.
wait ....
something happened
OK :)

Re: Chdk for SX130 IS ?
« Reply #1043 on: 23 / September / 2012, 10:59:56 »
every other mode crashes the camera
the camera does not crash if the mode dial is on either VIDEO or SCN (by the way it shows SCN_SMART_SHUTTER) in the drop down in ptpcam

now back to creating that romdump...


Re: Chdk for SX130 IS ?
« Reply #1044 on: 23 / September / 2012, 11:18:33 »
i have verified with the SX 150 and it is the same the camer does not crash if the mode dial is in SCN or VIDEO
in all other options P,Auto,Landscape ..... it crashes

here are the romlog from both the cameras....

Re: Chdk for SX130 IS ?
« Reply #1045 on: 23 / September / 2012, 11:19:39 »
sorry connection acting up a little ....

here are the romlogs

*

Offline srsa_4c

  • ******
  • 4146
Re: Chdk for SX130 IS ?
« Reply #1046 on: 23 / September / 2012, 11:46:06 »
here are the romlogs
Both are the same kind. As the problem is the mode switch, can you do the following:
- start the camera, switch to record mode
- change the dial to movie mode
- change the dial to something else
- run the script that makes it crash (the one which changes to movie mode and presses a key)
- make a romlog
Hopefully the romlog will include the previous manual mode change too. You only need to do this on one camera.
About the romlogs: as I suspected, it's an indirect crash, those txt files are not needed this time.
Finding a solution may take a while, I hope that others can help with this...

*

Offline reyalp

  • ******
  • 12435
Re: Chdk for SX130 IS ?
« Reply #1047 on: 23 / September / 2012, 15:00:20 »
FWIW, I've noted before the func menu gets in a confused state when switching modes from script http://chdk.setepontos.com/index.php?topic=4338.msg86538#msg86538

Unfortunately, the set_capture_mode command just calls a canon function SetCurrentCaptureMode, so outside of modemap errors, there isn't much room for a bug in the CHDK implementation. The original development thread for this feature is found here http://chdk.setepontos.com/index.php?topic=3228.0 - some other methods of changing modes were explored before we settled on SetCurrentCaptureMode.
Don't forget what the H stands for.


*

Offline srsa_4c

  • ******
  • 4146
Re: Chdk for SX130 IS ?
« Reply #1048 on: 23 / September / 2012, 15:11:25 »
@reyalp
Thanks for the link. I'm hoping for a romlog here, in which both a proper and a CHDK-style mode switch is present - to compare them.

Re: Chdk for SX130 IS ?
« Reply #1049 on: 24 / September / 2012, 01:46:00 »
here is what i did

Camera Off ( it is a SX 130 by the way )
Mode dial is on M
Camera On
Half Press Shutter-Camera is in Rec mode now
Mode dial To VID
Mode dial To M
<ALT>- button press
Full Press Shutter-Run the script setvid.lua with following content
Code: [Select]
require("capmode").set("VIDEO_STD")
sleep(2000)
click("set")
camera switches to Vid mode waits and Crashes

<ALT><MENU><MISC STUFF><DEBUG PARAMETERS><SAVE ROM CRASH LOG>

Here is the ROMLOG

Finding a solution may take a while, I hope that others can help with this...
dont mind - thank you for all the effort - i can do what ever is necessary - even disassemble the camera :) (i know it is not necessary in this case, just letting all you fantastic people know how much i appreciate the whole CHDK as a beautifull piece of art)
« Last Edit: 24 / September / 2012, 01:51:15 by ntstatic »

 

Related Topics