supplierdeeply

Chdk for SX130 IS ?

  • 1094 Replies
  • 178476 Views
*

Offline quid

  • **
  • 67
  • SX130IS
  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #120 on: 20 / January / 2011, 14:56:49 »
    Advertisements
    Free mem for sx130 after shoot in PB mode is about 40 kb.  
    This is our main problem with sx130. You do not even have to take a shoot. Memory disappears when you use (or start in) a playback mode with at least one picture on the SD card.

    Problem also exists with only main CHDK task (without any overridden tasks). I've double-checked all stubs - maybe we need fresh pair of eyes there?
    « Last Edit: 20 / January / 2011, 14:58:26 by quid »

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #121 on: 20 / January / 2011, 17:38:32 »
    Wait a minute, is this correct: I have to use the patch with chdk for sx130, couse without it my camera 'should' crash? Becouse of low memory?

    I tried so - I've put on SD only unziped sx130is-101c-0.9.9.zip from post #101, without patch and everything looks ok. The camera can shot, record movies, all settings and functions I tried (Av, Tv set, long time expo, display photos, play movies, save RAW, zoom, OSD...) work fine (both Canon and CHDK). So - what's the point of using patch?

    I didn't try scripting, since I'm just newbie:D And have no time now. But I'm still wonder - what is the patch for?

    And yes - I've got a photos on SD - around 55 photos and one movie. Preview mode also works with no problems.

    BTW - in normal, patched version - I had a problem with 812 sec time exposure - camera crashed (or it really takes more than 1 hour to shot and calculate all the things before save the photo?). The 645 sec. works fine.
    « Last Edit: 20 / January / 2011, 17:48:53 by outslider »
    if (2*b || !2*b) {
        cout<<question
    }

    Compile error: poor Yorick

    *

    Offline alvm

    • ***
    • 116
  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #122 on: 21 / January / 2011, 03:34:21 »
    Free mem for sx130 after shoot in PB mode is about 40 kb.  
    This is our main problem with sx130. You do not even have to take a shoot. Memory disappears when you use (or start in) a playback mode with at least one picture on the SD card.

    I think we need understand a cause of small mem size of heap in PB mode.

    What do we know?

    sx130 and a495 have approximately equal size of CHDK/free mem but a495 works fine against sx130.

    The cause can be:

    1. CHDK mem leakage;
    2. Canon mem leakage;
    3. Canon f/w put anything into heap.

    I'm going to compare dump sx130 and a495 for understanding n2,3. If canon firmware is the same for both cams the cause of mem leakage is sx130 platform-depend part of CHDK.
    « Last Edit: 21 / January / 2011, 03:37:01 by alvm »

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #123 on: 21 / January / 2011, 17:35:53 »
    Still I can't understand what is the patch for, since without it the CHDK wokrs fine (on mine sx130is). I had a lot of images and one movie on SD (8GB), run in playback mode and any crash wasn't seen. Everything works fine without using the patch. The patch looks useless for me.

    Is this helpfull for you? I like to help, if I can.

    PS. What's wrong with the forum? It works very slowly and looks like there's no css.
    « Last Edit: 22 / January / 2011, 03:45:00 by outslider »
    if (2*b || !2*b) {
        cout<<question
    }

    Compile error: poor Yorick


  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #124 on: 25 / January / 2011, 03:22:39 »
    I think (I'm not sure) the patch adds support for scripting, which currently is not included in the CHDK for the SX130IS (because problems occur when it is included.)

    Scripts can add a lot of functionality, and are a part of why CHDK is so popular.
    For me the most important option is AEB (Auto Exposure Bracketing)....  but there are others I find useful too.

    *

    Offline quid

    • **
    • 67
    • SX130IS
  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #125 on: 25 / January / 2011, 03:37:10 »
    If you are talking about .patch file from my posts, you don't need it to run CHDK on camera. This file contains changes to source code needed to compile CHDK for sx130.

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #126 on: 25 / January / 2011, 04:40:41 »
    @Quid - ok, I understand now, thx for the explnanation and all the things you've done for sx130 support!
    if (2*b || !2*b) {
        cout<<question
    }

    Compile error: poor Yorick

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #127 on: 25 / January / 2011, 05:12:19 »
    hello, congratulations for the work with this camera! I will update my firmware to version 1.01c I have the version 1.00b now. I have read here that works ok in 1.01c.
    thanks for the effort in this.  :D


  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #128 on: 25 / January / 2011, 11:08:52 »
    So is it just me, or is custom auto ISO not working at all? With CHDK active, ISO set to auto, and custom auto ISO turned on, it doesn't seem to be making any attempt to respect the custom shutter speed threshold, and performance is extremely similar to the camera's normal auto ISO behavior without CHDK.

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #129 on: 25 / January / 2011, 15:17:14 »
    can chdk get around the 10:00 min limit on hd video? other than that no problems with it

     

    Related Topics