Chdk for SX130 IS ? - page 18 - CHDK Releases - CHDK Forum

Chdk for SX130 IS ?

  • 1094 Replies
  • 250286 Views
*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #170 on: 03 / February / 2011, 21:55:14 »
Advertisements
@quid - If it's not too much trouble, when you are compiling the newest release, could you enable scripting?  In ofher words, two zips, one with and one without scripting?

If it's a hassle, I understand, but I don't really know how much work is involved removing/re-adding script capabilities, so I have to ask.  Even though the camera does crash with pictures on it when you load a script, I don't mind unloading the pics to re-load a different script, and I'd like to see what's different in the newer compiliations.
Don't let the sands of time get in your lunch.

Re: Chdk for SX130 IS ?
« Reply #171 on: 04 / February / 2011, 13:46:22 »
@whim: You're right, I will report this.

@Vash11779: This is source code patch. If you don't have any experience with compiling open source software from source code, then I suggest you to wait for next binary. Some basic instructions are available here: http://chdk.wikia.com/wiki/Compiling_CHDK_under_Windows

@elpols: Wow, why do you want to use camera like this for sound recording? I think there are devices much better for this task?

okay i will wait for the binary, but i have one question is the CHDK from post #136 good to go without the patch or does it have to be applied for those changes to be included

*

Offline whim

  • ******
  • 2013
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Chdk for SX130 IS ?
« Reply #172 on: 04 / February / 2011, 14:04:57 »
@Vash11779

As quid says in post #164:
Quote
This patch will be included in my next build. I'm going to do it this weekend. I suggest to use English language until then.

*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #173 on: 05 / February / 2011, 15:52:22 »
New version changes:
- USB Remote Cable should work now (not tested much)
- Corrected DNG active area to correspond JPEG area
- fixed crash in Memory Info message box for German and Polish languages.

Requested special version with scripts enabled, AKA Crash Will Happen (not recommended for daily use):
http://www.megaupload.com/?d=07A2YTSR




*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #174 on: 06 / February / 2011, 07:20:37 »
Memory info taken in playback mode using Canon Script, without CHDK loaded:

Without pictures on card:
Code: [Select]
Malloc Information (onetime type)
  Start Address       = 0x00166218
  End Address         = 0x002f1de0
  Total Size          = 0x0018bbc8 (  1620936)
  Allocated Size      = 0x0011cbf8 (  1166328)
  Allocated Peak      = 0x0012ef20 (  1240864)
  Allocated Count     = 0x00000734 (     1844)
  Free Size           = 0x0006efd0 (   454608)
  Free Block Max Size = 0x0006d090 (   446608)
  Free Block Count    = 0x00000002 (        2)

With pictures on card:
Code: [Select]
Malloc Information (onetime type)
  Start Address       = 0x00166218
  End Address         = 0x002f1de0
  Total Size          = 0x0018bbc8 (  1620936)
  Allocated Size      = 0x00144510 (  1328400)
  Allocated Peak      = 0x00156838 (  1402936)
  Allocated Count     = 0x00000745 (     1861)
  Free Size           = 0x000476b8 (   292536)
  Free Block Max Size = 0x000467b8 (   288696)
  Free Block Count    = 0x00000002 (        2)

I think we can now exclude CHDK bug, as a reason for small free memory size in the playback mode.

Re: Chdk for SX130 IS ?
« Reply #175 on: 06 / February / 2011, 15:23:15 »
@quid

Hi - what's the problem with scripts? Am I right - CHDK crashes while some pictures on SD? I've used your lastest CHDK (with scripts enabled). I've got a lot pictures on SD, a few movies and one very laaarge file (I have more place on SD than on my hard drive;p). Nevertheless, everything works fine. Now I'm runing scripts and it's working.

I saw more - when I've copied cfg file from previous version (to save my settings) the camera crashes very often, trying to do almost anything. But without cfg there is no crash.

Forgive me, if I don't understand, what's the problem, but for me this realase works fine, excluding my settlings. I'll play around, maybe I'll find more informations.

I still load CHDK through Firm Update, the script I ran is just serial shotting, now camera is shotting a serie of 30 pictures.

Once again - thank you for your job, it's still more and more excelent!
« Last Edit: 06 / February / 2011, 15:27:58 by outslider »
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #176 on: 06 / February / 2011, 15:35:49 »
This was discussed earlier in this thread: When you switch to (or start in) playback mode, free memory drops to about 20-40kB. This memory is not released when you switch back to shooting mode, and camera will crash next time when additional memory is needed (for example during saving to DNG). Disabling scripting gives us about 100kB of additional free memory, and camera behaves (almost) correctly.

Re: Chdk for SX130 IS ?
« Reply #177 on: 06 / February / 2011, 17:26:55 »
Hello guys!
Ive downloaded and installed the latest CHDK version from the sx130is-101c-0.9.9-1054-1-full.zip file.
I upgraded the original camera firmware, and followed every instruction in the process.
I made CHDK to load automatically every start (boot).
My experiences are:
1. When I turn the camera on with its on/off button, it always starts in picture view (play) mode.
2. When i enabled the raw format, and dng extension, after every shot it crashes (turn off automatically, without retracting the lenses (it makes the dng, but not the jpeg).
3. When i set the continuous mode to Tv or Av, it doesnt take pictures according to this setting. Sometimes it makes 1 picture with different setings, but the rest are made with the same setting.


*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #178 on: 06 / February / 2011, 17:49:31 »
1. Known limitation of CHDK - hold on/off key for about 1s to start in shooting mode.
2. Known bug in sx130 port - don't use edge overlay when you start in playback mode.
3. Works fine for me, what exact settings do you use?

Re: Chdk for SX130 IS ?
« Reply #179 on: 06 / February / 2011, 19:01:24 »
New version changes:
- USB Remote Cable should work now (not tested much)
- Corrected DNG active area to correspond JPEG area
- fixed crash in Memory Info message box for German and Polish languages.
@quid: I'd say USB remote works. At least camera won't switch to playback mode when I connect it with the computer, but both, PS remote and RemoteCapture are not able to connect to camera. Am I doing something wrong? (this is my first expirience with CHDK  ::) )

 

Related Topics