Chdk for SX130 IS ? - page 19 - CHDK Releases - CHDK Forum

Chdk for SX130 IS ?

  • 1095 Replies
  • 266146 Views
*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #180 on: 06 / February / 2011, 22:32:20 »
Advertisements
Thanks for the additional build quid.  

I've loaded the newest build with scripting enabled and aside from a few minor problems, and NOT USING RAW OR DNG, the latest build has freed up an additional ~9k of memory, which is just enough to load and reload scripts with pics on camera.  The camera crashed once or twice, but I can't rule out battery death, and once I restarted it, I could reload chdk and start where I left off (until the batteries died again).

I haven't unloaded any pics, and can continue to use and load chdk, and switch between fast motion and ultra intervalometer with no problems.  (I kept track of the memory usage using the chdk memory info here and there during my picure taking if it might help.. no pics.. one pic.. 3 pics.. 3 pics and movie, 3 pics 2 movies, 6 pics 2 movies, bunch'o pics 5 movies.. scripting still works!)

Keep on rocking quid.. I can't wait until it's done!

As an aside, I'll be building a remote usb cable tomorrow, and should be getting a power supply in the mail in the next few days.  If there's anything I can test for you, I'd love to help somehow.

EDIT -- I just finished building and testing my new USB remote trigger. I used a little LED flashlight with 3 button cells and left both ends on the USB cable just in case.  It works great with this build, and triggers as expected.  (for the first batch of pics anyway!) I haven't had this much camera functionality in a long time, and I'm psyched.
« Last Edit: 07 / February / 2011, 00:53:14 by achillies »
Don't let the sands of time get in your lunch.

*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #181 on: 07 / February / 2011, 01:48:22 »
@nobody460: USB Remote Cable functionality is not meant for programs like PSRemote, but for the cable described on this page: http://chdk.wikia.com/wiki/USB_Remote_Cable

Re: Chdk for SX130 IS ?
« Reply #182 on: 07 / February / 2011, 02:00:53 »
Thanks for the fast answers quid!

1. Solved, with the 1 sec hold. Thnx!
2. Seems to be solved too, i think due to point 1. Thnx!
3. Dont have time now for another test, but i will do that too. A question about it: does the camera save theese bracketing images into the same folder where the original continuous images are?

Re: Chdk for SX130 IS ?
« Reply #183 on: 07 / February / 2011, 05:30:47 »
@nobody460: USB Remote Cable functionality is not meant for programs like PSRemote, but for the cable described on this page: http://chdk.wikia.com/wiki/USB_Remote_Cable
@quid: Thanx for the explanation. Is there a way to make SX 130 IS work with this kind of programs?


*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #184 on: 07 / February / 2011, 13:49:34 »
@CanonPeter: Yes, bracketing images should be in the same folder.

@nobody460: Not with PSRemote or RemoteCapture, but maybe with ptpcam from CHDKDE. It is very small chance that this will work with SX130 without source code modifications, and it's low on my priority list, but if you want it very badly, you can always try yourself to make necessary changes.

*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #185 on: 07 / February / 2011, 14:22:39 »
OK guys, I need some help from you. I've build a special version of CHDK, with additional test enabled. When you start it, you will see a small "OK" text on a left side of the screen.
I need you to use your camera as usual, or try to use all features - but watch if "OK" text changes to some numbers. In that case write down these numbers, restart camera and try to repeat last thing before change. After that send me message with these numbers and information what were you doing.
Focus on camera's builtin features. Features added by CHDK are secondary in this test.
If after tests there is still message "OK" on screen, send me a message too, so I know how many users performed this test.

Script users - I need CHDK as stable as possible, so there is no script version this time.

Re: Chdk for SX130 IS ?
« Reply #186 on: 07 / February / 2011, 17:33:44 »
@quid: OK I downloaded it, an I'll do some tests for you. (I'm also a programmer, although not for embedded systems, but I know how it helps when I have somebody to test... :) )

and for the issue with remote capture... I check out complete sources of CHDK from svn (https://tools.assembla.com/svn/chdk) but there is nothing about SX130 IS. Are alpha sources somewhere else? I guess I'll need your's sources and there I'll try to add ptp support. Right?

*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #187 on: 07 / February / 2011, 19:04:55 »
I've been running it all day and had no problems (no scripting).  I've saved RAW files, DNG files, used the remote functions** and taken more than a hundred pictures of different walls from different angles! So far no problems that might help (if that makes sense).

**USB remote problem NOT RELATED TO CHDK BUILD.  Can anyone reproduce this:  When using my USB remote I get no flash while only using Canon settings (no chdk running).  The remote triggers the shutter, but no flash regardless of settings (manual-flash always on etc.. ).  IF I load CHDK, and use the "extra photo settings" and "force manual flash", the flash operates as expected.  Anyone?

EDIT - QUID, if there's anything specific that I can test to force failure (or success), let me know, But I suspect that my current usage may not find the problems you're tracking.
« Last Edit: 07 / February / 2011, 19:09:43 by achillies »
Don't let the sands of time get in your lunch.


Re: Chdk for SX130 IS ?
« Reply #188 on: 07 / February / 2011, 19:31:04 »
@quid:
 ok I've been using the latest version but I have found bugs in the functions is currently enabled, the trigger usb not tried it yet (I have not done) but I'll use your latest version of debugging so you have accurate information how it works.
sorry for my bad English.

Re: Chdk for SX130 IS ?
« Reply #189 on: 08 / February / 2011, 00:28:00 »
@quid:

I've used the camera as usual, and tested some CHDK features like DNG RAW, bracketing and histogram. The OK text has never changed and I haven't got any problems so far, everything seems to work perfectly (like with previous no script-enabled releases).

The only problem I have is with auto boot at start. I have to start the camera in playback mode or it will hang at boot.

Thanks for your hard work!

 

Related Topics