Chdk for SX130 IS ? - page 33 - CHDK Releases - CHDK Forum
supplierdeeply

Chdk for SX130 IS ?

  • 1095 Replies
  • 265896 Views
Re: Chdk for SX130 IS ?
« Reply #320 on: 16 / March / 2011, 05:41:15 »
Advertisements
Thanks for this development!
I've bought a new SX130 and it had two hot pixels. I've removed them with CHDK.
It's working OK!

*

Offline quid

  • **
  • 67
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #321 on: 17 / March / 2011, 16:57:18 »
I think I can confirm, that there is a problem with SX130IS. My camera just returned from service center after second repair of "Lens error".
First time I've blamed crash when camera was retracting it's lens (I was testing something and camera was crashing a lot), but second time camera crashed when I was just using memory browser with extended lens. Both times camera retracted it's lens normally on next start, but could not extend it again.

Unfortunately, I don't have any idea what could be a cause for this problem and now I'm not so eager to do any further development on this camera.

*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #322 on: 17 / March / 2011, 19:53:17 »
I think I can confirm, that there is a problem with SX130IS. My camera just returned from service center after second repair of "Lens error".
First time I've blamed crash when camera was retracting it's lens (I was testing something and camera was crashing a lot), but second time camera crashed when I was just using memory browser with extended lens. Both times camera retracted it's lens normally on next start, but could not extend it again.

Unfortunately, I don't have any idea what could be a cause for this problem and now I'm not so eager to do any further development on this camera.

I was wondering where you went!  That is really unfortunate (and absolutely understandable why you're not so eager).  The service center didn't tell you what caused the error?  I had read that it was caused by dirt/dust in the mechanism, and as often as my camera gets turned on and off during testing things (probably at least 50x more than an average user) I could see that happening.  I  am really anxious to hear more.  BTW, if I had an extra sx130is, you'd be the first one to get it, because I appreciate your work that much.

I am currently using build 1082, patched with your changes, and have now taken over 1650 pictures - all but 50 have been taken using CHDK.  I hope this gets resolved!  Everyone.. please post comments and thoughts.
Don't let the sands of time get in your lunch.

Re: Chdk for SX130 IS ?
« Reply #323 on: 17 / March / 2011, 20:47:31 »
sorry to hear the news quid, if it helps i had the same prob with eariler builds of CHDK mostly before the partion bug was fixed all cars <4 worked fine but moment i tried a >4 gb it crashed and got a lens error till the bug was fixed and camera was repaired sad though you were one of the main devs for this and i was looking forward to the stuff yet to come but thank so much your work thus far

though mine has crashed a few times with the lens open or right after it turned on and never got the lens error worse that happened was the batterys gave out and a script was running but changing the batterys solved that one

also if u google lens error there are some DIY fixes im not sure if theres any for this model but some do require taking it apart yourself or doing certain things i doubt they'll work though thought itd be worth mentioning
« Last Edit: 17 / March / 2011, 21:01:03 by Vash11779 »


*

Offline reyalp

  • ******
  • 12208
Re: Chdk for SX130 IS ?
« Reply #324 on: 18 / March / 2011, 00:09:35 »
I think I can confirm, that there is a problem with SX130IS. My camera just returned from service center after second repair of "Lens error".
First time I've blamed crash when camera was retracting it's lens (I was testing something and camera was crashing a lot), but second time camera crashed when I was just using memory browser with extended lens. Both times camera retracted it's lens normally on next start, but could not extend it again.

Unfortunately, I don't have any idea what could be a cause for this problem and now I'm not so eager to do any further development on this camera.
I've added this to http://chdk.wikia.com/wiki/Camera_failures_suspected_to_be_caused_by_CHDK and also the sx130 page.

If shutting down with the lens extended is actually the cause, this seems like a rather bad design error on Canons part, as there are plenty of ways this could happen even without CHDK. Canons own crash handler code does this...

Many of us have subjected other models to the same thing dozens or hundreds of times without any obvious ill effect.

That said, the possibility of a fault like this cannot be excluded.

It is also possible that the lens mechanism has weakness unrelated to CHDK. If you get further lens error without using CHDK, please let us know.
Don't forget what the H stands for.

*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #325 on: 18 / March / 2011, 01:42:47 »
It is also possible that the lens mechanism has weakness unrelated to CHDK.

This is not one of canons more expensive models, although it has quite a few really nice features.  They had to keep the price down somehow, and I wonder if these lens error problems are related to that.  But I guess facts rather than speculation (on my part) would be a good idea.
Don't let the sands of time get in your lunch.

Re: Chdk for SX130 IS ?
« Reply #326 on: 18 / March / 2011, 02:36:25 »
i have a question to chdk developers:

can you make "lite" build, without access to lens or something mechanical? as far as i know, users mostly use chdk for raw.

personally to me meanwhile it will be enough.

Re: Chdk for SX130 IS ?
« Reply #327 on: 18 / March / 2011, 03:35:40 »
i have a question to chdk developers:

can you make "lite" build, without access to lens or something mechanical? as far as i know, users mostly use chdk for raw.

personally to me meanwhile it will be enough.

I think it could be a good idea. Maybe an option to deactivate any mechanical access to avoid any physical malfunction?


Re: Chdk for SX130 IS ?
« Reply #328 on: 18 / March / 2011, 07:12:09 »
then if I put the 12x zoom and turn off the camera when turn on happens? or if it hits the lens being extended?, I never had that error in the camera without or with CHDK.

we need to know if a lot of cameras in particular (as the failure of HD video audio) or if all have the defect of the lens they say


I'll settle for at least that can be used Raw, long exposure, bracketing, and some motion detection script.



Re: Chdk for SX130 IS ?
« Reply #329 on: 18 / March / 2011, 12:26:49 »
the lens errors has a variety of causes from when i researched when i had a lens error some of the stories where the person dropped the camera while the lens was extended, others are dust or sand from beachs get in the motor and stop it (however there are some guides on how to take apart the cameras and remove the obstruction) others where they had camera for awhile and simply gave them the error when they tryed to turn it on, sadly i dont think theres a work around for it you just have be careful with the camera and hope it never happens to you

one more cause ive heard is the camera was being carried in a bag or tight space and got turned on lens was pushing agaisnt the object and got damaged that way also ive read other brands such as nikkon can get the error as well dont know if its for the same reasons cannon cameras get the error though
« Last Edit: 18 / March / 2011, 13:27:26 by Vash11779 »

 

Related Topics