Chdk for SX130 IS ? - page 56 - CHDK Releases - CHDK Forum supplierdeeply

Chdk for SX130 IS ?

  • 1095 Replies
  • 370633 Views
Re: Chdk for SX130 IS ?
« Reply #550 on: 25 / May / 2011, 04:41:11 »
Advertisements
I have the following questions on chdk on sx130:
1) I like a Tv mode, which when set to for example 1/80th and AutoIso, will go up with the iso from iso80 when it becomes darker (obviously), but in brighter light it will take *shorter times* than 1/80th (note this is different than official Tv mode,
which unfortunately closes the iris (larger F values) in brighter light) Is this possible with chdk?
2) I like to create a own P mode (with script?), which chooses automatically the time and iso (F always full-open), for every measured light value, but a different choice than the official P mode.
« Last Edit: 25 / May / 2011, 05:32:47 by nxuux22 »

Re: Chdk for SX130 IS ?
« Reply #551 on: 26 / May / 2011, 10:46:43 »
I have the following questions on chdk on sx130:
1) I like a Tv mode, which when set to for example 1/80th and AutoIso, will go up with the iso from iso80 when it becomes darker (obviously), but in brighter light it will take *shorter times* than 1/80th (note this is different than official Tv mode,
which unfortunately closes the iris (larger F values) in brighter light) Is this possible with chdk?
2) I like to create a own P mode (with script?), which chooses automatically the time and iso (F always full-open), for every measured light value, but a different choice than the official P mode.


idk if its possible to do that if it is it would have to be by script

Re: Chdk for SX130 IS ?
« Reply #552 on: 26 / May / 2011, 16:27:21 »
Hi everyone.

I have found trouble recording HD vids with the experimental DE (1.1.0) version posted in April.  The video files are corrupt.  It's late and I haven't checked the forums thoroughly, but has anyone else seen this?

The camera can't play back the videos.  I've tested them on VLC as well and they truly are corrupt.  Further when I went back to 0.9.9 the non DE version the problems went away.

I haven't seen any problems with crashing related to the flash - at least not so far, but I'll post anything else I've noticed.

Re: Chdk for SX130 IS ?
« Reply #553 on: 27 / May / 2011, 04:25:37 »
I'm not a developer, but I know, that there were some problems with corupted video files at the begining of this port. If there is a specific way to make corupted video, please, describe all steps. Are there all video files corupted? Or in some special conditions?
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick


Re: Chdk for SX130 IS ?
« Reply #554 on: 29 / May / 2011, 02:49:01 »
All
I'm not a developer, but I know, that there were some problems with corupted video files at the begining of this port. If there is a specific way to make corupted video, please, describe all steps. Are there all video files corupted? Or in some special conditions?

I just had to use the version (1.1.0) I downloaded from this post http://chdk.setepontos.com/index.php?topic=5691.msg65719#msg65719 and the video files were corrupted when recorded as 720p.  I don't know if they were corrupted in any other resolution, but I've repeated it several times.  As soon as I tried the one from the post immediately before that one - the corruption stopped.  I tried a lot of different settings - I even wiped the config file and installed CHDK from scratch, out of the box it corrupts video.  At least for me.

I did notice however that it is MUCH faster at taking Raw photos, even in DNG format it's at least 3x faster than before previous versions.

*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #555 on: 30 / May / 2011, 01:30:06 »
Here is a new build based on the current trunk.  It is a full build with everything enabled.
Don't let the sands of time get in your lunch.

Re: Chdk for SX130 IS ?
« Reply #556 on: 30 / May / 2011, 01:31:15 »
Here is a new build based on the current trunk.  It is a full build with everything enabled.

Thanks, trying it out.

*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #557 on: 30 / May / 2011, 01:32:23 »
@mephistos - try this DE build (if you need the DE build), if it doesn't help I will change some compile options and post a new one for you.
Don't let the sands of time get in your lunch.


*

Offline achillies

  • ***
  • 227
  • SX130IS
Re: Chdk for SX130 IS ?
« Reply #558 on: 30 / May / 2011, 01:49:49 »
Both of these builds are based on the latest trunks, and should fix a DOF calculation error.

**As always, use them at your own risk**, and if you have any trouble please post an explanation of the error, what you were doing, and a romlog.
Don't let the sands of time get in your lunch.

Re: Chdk for SX130 IS ?
« Reply #559 on: 30 / May / 2011, 03:58:16 »
Good Morning,

I have just bought a SX130 and am interested to try Chdk. The firmware version on my camera is GM1.01D.  The 101c Chdk clearly doesn't work and so I was just wondering if there is a Chdk release planned for cameras with the GM1.01D firmware?

 

Related Topics