Chdk for SX130 IS ? - page 78 - CHDK Releases - CHDK Forum  

Chdk for SX130 IS ?

  • 1095 Replies
  • 336518 Views
*

Online philmoz

  • *****
  • 3332
    • Photos
Re: Chdk for SX130 IS ?
« Reply #770 on: 17 / August / 2011, 05:16:50 »
Advertisements
there is an slight opposite effect at the wide side of the zoom - little bit of a barrel distortion - but i think can live with that.

Is the image at the wide end using ptp different than if taken in the camera (is it applying a different amount of correction)?

Can you also test how it works if you use a ubasic or Lua script to zoom and shoot - need to make sure it doesn't break that.

I will update the main code trunk; but the sx130is is not in the autobuild server yet so you will still need to build manually.

A patch with the changes is attached.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: Chdk for SX130 IS ?
« Reply #771 on: 17 / August / 2011, 05:47:32 »
I am having problems with liveview on the SX130is 101c and A650 100d.

As soon as it is enabled, the camera disconnects.

Any idea why ?

@ntstatic

Can you post the various ptp get_video_parameters functions (in \lib.c) you are using for SX130is ?

Re: Chdk for SX130 IS ?
« Reply #772 on: 17 / August / 2011, 06:31:19 »
thank you philimoz - sorry my pc was acting up so the delay -
i will check everything you said and get back in half an hour with the results and the sample pics

and since you mentioned - i think the lens in the SX130 is more like the S series rather than the older SX series (100, 110, 120) - the sx series has only around 22 steps while the s series had ( at least uptill s5 that i know of) around 120 steps which is what the SX 130 has. and therefore the distortion must be like the SX series rather than the S

Re: Chdk for SX130 IS ?
« Reply #773 on: 17 / August / 2011, 06:33:14 »
I am having problems with liveview on the SX130is 101c and A650 100d.

As soon as it is enabled, the camera disconnects.

Any idea why ?

@ntstatic

Can you post the various ptp get_video_parameters functions (in \lib.c) you are using for SX130is ?

i have noted this in the SX 120 and the SX 130. try turning off the continous AF and most probably the problem will go away. have you noticed the hanging problem particularly severe just after the zoom ??


Re: Chdk for SX130 IS ?
« Reply #774 on: 17 / August / 2011, 06:37:14 »
and the parameters are the same as supplied by mweerden. i have hardly made any changes in his patch( just left out the camera specific changes )
still i let you know as soon as i get my machine back up ( working on the notebook for the moment ) - around an hour !

Re: Chdk for SX130 IS ?
« Reply #775 on: 17 / August / 2011, 07:08:45 »
Thanks.

Where is mweerden's patched copy ?

Don't see anything on CHDKDE CS685


Re: Chdk for SX130 IS ?
« Reply #776 on: 17 / August / 2011, 08:09:37 »
here is mweerden's patched copy for trunk 685
remember this does not have phil's patch for the pincushion distortion applied yet
(still testing phils patch !)

http://www.megaupload.com/?d=YDS8CIDY
sx130is-101c-1.1.0-r685-full

didnt know where to upload so using megaupload - hope thats not a problem on this fourm

Re: Chdk for SX130 IS ?
« Reply #777 on: 17 / August / 2011, 08:19:20 »
Thanks, I will download in one hour after my 45 minute brisk walk !


David


Re: Chdk for SX130 IS ?
« Reply #778 on: 17 / August / 2011, 11:34:33 »
Thanks, I will download in one hour

and maybe not as the forum was down for hours.

At Megaupload the file is temporarily unavailable !

Re: Chdk for SX130 IS ?
« Reply #779 on: 18 / August / 2011, 02:04:30 »
ok have merged mweerden and phil's patch to the current DE build 755 and it works beautifully on my firmware 101F
i dont think there should be an issue with any other firmware so here is the binary for 101c

http://www.megaupload.com/?d=6YQHWSQR
sx130is-101c-1.1.0-r755-20-full

hope i am doing this right ! or is there a better way to attach the file ?!

the forum was down yesterday as was my pc - bad RAM i think - was not able to thoroughly test phil's patch but everything looks ok.

and yes phil, the slight barrel distortion which i mentioned is present in the regular (button pressed) shots too at wide angle. so the patch is ok.
was not able to check the same with running a script on the camera (never ran a script on a camera, only ptp - but its about time :) ) - but i would hope it will be ok ( isnt ptp actually running lua when performing those functions ?? )

 

Related Topics