supplierdeeply

Chdk for SX130 IS ?

  • 1094 Replies
  • 177670 Views
  • Publish
    Re: Chdk for SX130 IS
    « Reply #90 on: 10 / January / 2011, 19:46:42 »
    Advertisements
     8)
    Great to hear progress is being made! I loved CHDK with my old A590, can't wait to do some crazy stuff with the SX130IS!

    Thanks for the work, folks.

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #91 on: 11 / January / 2011, 01:30:06 »
    hi, niwang,

    Sure, reply#85 works though it's not stable.

    Two things to download: sx130is-101c-0.9.9.zip in reply#85 and CardTricks if you're under Windows.

    Follow the instructions at http://chdk.wikia.com/wiki/CHDK_for_Dummies#I_have_my_camera_already.21

    hello! i'm new here and i am slowly trying to understand everything posted on this thread.

    i just want to clarify, is there a working chdk for sx130? and how do i use/install it?

    thanks in advance :)

    thanks for your reply! i did what you told me to do but when i loaded the SD Card on my camera and went to the Firm Update, the camera just turned off. i don't know what im doing wrong :(

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #92 on: 11 / January / 2011, 03:42:37 »
    I had the same problem, but I fixed it. I assume you have an old version of firmware on your camera. The people in this thread are making CHDK for firmware 1.01C    I used to have 1.00B installed until I went to the Canon website and installed the latest firmware.... now I have 1.01C.... and CHDK now works fine.
    Unlike CHDK... the firmware update on the Canon website is permanent.

    PS:  I love you guys!  I am so happy with what has been implemented so far... even if it is never fully finished, this temporary version of CHDK has already greatly improved my SX-130IS :)   Keep up the good work.    :xmas
    « Last Edit: 11 / January / 2011, 05:16:04 by Mr_Speedy »

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #93 on: 11 / January / 2011, 08:44:32 »
    oh..is this the firmware update http://web.canon.jp/imaging/dcp/firm-e/pssx130is/index.html i should install?

    thanks! :) ill try again once ive updated.


  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #94 on: 11 / January / 2011, 14:57:24 »
    That is the firmware I installed on my camera, and it works fine.
    I have no idea if it will be fine on your camera too... I assume it will be, but you are the one who has to make the decision / take the risk.

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #95 on: 12 / January / 2011, 11:43:29 »
    I have a 1.01c firmware SX130. Today I put CHDK on my SD 4GB with files downloaded in reply #85 and my cam booted up fine, running most features including taking RAW picture. However when I want to use the DNG format, I couldnt access the scripting parameter using PRINT + FUNC combo as instructed. Is there anything I must do/install/download in order to run the badpixel.lua script (I also downloaded the file badpixel.lua manually and put it in folder SCRIPTS/TEST/ but just could find a way to run)?

    *

    Offline quid

    • **
    • 67
    • SX130IS
  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #96 on: 12 / January / 2011, 12:00:04 »
    As I wrote in reply #85, scripting is completely disabled in this build. Instead of running script badpixel.lua, you should use "Create badpixel.bin" in "RAW parameters" menu.
    Unfortunately there is a bug in this build: After using that command, you have to put SD card in a computer and manually rename file bad_tmp.bin in CHDK folder to badpixel.bin

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #97 on: 12 / January / 2011, 12:50:38 »
    Yeah after lots of trials I finally found myself renaming it like u said, and I can enable the DNG option. Now everytime I take a picture the camera just shut down and the picture could not be saved. Another notice is the speed of which CHDK wears down my Eneloops. Normally i can use the cam for more than 300 pics before having to swap, now maybe it lasts for a couple of hours only. Any comment on that?


    *

    Offline quid

    • **
    • 67
    • SX130IS
  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #98 on: 12 / January / 2011, 13:09:49 »
    I think this FAQ entry is a good explanation of battery life :)
    http://chdk.wikia.com/wiki/FAQ#Q._Does_the_CHDK_program_consume_additional_battery_power.3F

    Which method of starting CHDK (Firm Update or automatic start) you are using? How many photos do you have on SD card?

  • Publish
    Re: Chdk for SX130 IS ?
    « Reply #99 on: 12 / January / 2011, 21:36:15 »
    Thanks quid, for the battery link.

    What i did was creating a bootable, formatted SD card using CardTricks, then install the CHDK ver attached on your post. Locked the card, put on cam, turn on then i see CHDK interface immediately. Then I press Alt, Menu -> Raw parameters, create bin file, rename it to badpixel.bin, enabled DNG format and extension. When I take a picture, however, the camera just shut down right away. There has been only few pictures on my SD card.
    « Last Edit: 12 / January / 2011, 21:38:25 by kyuuan »

     

    Related Topics